Jump to content


Replying to Setting Up 3DS MAX 7,8,9 and 2008


Post Options

    • Can't make it out? Click here to generate a new image

  or Cancel


Topic Summary

Kekoulis

Posted 06 October 2019 - 08:36 AM

I made a new fire animation for the thunderfire cannon and for some reason the tracks no longer move ingame even though they do in the OE. I've been comparing it with the vanilla chimera and can't figure out why it doesn't work.

 

maybe this is relevant, from the whe burn log

 

00:38:41.55   BURNER_0 started at 2019-10-06 00:38
00:38:41.55   OS NT 6.1, 0MB Physical Memory
00:38:41.55   RUN-OPTIONS
00:38:41.55   WORKING-DIR C:\Program Files (x86)\THQ\Dawn of War - Dark Crusade\ModTools
00:38:41.55   USER Admin
00:38:41.55   
00:38:41.55   SPOOGE - Driver[Null] on adapter[1146909548], version[4,32]
00:38:41.57   'troops': WARNING -- Motion 'idle_aim_horiz_right' has an absolute modifier, has events, and does not ignore transitions -- it may skip events!
00:38:41.57   'troops': WARNING -- Motion 'idle_aim_vert_right' has an absolute modifier, has events, and does not ignore transitions -- it may skip events!
00:38:41.58   
Application closed without errors

Replied to the other thread.

Better please to keep this thread clean as it is meant for setting up MAX.Not questions for actual MAX use.Instead use your other thread.I follow it as well.


Moreartillery

Posted 06 October 2019 - 08:27 AM

I made a new fire animation for the thunderfire cannon and for some reason the tracks no longer move ingame even though they do in the OE. I've been comparing it with the vanilla chimera and can't figure out why it doesn't work.

 

maybe this is relevant, from the whe burn log

 

00:38:41.55   BURNER_0 started at 2019-10-06 00:38
00:38:41.55   OS NT 6.1, 0MB Physical Memory
00:38:41.55   RUN-OPTIONS
00:38:41.55   WORKING-DIR C:\Program Files (x86)\THQ\Dawn of War - Dark Crusade\ModTools
00:38:41.55   USER Admin
00:38:41.55   
00:38:41.55   SPOOGE - Driver[Null] on adapter[1146909548], version[4,32]
00:38:41.57   'troops': WARNING -- Motion 'idle_aim_horiz_right' has an absolute modifier, has events, and does not ignore transitions -- it may skip events!
00:38:41.57   'troops': WARNING -- Motion 'idle_aim_vert_right' has an absolute modifier, has events, and does not ignore transitions -- it may skip events!
00:38:41.58   
Application closed without errors


Kekoulis

Posted 27 September 2019 - 12:15 PM

 

 

 

 

 

 

Install the mod tools in Dawn of War Dark Crusade.

The mod tools were created based on Dark Crusade,not Soulstorm.However,any model you produce with them,can be used in Soulstorm just fine.

 

I tried that and got the same error again.

 

Do you actually have Dark Crusade installed?

 

In addition,the mod tools are hard coded to use this directory:
C:\Program Files (x86)\THQ\Dawn of War Dark Crusade\ModTools

Make sure you have it such.

Lastly,make sure you have installed everything.Re-install if necessary.

 

I'm not sure if it's because I copied/pasted from my old computer instead of installing, but the mod tools I'm using work fine outside of that directory I have all my Dawn of War folders in "C:/users/Public/Programs/steam/steamapps/common//" and haven't had any issues, my models even export from an XP virtual machine to my dawn of war folder treating it as a shared network folder (had to that since for some reason Max crashes the display driver on this computer unless I run it in a vm)

 

Then the gods were by your side then.

I always had issues with MAX 2008 concerning the file path.And many other people as well.

Also,I am not using a virtual machine for this.I am running in Win10 Pro with compatibility setting and works just fine.

Same with all modtools,provided they are in their file paths.

 

But of course,if it works on your end,all ok. :)


EzArIk

Posted 27 September 2019 - 10:45 AM

 

 

 

 

 

Install the mod tools in Dawn of War Dark Crusade.

The mod tools were created based on Dark Crusade,not Soulstorm.However,any model you produce with them,can be used in Soulstorm just fine.

 

I tried that and got the same error again.

 

Do you actually have Dark Crusade installed?

 

In addition,the mod tools are hard coded to use this directory:
C:\Program Files (x86)\THQ\Dawn of War Dark Crusade\ModTools

Make sure you have it such.

Lastly,make sure you have installed everything.Re-install if necessary.

 

I'm not sure if it's because I copied/pasted from my old computer instead of installing, but the mod tools I'm using work fine outside of that directory I have all my Dawn of War folders in "C:/users/Public/Programs/steam/steamapps/common//" and haven't had any issues, my models even export from an XP virtual machine to my dawn of war folder treating it as a shared network folder (had to that since for some reason Max crashes the display driver on this computer unless I run it in a vm)


Kekoulis

Posted 16 September 2019 - 09:07 PM

 

Only if you force invisibility on that part(meaning,you will have to detach the surface you want to make invisible as its own mesh)

Wouldn't that make it transparent from both directions? What I need is the opposite of backface culling, so the object is invisible from the outside but visible from the inside.

 

Well,you can't do that with the DOW Engine.

 

It is limited on this.

 

You have to get creative.

Either delete the vertices from the one side or flip the vertices of that part.
Depends on the mesh you are working on.


Moreartillery

Posted 16 September 2019 - 08:46 PM

Only if you force invisibility on that part(meaning,you will have to detach the surface you want to make invisible as its own mesh)

Wouldn't that make it transparent from both directions? What I need is the opposite of backface culling, so the object is invisible from the outside but visible from the inside.


Kekoulis

Posted 16 September 2019 - 10:32 AM

Only if you force invisibility on that part(meaning,you will have to detach the surface you want to make invisible as its own mesh) or use an opacity layer in the rsh if you want it transparent.


Moreartillery

Posted 16 September 2019 - 10:09 AM

Is there a way to make a surface invisible from only one direction? I want to make a roof object for maps that is invisible from the top but can be seen when the camera zooms down to infantry level.


Kaos_Crusader

Posted 30 July 2019 - 09:59 PM

Not only that,aims can be borked sometimes even with TCB.

 

Well... I did not know that. I just don't play enough with TCB   :smilehuh:

 

 

The reason why TCB is recommended on the guide is because it is easier to rotate in the ref scene and it is less likely you will get misplaced meshes in the ref file during import.

 

Well, they are points of view. I use MAX 7 and I never got problems with misplaced meshes. If instead with bad aims and corrupt animations. In reality everything depends on what is being imported; there are cases of units such as the space marine vanilla that is smooth and friendly to edit without problems, and others like the ork slugga where every damn time I get vertex errors and I have to apply the Fix Skin.


Kekoulis

Posted 30 July 2019 - 09:47 PM

Not only that,aims can be borked sometimes even with TCB.

 

The reason why TCB is recommended on the guide is because it is easier to rotate in the ref scene and it is less likely you will get misplaced meshes in the ref file during import.

 

Long story short.

If the rest of the animations are ok,then you only just have to redo the aims and check if the necessary bones are stale.

In the aims,you only need the animated bone NOT TO be stale.


Review the complete topic (launches new window)