Jump to content


BFME2 Out of sync issue?

  • Please log in to reply
8 replies to this topic

#1 BlueCnut

  • New Members
  • 1 posts

Posted 16 February 2016 - 10:27 PM

So, me and my friends just got everything set up on BFME2, we all got into a lobby just fine and started playing. About 10 minutes into the game we all got a pop up saying the game is out of sync and the game ended. Does anyone know what this issue is or how to fix it?

#2 ICT



  • Veterans
  • 3,075 posts
  •  -- MOC --
  • Division:BFME
  • Job:Online Admin

Posted 17 February 2016 - 07:37 AM

Hey, there are a couple of reasons this can happen. They are all local and not directly related to the server. Things to check:

Did you play a custom map? You have to restart your game after playing certain custom maps.

Did anyone of you install a mod into the game directory?

Did anyone of you modify his game files?

Did you all install the same game files, additional patches/community made content if any?

"To know what question we may reasonably propose is in itself a strong evidence of sagacity or intelligence. For if a question be in itself incongruous and begs for uncalled-for answers, it holds, sometimes, besides embarrassing the proposer, the disadvantage to seduce the unguarded listener into giving absurd answers, and we are presented with the ridiculous spectacle of one (as the ancients said) milking the he-goat, and the other holding a sieve beneath."

#3 The Smoking Man™

The Smoking Man™

    Developer & Composer

  • T3A Staff
  • 113 posts
  • Projects:game.dat, RotWk Patch 2.02 (retired)
  •  Mysterious figure...
  • Division:BFME
  • Job:T3A Staff

Posted 19 February 2016 - 08:36 PM

The OOS issue is mostly due to modified maps or game.dat. If you have extra or modified .ini files (inside .big files) then you will mostly receive a mismatch error and can't join in the first place.

~ Former "Rise of the Witch-king Patch 2.02" Project Coordinator, Developer and Sound Artist (version 5.0.0 & 5.0.1) ~

~ Former GameReplays.org Events Manager, Advisor, Senior Referee (2x), Strategy Specialist (2x) and Replay Reviewer ~

~ Former Clanwars.cc Rise of the Witch-king section Administrator (2x) ~

~ Can't run Rise of the Witch-king on Windows 10 without the CD? Try my No-DVD Maxi-image files! ~


Download The Battle for Middle-earth

Download The Battle for Middle-earth II

Download The Rise of the Witch-king Expansion Pack

#4 dgarbs33922

  • New Members
  • 1 posts

Posted 30 October 2018 - 04:36 AM

I still have this issue today.  I am playing BFME2 ROTWK using the unofficial 2.02 patch.  Everyone else that I am playing with uses the same patch, and multiplayer games crash within the first 15 minutes.  This can happen multiple games in a row, and then we will have a game that can last all the way to the end.  Haven't found any correlation between maps (custom vs official) or individuals playing the game at this point.  Any tips?  We have not tried LAN games, but I was curious if others had the same issue in LAN as well.  

#5 Before

  • Members
  • 189 posts

Posted 22 December 2018 - 04:49 AM

Try this:


Go to %appdata% folder (Windows key + R) -> Roaming (sometimes you're put into this by default) -> My Lord of the Rings (Version here, BFME I, II or RotWK) -> Maps -> Delete MapCache.ini. Make sure all players do this and all players restart their games.


It usually happens after you play a heavily modded map. Other suggestions:

If you're playing RotWK, make sure you all either replaced your game.dat or you all didn't

If you're playing RotWK, make sure you all have the same BFME II patch enabled

If you're playing RotWK, make sure you are all on the same 2.0.2 version (there's v1 through 7 I believe)


Otherwise, yeah. Mods can suck sometimes

#6 Syc12

  • New Members
  • 1 posts

Posted 19 April 2022 - 10:00 PM

i've been trying to play aotr with a friend but in every game after a few seconds the out of synch error pops out and we tried everything but we couldn't fix it. Hope anyone can help me.

#7 sokhrman

  • New Members
  • 1 posts

Posted 12 October 2022 - 12:47 AM

Hey, me and my brother are getting out of Sync issue after 90 seconds of online play. Help! I don't know how to mess with my game.dat file...any help would be appreciated, thanks! 

#8 skleb24

  • New Members
  • 2 posts

Posted 03 February 2024 - 05:59 AM

Having same issue here sadly. I'm on a mac and my two friends are on PC - they can get through a game fine but with me it crashes

#9 _MB_

  • New Members
  • 1 posts

Posted 03 February 2024 - 12:33 PM

Hi, I am also suffering from OOS on BFMEII 1.093. I run the game through wine on Manjaro (arch based Linux distro). OOS happens both on LAN and T3A. Can you suggest how to debug the issue, is there some tool to find out what exactly goes wrong and whether I can fix it? Thanks for replies.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users