Jump to content


Photo

Mental Omega 2.0psi problem


  • Please log in to reply
11 replies to this topic

#1 Dark Chi`

Dark Chi`
  • Members
  • 10 posts
  • Location:Near you....

Posted 29 May 2016 - 08:33 PM

So I came back to Mental Omega 2.0 just for nostalgia reasons and proceeded to follow the instructions of how to install it...
The thing is, when I booted up the game using the launcher, the thing on the bottom right side of the screen says "2.0psi P2 | 1.001" instead of "2.0psi P2 | NPSE"

So I thought, my game folder must have something it didn't want during the installation process so I reinstalled the entire thing (The First Decade Edition ) and redid the installation process...

It still displayed the same problem.. the installation was fresh and did a cleanup just in case something might have snuck into the game folder.

I checked NPatch Manager and it does confirm that "NPatch Special Edition" version "1.05.0022" is installed....

The game works fine really, it's just that Yuri/Epilson is not selectable and the enemy AI spams vans like there's no tomorrow ( This spam goes into a whole new level on Meteor Shower )

Is there any help I could get to get this version to work?


Edited by Dark Chi`, 29 May 2016 - 08:35 PM.


#2 mevitar

mevitar

    (◉ _ ◉)

  • Hosted
  • 1,965 posts
  • Location:your imagination
  • Projects:Doom Desire
  •  :3

Posted 30 May 2016 - 09:37 PM

Wasn't TFD's YR exe edited? NPatch doesn't work with edited exes (i don't know why it tells you that it's installed, though).
ded signature

(◉ ᗝ ◉)

#3 Graion Dilach

Graion Dilach

    Supérior Caliburwielder

  • Project Team
  • 2,187 posts
  • Location:Iszkaszentgyorgy, Hungary
  • Projects:Attacque Superior, OpenRA, Nomad Galaxy, Crystallized Doom, random ORA mod support/voicing
  •  Your favourite proud heretic renegade reaper of the stupid people

Posted 31 May 2016 - 06:30 PM

The TFD YR exe works with NPatch, it was only hexedited to check for the TFD disc instead of the WW one. RP 1.08 was the first such patch with TFD support. I remember having 2.0a broken for months (also hackish in country ordering with PsiCorps staying at it's original place, before some Soviet countries to allow Yuri playable on installs w/o RP support) because of having TFD and 1.08 coming late.

IIRC NPatch only stands from NPatch.mix and gamemd.exe, so I'd rename the former and see what it says then. Although myself I haven't used that thing for a decade.
kuuHd4s.png6pDXsCS.png
n0J1wqE.pngIX8pBXZ.png

AS Discord server: https://discord.gg/7aM7Hm2

ComradeCrimson: AS is the product of Hungarian acid
ComradeCrimson: And magical hussars
Dutchygamer: and Weird Al.


#4 Dark Chi`

Dark Chi`
  • Members
  • 10 posts
  • Location:Near you....

Posted 03 June 2016 - 09:15 AM

So I am not sure about the instruction...

Do I rename both .mix and .exe and find out?



#5 Graion Dilach

Graion Dilach

    Supérior Caliburwielder

  • Project Team
  • 2,187 posts
  • Location:Iszkaszentgyorgy, Hungary
  • Projects:Attacque Superior, OpenRA, Nomad Galaxy, Crystallized Doom, random ORA mod support/voicing
  •  Your favourite proud heretic renegade reaper of the stupid people

Posted 06 June 2016 - 07:27 AM

No, just NPatch.mix then launch the NPatch Manager to see if it reports again itself as installed.
kuuHd4s.png6pDXsCS.png
n0J1wqE.pngIX8pBXZ.png

AS Discord server: https://discord.gg/7aM7Hm2

ComradeCrimson: AS is the product of Hungarian acid
ComradeCrimson: And magical hussars
Dutchygamer: and Weird Al.


#6 Dark Chi`

Dark Chi`
  • Members
  • 10 posts
  • Location:Near you....

Posted 08 June 2016 - 05:31 PM

Yes it still says that it's installed....
Do I do something about it?



#7 mevitar

mevitar

    (◉ _ ◉)

  • Hosted
  • 1,965 posts
  • Location:your imagination
  • Projects:Doom Desire
  •  :3

Posted 18 June 2016 - 06:56 PM

As you might have noticed, none of us knows what might be the issue. :p

Try to uninstall NPatch and install it again. If it's a regular TFD installation, NPatch really shouldn't give you problems...
ded signature

(◉ ᗝ ◉)

#8 Dark Chi`

Dark Chi`
  • Members
  • 10 posts
  • Location:Near you....

Posted 20 June 2016 - 07:44 AM

I uninstalled it and re-installed.... now it says Patch version installed : "4[chinese letter]"
What?



#9 mevitar

mevitar

    (◉ _ ◉)

  • Hosted
  • 1,965 posts
  • Location:your imagination
  • Projects:Doom Desire
  •  :3

Posted 20 June 2016 - 02:56 PM

Do you have a chinese version of TFD (if there is such), or did you have some chinese mod in that directory before?
ded signature

(◉ ᗝ ◉)

#10 Dark Chi`

Dark Chi`
  • Members
  • 10 posts
  • Location:Near you....

Posted 26 June 2016 - 09:37 AM

Everything is in English really....
I have no hope in playing 2.0 do I? xD



#11 mevitar

mevitar

    (◉ _ ◉)

  • Hosted
  • 1,965 posts
  • Location:your imagination
  • Projects:Doom Desire
  •  :3

Posted 27 June 2016 - 10:56 AM

You could try uninstalling YR and RA2, removing their folder (you didn't mention removing the folder last time you reinstalled, so i assume you didn't remove it), then reinstalling and applying NPatch afterwards. If it's a botched installation, leftover files, or a botched exe, it will fix it.
Otherwise, i don't really know what might be the case here...

Edited by mevitar, 27 June 2016 - 11:00 AM.

ded signature

(◉ ᗝ ◉)

#12 Dark Chi`

Dark Chi`
  • Members
  • 10 posts
  • Location:Near you....

Posted 30 June 2016 - 03:35 AM

Tried all things I could do to uninstall it, removing the folder, removing the registry files etc.

Somehow, NPatch that was included in other mods worked perfectly (They were installed with the mod, there wasn't any separate file to install it with)
I also tried copying in the Npatch files plus the exe into the folder I want to play Mental Omega 2.0 with, didn't work...
Tried playing MO 2.0 in the folder where the Npatch worked with other mods, didn't work.

Sad life for me then :(
Thanks for the help though...






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users