Jump to content


Photo

Auto-Capture Outpost Flags, world builder?

flag outpost auto capture signal fire

Best Answer Echo, 02 July 2016 - 04:11 PM

Your initial thought wasn't wrong. Assign the outposts to the player who you want to be the owner. Then use 2 scripts (If you need more help on scripts, let me know). What these scripts do is they force the 'CAPTURED' model condition on named objects, so make sure to give your outposts names (In this case, 'CaptureFlag01', 'CaptureFlag02' and 'CaptureFlag03' are the names of the Helms Deep outposts).

 

Script 1 - initiates the next script after the timer expires. Not sure if this is mandatory but EA used it so I recommend you just stick to their method:

*** IF ***
    True.
*** THEN ***
  Set timer 'FlagTimer' to expire in 1.00 seconds.
Script 2 - auto-captures the outposts for the owner of the objects:
*** IF ***
    Timer 'FlagTimer' has expired.
*** THEN ***
   Unit 'CaptureFlag01' sets model condition ModelCondition State: CAPTURED for 0.00 seconds. Percentage (hordes) 0.00%.
   Unit 'CaptureFlag02' sets model condition ModelCondition State: CAPTURED for 0.00 seconds. Percentage (hordes) 0.00%.
   Unit 'CaptureFlag03' sets model condition ModelCondition State: CAPTURED for 0.00 seconds. Percentage (hordes) 0.00%.
Go to the full post


  • Please log in to reply
6 replies to this topic

#1 Glock18

Glock18
  • Members
  • 5 posts

Posted 02 July 2016 - 06:24 AM

Hello guys at revora!

I'm new here, and actually made an account just to find out if anyone could me with a problem I'm having with world builder. I'm pretty darn sure no tutorial has covered this, and if there is, well pardon me for creating this post!

Here's my issue:

When you play a skirmish on any "stronghold" map (Isengard, Helm's Deep, etc), you'll notice that in your fortress, you spawn with a few Outposts (you know the capture buildings that generate resources). The flags for them are already on your team, and the outposts will generate resources for you without you needing to capture them first.

It's such a nit-pick, but I would love to be able to do this with my maps too. I've tried changing who the building's and flag's belong to, and I've also tried scripting and changing the allegiance of the flags and buildings, but nothing seems to work. The flags always start off white (neutral)... I don't know how the hell to do it. Perhaps the designers of BFME coded the outposts of isengard, in which case it's impossible without modding the game. But I wanted to check if it were possible in world builder.

Thanks guys

-Glock18



#2 MattTheLegoman

MattTheLegoman

    LEGO Knight of Minas Ithil

  • T3A Staff
  • 3,636 posts
  • Location:Tomorrow, when the War began
  • Projects:Mapping this Middle-earth
  •  Mapper
  • Division:BFME
  • Job:T3A Staff

Posted 02 July 2016 - 10:20 AM

Open the map files in Worldbuilder and check out how they did it.

 

Use FinalBig to extract the maps.big file in the game folder.


Remember that all worlds draw to an end and that noble death is a treasure which no one is too poor to buy. - C.S. Lewis

There will come a time when you believe everything is finished. That will be the beginning. - Louis L'Amour

What will matter then will be people. If relationships will matter most then, shouldn't they matter most now? - Max Lucado


#3 Mathijs

Mathijs

    Post-modern Shaman

  • Network Leaders
  • 13,689 posts
  • Projects:Age of the Ring
  • Division:Revora
  • Job:Leader

Posted 02 July 2016 - 03:03 PM

Hey Glock. I can't help you with the issue (other than recommending Matt's solution), but I'd just like to welcome you to the forums.

 

Welcome!


No fuel left for the pilgrims


#4 Echo

Echo

    T3A:Online

  • T3A Staff
  • 1,021 posts
  • Projects:Blue Wizard Mod
  •  yay blue
  • Division:BFME
  • Job:T3A Moderator
  • Donated

Posted 02 July 2016 - 04:11 PM   Best Answer

Your initial thought wasn't wrong. Assign the outposts to the player who you want to be the owner. Then use 2 scripts (If you need more help on scripts, let me know). What these scripts do is they force the 'CAPTURED' model condition on named objects, so make sure to give your outposts names (In this case, 'CaptureFlag01', 'CaptureFlag02' and 'CaptureFlag03' are the names of the Helms Deep outposts).

 

Script 1 - initiates the next script after the timer expires. Not sure if this is mandatory but EA used it so I recommend you just stick to their method:

*** IF ***
    True.
*** THEN ***
  Set timer 'FlagTimer' to expire in 1.00 seconds.
Script 2 - auto-captures the outposts for the owner of the objects:
*** IF ***
    Timer 'FlagTimer' has expired.
*** THEN ***
   Unit 'CaptureFlag01' sets model condition ModelCondition State: CAPTURED for 0.00 seconds. Percentage (hordes) 0.00%.
   Unit 'CaptureFlag02' sets model condition ModelCondition State: CAPTURED for 0.00 seconds. Percentage (hordes) 0.00%.
   Unit 'CaptureFlag03' sets model condition ModelCondition State: CAPTURED for 0.00 seconds. Percentage (hordes) 0.00%.

26285.png


#5 Glock18

Glock18
  • Members
  • 5 posts

Posted 03 July 2016 - 10:56 AM

Thanks for the welcome and replies everyone!

 

 

Open the map files in Worldbuilder and check out how they did it.

 

Use FinalBig to extract the maps.big file in the game folder.

 

I'll try this mate, what's final big though?

 

@Echo

 

This looks like it will work! One thing though, should I set the flags to PlyrNuetral? Or to the player who should own the captured flag?

 

I'll try your solution, but I'm not sure how to deal with the maps.big file.

 

PS. How did you create the name "FlagTimer"? What kind of entity is this?

 

PS. 2. It isn't working :( I followed the scripting exactly, but somethings up. I even messed around with the inital ownership of the flag... Any idea what could be wrong?

 

PS. 3. Wait hang on, actually the outposts are generating resources! But... the flags are still white. That's pretty weird. It's got nothing to do with the scripts though. I just set the outposts to Plyr_1 and they generate resources. The flags don't change though, and I'm not sure if my signal fire works

 

Okay, I've managed to solve the problem. I changed the ownership and script locations to Plyr_1 and it works now! Cheers for the help guys. On a final note, could I find out how you managed to access the Helm's Deep world builder file? If you could link me to some tutorials that would be awesome

 

-Glock18


Edited by Glock18, 03 July 2016 - 12:11 PM.


#6 Echo

Echo

    T3A:Online

  • T3A Staff
  • 1,021 posts
  • Projects:Blue Wizard Mod
  •  yay blue
  • Division:BFME
  • Job:T3A Moderator
  • Donated

Posted 03 July 2016 - 01:19 PM

You're welcome, glad we could help.

 

To open up EA maps, you'll need FinalBIG to extract the .big files: http://wagnerma.de/y...ad.php?detail=1

 

Make sure you store finalbig.exe in the same folder as finalbig.ini. Then double-click finalbig.exe and File->Open Maps.big, which you can find in the EA Games -> The Battle for Middle-earth II folder. Then go to Edit->Extract All and select your desired extract path. Once extracted, go to worldbuilder's Open->Browse function and select the map you want to open. :)


26285.png


#7 Glock18

Glock18
  • Members
  • 5 posts

Posted 03 July 2016 - 03:06 PM

Thanks again bro! Have a nice day







Also tagged with one or more of these keywords: flag, outpost, auto, capture, signal fire

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users