Jump to content


Photo

Texture of model is white ingame


  • Please log in to reply
11 replies to this topic

#1 Easterling26

Easterling26
  • Members
  • 63 posts

Posted 12 August 2016 - 09:51 PM

I saw that there has been something similar related to my problem.

I however could not find the solution for my problem in that topic.

The topic was called Shiny texture I think.

 

My problem is that the texture of my new units are completely white.

I made a screenshot to show the problem.

 

I never had this problem before and I have already made a few new units

for my mod.

 

In W3D viewer everything was fine. I checked several times to be 100 % sure

that everything works.

 

I hope some knows how to fix this without having to remake both units because

it was a huge pain to make them.

Attached Files



#2 Mathijs

Mathijs

    Post-modern Shaman

  • Network Leaders
  • 13,687 posts
  • Projects:Age of the Ring
  • Division:Revora
  • Job:Leader

Posted 12 August 2016 - 09:58 PM

Before tackling your issue, I suggest uploading a screenshot that isn't a BMP file.


No fuel left for the pilgrims


#3 Easterling26

Easterling26
  • Members
  • 63 posts

Posted 12 August 2016 - 11:16 PM

Oh sorry I dont know how that happened.

I cannot upload any pictures right now.

I keep getting Error This upload failed.

 

I will try to make another unit and see what

happens. I might have uploaded too many

pictures already.

 

Usually when there is something missing

ingame the texture should be pink right?

W3D viewer also said that nothing was missing.

Could the problem be in the compiledtextures folder?

Can the game only read the files when they are

in the right folder? For example, the texture for my rangers

is called guranger_gry so this texture should be in compiledtexture_gu

right? Or does it not really matter?



#4 NewErr

NewErr

    Legionary of Doom

  • Project Team
  • 2,169 posts
  • Location:Romania
  • Projects:The RC Mod
  •  World Wide Artist

Posted 13 August 2016 - 05:26 AM

If the texture is missing the model should  be pink, never seen white. But you should check if the texture is in the right place.

It does matter where you place your texture, what you state above is correct and it seems the texture is placed correct. What asset builder are you using? Depending on that you might need to switch folder name from compiledtexture to textures(?). 



#5 ChildrenofBodom

ChildrenofBodom
  • Members
  • 32 posts
  • Location:U.S.A
  • Projects:RiseofTheIronCrownMod

Posted 13 August 2016 - 07:43 AM

I have had this problem before (I posted it here https://forums.revor...-model-problem/ ), and here are your options for solving your problem: 

 

Select each object on your model individually and set it to edible poly, then re-apply the texture to each object.

 

If this does not work, then you can try attaching all the objects into one big mesh; You'll have to re-bind the model if you do the this, and it will be harder to bind as well, but the plus side is the white model bug will disappear (Never saw the bug after I did that). 


Edited by ChildrenofBodom, 13 August 2016 - 08:11 AM.

TricLogoRevora.Jpeg


#6 Easterling26

Easterling26
  • Members
  • 63 posts

Posted 13 August 2016 - 11:28 AM

@NewErr

I am using the asset builder where you have to rename the folder back to compiledtextures.

 

@ChildrenofBodom

Your first suggestion did not work.

I will your other suggestion a try.

I was hoping that I could avoid rebinding the model.

 

Ok I tried your last suggestion and it did work indeed.

I was just a pain to rebind them.

Now all my new rangers have their texture.

 

The only thing that bothers me is that some of them have their house

color some dont. Is there a way how to turn on/off house colors?


Edited by Easterling26, 13 August 2016 - 12:08 PM.


#7 Ganon

Ganon

    What's this?

  • Project Team
  • 967 posts
  • Location:Ohio, United States
  • Projects:My Link Mod
  •  Code Scientist

Posted 13 August 2016 - 08:23 PM

Yes, in gamedata.ini

#8 Easterling26

Easterling26
  • Members
  • 63 posts

Posted 15 August 2016 - 02:15 PM

Thank you for your answer.

 

Could you perhaps give me some more information?

Is there anything specific that I need to look for?

I would really appreciate if you could help me with the housecolors.

 

I think they look rather bad on models.



#9 Rider of Rohan

Rider of Rohan

    The Lazy Modder

  • Division Leaders
  • 1,554 posts
  • Location:The Caribbean
  • Projects:Age of the Ring and the HD Editions
  •  Mathijs' Bug fix expert
  • Division:BFME
  • Job:T3A Leader

Posted 15 August 2016 - 07:17 PM

Look for this line in the gamedata.ini
  EnableHouseColor = Yes
Change Yes to No and it should be disabled.


99dxc486ltde132zg.jpgh5je9noaofg3o26zg.jpg

No parent should have to bury their child - King Theoden


#10 Easterling26

Easterling26
  • Members
  • 63 posts

Posted 15 August 2016 - 09:14 PM

Thank you for your quick answer.

 

I had already found it and I also changed it but all my troops still

have their house colors.

 

I just tried Arnor I did not check the other factions yet.



#11 Rider of Rohan

Rider of Rohan

    The Lazy Modder

  • Division Leaders
  • 1,554 posts
  • Location:The Caribbean
  • Projects:Age of the Ring and the HD Editions
  •  Mathijs' Bug fix expert
  • Division:BFME
  • Job:T3A Leader

Posted 16 August 2016 - 12:46 AM

How is your mod set up? Is it -mod or in the installation folder? 
 


99dxc486ltde132zg.jpgh5je9noaofg3o26zg.jpg

No parent should have to bury their child - King Theoden


#12 Easterling26

Easterling26
  • Members
  • 63 posts

Posted 16 August 2016 - 12:24 PM

Well my mod is in a folder.

 

It does not use the -mod command

I use a shortcut to start my mod.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users