Jump to content


Red Alert 3 Splashscreen freezes when using cnc Launcher

redalert3 launcher

  • Please log in to reply
1 reply to this topic

#1 Astariol

  • New Members
  • 1 posts

Posted 29 October 2016 - 04:13 PM



I am trying to play the Red Alert 3 campaign in Coop-Mode with a frriend. We both installed the CNC Launcher and tried to start the game via Origin.


After I choose theRed Alert 3 Entry from the Addon Chooser, the CNC Launcher is started so the hook seems to be working.

But when I clic "Red Alert 3" in the launcher, the splashscreen will come up and then nothing else will happen.


My friend did the exact same steps and it has worked perfectly for him. He can logon to the CNC Online Servers just fine


The strange thing is we have the exact same System setup and nealry the same hardware....  OS is Windwos 10 Pro with latest updates on both machines.

No additional monitors.



Does anyone have any ideas why one system would freeze the game while the other would not?





#2 ViperMkVII


    What is this?

  • Project Team
  • 1,010 posts
  • Location:Ylati, Anorev
  •  C&C:Online Red Alert 3 Player~

Posted 29 October 2016 - 10:38 PM

Hi, can you please post your Error Log?

You can read this topic if you don't know where to find your Error Log: How to report issues


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users