Jump to content


Photo

MO3.3 SUPPORT // Game or Client Crashes & Launch Issues Megathread


  • Please log in to reply
1225 replies to this topic

#1221 Orklord123

Orklord123
  • New Members
  • 2 posts

Posted 23 June 2019 - 07:11 AM

I got a problem getting the client to launch, everytime the client launches it comes up with "DTA Client has stopped working". I checked the problem details and it came up with this: 

  Problem Event Name: CLR20r3
  Problem Signature 01: clientdx.exe
  Problem Signature 02: 2.2.0.5
  Problem Signature 03: 5b924834
  Problem Signature 04: DTAClient
  Problem Signature 05: 2.2.0.5
  Problem Signature 06: 5b924834
  Problem Signature 07: 517
  Problem Signature 08: 0
  Problem Signature 09: PSZQOADHX1U5ZAHBHOHGHLDGIY4QIXHX
  OS Version: 6.1.7601.2.1.0.256.48
  Locale ID: 1033
  Additional Information 1: 0a9e
  Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
  Additional Information 3: 0a9e
  Additional Information 4: 0a9e372d3b4ad19135b953a78882e789
 
Edit: I also checked my client crash log and it came up with this:
 
24.06. 17:58:38.278    ***Logfile for Mental Omega Client client***
24.06. 17:58:38.294    Client version: 2.2.0.5
24.06. 17:58:38.294    Loading settings.
24.06. 17:58:38.419    Initializing updater.
24.06. 17:58:38.419    Update mirror count: 1
24.06. 17:58:38.419    Running from: clientdx.exe
24.06. 17:58:38.434    Operating system: Microsoft Windows NT 6.1.7601 Service Pack 1
24.06. 17:58:38.434    Selected OS profile: WIN7
24.06. 17:58:38.434    Removing partial custom component downloads.
24.06. 17:58:38.434    Checking for the existence of FinalSun.ini.
24.06. 17:58:38.450    FinalSun settings file exists.
24.06. 17:58:38.715    Writing installation path to the Windows registry.
24.06. 17:58:41.061    Initializing GameClass.
24.06. 17:58:41.076    Hardware info: Intel® Pentium® CPU G3240 @ 3.10GHz (2 cores)  Video controller: NVIDIA GeForce GT 240 
24.06. 17:58:42.090    InitGraphicsMode: 1280x720
24.06. 17:58:43.997    Checking local file versions.
24.06. 17:58:44.006    Loading maps.
24.06. 17:58:49.419    Setting info for MapsmO\Standard\cloudnine failed! Reason: Object reference not set to an instance of an object.
24.06. 18:00:12.181    Attempting to parse INI\Battle.ini to populate mission list.
24.06. 18:00:12.185    File INI\Battle.ini not found. Ignoring.
24.06. 18:00:12.189    Attempting to parse INI\BattleClient.ini to populate mission list.
24.06. 18:00:12.569    Finished parsing INI\BattleClient.ini.
24.06. 18:00:13.533    Skipping reading statistics because the file doesn't exist!
24.06. 18:00:14.261    KABOOOOOOM!!! Info:
24.06. 18:00:14.272    Message: Retrieving the COM class factory for component with CLSID {56FDF344-FD6D-11D0-958A-006097C9A090} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).
24.06. 18:00:14.368    Source: DTAClient
24.06. 18:00:14.372    TargetSite.Name: .ctor
24.06. 18:00:14.394    Stacktrace:    at DTAClient.DXGUI.Generic.TaskbarProgress..ctor()
   at DTAClient.DXGUI.Generic.UpdateWindow.Initialize()
   at Rampastring.XNAUI.XNAControls.XNAControl.AddChildImmediate(XNAControl child)
   at Rampastring.XNAUI.XNAControls.XNAControl.AddChild(XNAControl child)
   at DTAClient.DXGUI.Generic.MainMenuDarkeningPanel.Initialize()
   at Rampastring.XNAUI.XNAControls.XNAControl.AddChildImmediate(XNAControl child)
   at Rampastring.XNAUI.XNAControls.XNAControl.AddChild(XNAControl child)
   at DTAClient.DXGUI.Generic.MainMenu.Initialize()
   at Rampastring.XNAUI.WindowManager.AddAndInitializeControl(XNAControl control)
   at DTAClient.DXGUI.Generic.LoadingScreen.Finish()
   at DTAClient.DXGUI.Generic.LoadingScreen.Update(GameTime gameTime)
   at Rampastring.XNAUI.WindowManager.Update(GameTime gameTime)
   at Microsoft.Xna.Framework.Game.<>c.<.cctor>b__114_1(IUpdateable updateable, GameTime gameTime)
   at Microsoft.Xna.Framework.Game.SortingFilteringCollection`1.ForEachFilteredItem[TUserData](Action`2 action, TUserData userData)
   at Microsoft.Xna.Framework.Game.Update(GameTime gameTime)
   at Microsoft.Xna.Framework.Game.DoUpdate(GameTime gameTime)
   at Microsoft.Xna.Framework.Game.Tick()
   at MonoGame.Framework.WinFormsGameWindow.RunLoop()
   at MonoGame.Framework.WinFormsGamePlatform.RunLoop()
   at Microsoft.Xna.Framework.Game.Run(GameRunBehavior runBehavior)
   at Microsoft.Xna.Framework.Game.Run()
   at DTAClient.Startup.Execute()
   at DTAClient.PreStartup.Initialize(String[] args)
   at DTAClient.Program.Main(String[] args)
 

Edited by Orklord123, 24 June 2019 - 06:05 AM.


#1222 CidSilverwing

CidSilverwing
  • New Members
  • 2 posts

Posted 26 June 2019 - 11:59 PM

I had to recently reinstall my Origin copies of RA2/Yuri's and Mental Omega because gamemd.exe didn't exist and even when I renamed both the Yuri .exe's Syringe kept giving me a parameter error of sorts.

 

Now I get these errors when I run the .exes:

clientdx.exe:

Fullscreens, error says: Mental Omega Client has crashed. Error message:

D:\Program Files (x86)\Origin Games\Command and Conquer Red Alert II\Resources\clienticon.ico

 

If I run clientogl.exe:

No application, error: Index was out of range. Must be non-negative and less than the size of the collection. Parameter name: index.

 

If I run clientxna.exe:

No application, error: Could not load file or assembly 'Microsoft.Xna.Framework.Game,Version=4.0.0.0, Culture=neutral, PublicKeyToken=842cf8be1de50553' or one of its dependencies. The system cannot find the file specified.

 

Solved, user error.


Edited by CidSilverwing, 27 June 2019 - 07:17 PM.


#1223 Orklord123

Orklord123
  • New Members
  • 2 posts

Posted 30 June 2019 - 05:50 AM

Does anyone know how to fix my problem?



#1224 Rozieeeee

Rozieeeee
  • New Members
  • 1 posts

Posted 01 August 2019 - 01:33 PM

Hello. I have this problem that whenever i press esc to access buttons like abort mission,save game,etc.  The display is still at the game, it is like it freezes the game interface  BUT you can hear the buttons whenever you click on their supposed position AND they respond to their according function.



#1225 Handepsilon

Handepsilon

    Mapper and Mix Hacker

  • Members
  • 2,149 posts
  • Location:Indonesia
  •  No, I don't main PsiCorps. I suck at it.

Posted 01 August 2019 - 02:09 PM

Change your game's renderer in the client's option. Common newer windows' bug

I like gnomes

 

YunruThinkEmoji.png

(Sorry for any double posts, my mobile browser is messed up atm)


#1226 Azaz3l

Azaz3l
  • New Members
  • 1 posts

Posted 19 August 2019 - 10:57 PM

Hello, I'm unable to start any of the Skirmish or Campaign games, whenever I start the game I get a "Yuri's revenge has encountered a fatal error" and the game seems to crash with the same log every time -

About to call gethostbyname
gethostbyname failed! Error code 11001

 
I tried setting compatibility mode to Windows XP SP3 and running as administrator but no luck.
 
Here's the full log:
Spoiler

Edited by Azaz3l, 19 August 2019 - 10:58 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users