Jump to content


[Red Alert 3] Can't connect to a friend when playing

  • Please log in to reply
3 replies to this topic

#1 ChungV2

  • New Members
  • 2 posts

Posted 10 January 2017 - 04:47 PM

Hello everyone! I am having an issue with connecting to my friend when trying to play Red Alert 3.


I have the Ultimate Collection version on Origin.

I am having the "1-2" error, I don't know the actual name of it. It happens both when trying Skirmish and Campaign mode online and it happens both when he is hosting and when I am hosting.

I am using Windows 7 SP1.

Here's the CNCOnline_Log, in the spoilers.

And this is the result of NATNegTest
Sorry if the solution is obvious, but I don't see it. Thanks for your patience!
P.S. Here's what came out of trying the solutions from your "Common Issues and Solutions" thread regarding connection issues.


#2 ViperMkVII


    What is this?

  • Project Team
  • 1,002 posts
  • Location:Ylati, Anorev
  •  C&C:Online Red Alert 3 Player~

Posted 10 January 2017 - 08:51 PM

Hi, if you configured DMZ correctly, the NATNegTest shouldn't fail. How did you set it up? Did you remember to put your computer's local IP address in DMZ setting?

Edited by ViperMkVII, 10 January 2017 - 08:52 PM.


#3 ChungV2

  • New Members
  • 2 posts

Posted 12 January 2017 - 03:35 AM

Thanks for the quick response. 

The IP that I am putting in should look something like this 192.168.x.x ? The problem is, this address changes every time I restart internet. It doesn't change the whole address, just the last number.

If you mean my public IP address, that also changes every time I restart internet because it's a dynamic IP address. 


Sorry if this all sounds stupid, I just want to play the game with my friend and in order to achieve that I want to do this right, so I know if it actually works or not. 

Again, thanks for you patience!

#4 ToxicShock


    Gamereplays.org Staff

  • Division Admins
  • 8,358 posts
  • Location:London, England
  • Projects:Shatabrick C&C Player Database
  •  I have blue text?
  • Division:C&C:Online
  • Job:Online Admin

Posted 12 January 2017 - 04:52 AM

Try giving your network card a static address (so it doesn't change when you restart Windows) and disable DHCP on your router. This video explains how to do that; Static IP Tutorial. You will need to access your router from the web interface to do that. You may find that you can forward to your computer using the network card's MAC address (so you don't need to set the static address) but that will vary from router to router.
Gamereplays.org staff - Shatabrick admin.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users