Jump to content


Photo

[How To] Red Alert 3 Full Port Fowarding for Co-Op and Multiplayer.



  • Please log in to reply
3 replies to this topic

#1 CnC.Cap

CnC.Cap
  • Members
  • 24 posts

Posted 07 September 2017 - 12:32 AM

Hello, I was having problems with Co-Op and Multiplayer, even after the doing what was in the "connective issues" and they didn't resolve anything.

 

So me and PLATINUM_XII where trying something, that he saw online on the forums, and i went to search and he sent me a print.

 

This Ports are for your Router and Firewall so you dont need to DMZ =)

 

TCP 3783 (Voice Chat Port)
TCP 4321 (Mangler Servers)
TCP 28900 (Master Server List Request)
TCP 29900 (GP Connection Manager)
TCP 29901 (GP Search Manager)
TCP 16000 (Revora/CnC Online)
//
UDP 6500 (Query Port)
UDP 6515 (Dplay UDP)
UDP 13139 (Custom UDP Pings)
UDP 27900 (Master Server UDP Heartbeat)
UDP 16000 (Revora/CnC Online)
 
And for no issues with the port, dont use the "port overwrite", go to %appdata% > Red Alert 3 > Profiles > //Your Profile > Options.ini and delete the FirewallPortOverride = , and make the file Read only, this should work, screenshots below are how my router and firewall looks like =)

 

Any doubts please ask.

 

Credits for helping and testing goes to: PLATINUM_XII

and credits for the orignal post on GameReplays.

 

//

Screenshot_1.png

//

Screenshot_2.png

//

Screenshot_3.png

//

Screenshot_4.png

//


Edited by CnC.Cap, 07 September 2017 - 12:33 AM.


#2 ToxicShock

ToxicShock

    Gamereplays.org Staff

  • Division Leaders
  • 9,627 posts
  • Location:London, England
  • Projects:Shatabrick C&C Player Database
  •  I have blue text?
  • Division:C&C:Online
  • Job:C&C:Online Leader

Posted 07 September 2017 - 07:02 AM   Best Answer

As above

Gamereplays.org staff - Shatabrick admin.


#3 luisdeoz

luisdeoz
  • Members
  • 5 posts
  • Location:Argentina

Posted 14 October 2017 - 10:27 PM

EDIT: I've started a new post, sorry. https://forums.revor...ding/?p=1069442


Edited by luisdeoz, 14 October 2017 - 10:44 PM.


#4 Drek_Grey

Drek_Grey
  • Members
  • 10 posts

Posted 09 May 2020 - 09:30 AM

My friend and I did this and it worked after so many attempts to fix our connection. But only once tho. After 1 online match against medium bots we tried doing co op but connection failed then we tried doing an online skirmish again but it says connection and progress. We were only able to play once and we have the same settings for the fire wall. We still have no clue what happened, we didn't change a thing and we keep restarting the game and our PCs 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users