Jump to content


Photo

[Red Alert 3] [Steam] Not launching when hooked


  • Please log in to reply
5 replies to this topic

#1 Commander_Solem

Commander_Solem
  • New Members
  • 1 posts

Posted 24 March 2018 - 11:13 PM

At first, some information.
Windows 10, DirectX9, the game works completely fine when launched normally Steam. I went into my Anti-Virus and firewall and made sure that there are no conflicts there.

 

I am trying to get CNC Online working again on Steam, but I am having a strange issue. It does not give me any prompts when hooking, and launching it as suggested with a shortcut only briefly starts up the process before it shuts down again. My "Playing" icon on Steam turns green, then it turns blue again after a few seconds and telling me that I am no longer playing anything.

I have tried to access the log file, but it is always empty.

 

It also does not launch from Steam if I have it hooked, but it works fine after I unhook it. Launching without the Steam launcher simply gives me the patching routine error, but the suggested solution for that error did not work.

 

This does not seem like a common issue. Any solution?

 

Edit: I just attempted to run it without Steam to get the CA error. This generated an error log, altough I suppose that might be because I was not directly running it from Steam.

 

 

---- C&C:Online Launcher Start -----
Game: Red Alert 3
Red Alert 3 Install Path: C:\Program Files (x86)\Steam\steamapps\common\Command and Conquer Red Alert 3\
Started game with: ""C:\Program Files (x86)\Steam\steamapps\common\Command and Conquer Red Alert 3\RA3.exe" "
Caught CREATE_PROCESS_DEBUG_EVENT from Red Alert 3. Detaching...
Found game.dat process. PID 11424
*** Starting CA public key patching routine ***
ERROR: Reading process memory failed. Error: Bare deler av en ReadProcessMemory- eller WriteProcessMemory-forespørsel ble fullført.


ERROR: Reading process memory failed. Error: Bare deler av en ReadProcessMemory- eller WriteProcessMemory-forespørsel ble fullført.


ERROR: CA public key differs from expected value. Not patching.
ERROR: CA public key patching routine failed.
 


Edited by Commander_Solem, 24 March 2018 - 11:36 PM.


#2 ToxicShock

ToxicShock

    Gamereplays.org Staff

  • Division Leaders
  • 9,544 posts
  • Location:London, England
  • Projects:Shatabrick C&C Player Database
  •  I have blue text?
  • Division:C&C:Online
  • Job:C&C:Online Leader

Posted 25 March 2018 - 02:04 PM

So it's that again. :p I have sent you a PM with a solution which we're testing. If anyone else wants that solution to try, please make your own topic and post your error log.

Gamereplays.org staff - Shatabrick admin.


#3 Goaneo

Goaneo
  • New Members
  • 1 posts

Posted 31 March 2018 - 08:07 PM

Hey Guys,

 

i have the same problem when i hook RA3. Please send me the  solution too =)



#4 ToxicShock

ToxicShock

    Gamereplays.org Staff

  • Division Leaders
  • 9,544 posts
  • Location:London, England
  • Projects:Shatabrick C&C Player Database
  •  I have blue text?
  • Division:C&C:Online
  • Job:C&C:Online Leader

Posted 01 April 2018 - 08:53 AM

If anyone else wants that solution to try, please make your own topic and post your error log.


Gamereplays.org staff - Shatabrick admin.


#5 Rdjdoughboy

Rdjdoughboy
  • New Members
  • 1 posts

Posted 08 December 2019 - 01:00 AM

I have the same issue with loading after its hooked but i don't know how to get an error log. Please help!



#6 JackGold

JackGold
  • New Members
  • 1 posts

Posted 08 December 2019 - 09:11 AM

what is the solution? I'm getting error when launching via hook too...






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users