Jump to content


"Failed to join - game is a different version"

rotwk/bfme2 online support

  • Please log in to reply
4 replies to this topic

#1 MasterofArda

  • New Members
  • 4 posts

Posted 14 July 2018 - 04:27 AM

Hello, I'm making an independent topic because I did not get a response elsewhere. I am trying to play online but I get that different version error. I'm on Windows 10, I am using up to date version of the patch switcher, while trying to play rotwk online my bfme2 is on 1.06 and rotwk is on 2.02v7. I'm using the game.dat file that does not require a CD or any mounting but I got the same error with the original game.dat and a mounted CD image. I have previously added the options.ini folder to fix crashing. I have not found any relevant thread yet so I'm really hoping someone can help me out. Both BFME2 and ROTWK work perfectly in skirmish mode but I cannot join an online game. 

#2 MattTheLegoman


    LEGO Knight of Minas Ithil

  • T3A Staff
  • 3,669 posts
  • Location:Tomorrow, when the War began
  • Projects:Mapping this Middle-earth
  •  Mapper
  • Division:BFME
  • Job:T3A Staff

Posted 14 July 2018 - 12:36 PM

Try this.


And make sure you've installed the game correctly.



Remember that all worlds draw to an end and that noble death is a treasure which no one is too poor to buy. - C.S. Lewis

There will come a time when you believe everything is finished. That will be the beginning. - Louis L'Amour

What will matter then will be people. If relationships will matter most then, shouldn't they matter most now? - Max Lucado

#3 MasterofArda

  • New Members
  • 4 posts

Posted 15 July 2018 - 02:31 AM

Thanks, but no luck. I used that guide and those files to install the games to the best of my ability. I'm going thru the t3a launcher, everything is running as administrator, the options.ini line is correct, I just get the same error. 

#4 FlixorDrakel

  • New Members
  • 1 posts

Posted 21 February 2021 - 11:32 PM

did you ever find a solution?

#5 JustinORing

  • Members
  • 6 posts

Posted 23 June 2021 - 03:53 AM

I have the same issue.  I can't join any games because I guess I have a different game version.  I'm assuming it has to do with the different patches.  some people may not be using the latest patches and maybe that is why.   You would think the latest patch would be backwards compatible, but maybe not.  That is my only guess.  Not sure how to solve it.  I'm looking for answers too.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users