Jump to content


Photo

Questions about modding weapons


108 replies to this topic

#101 Moreartillery

Moreartillery
  • Members
  • 122 posts

Posted 23 October 2019 - 03:20 AM

I've also tried typing none in the in the motion names and it didn't make a difference. Hardpoint 1 and 3 are the same, hardpoint 2 is the heavy bolter. And I've tried with and without 'name for this weapon choice' filled in.

Attached Files

  • Attached File  asdf.PNG   235.85KB   0 downloads


#102 Gambit

Gambit

    title available

  • Members
  • 6,320 posts
  • Location:Athens, Greece

Posted 23 October 2019 - 07:46 AM

I suppose the 1st "projectiled" weapon is coded in either hardpoint_01 or hardpoint_02 right?

And in hardpoint_03, the 2nd projectiled" weapon is coded, and this is where the projectile is problematic. Correct?

 

If so, I can only suggest removing (leave blank) ALL motion variable name values (those with the _3), and keep ONLY the harpoint_weapon_variant_motion, simply using <None>, as a name.

And retry.

 

It worked for me...


-In search of Papasmurf...

#103 Moreartillery

Moreartillery
  • Members
  • 122 posts

Posted 24 October 2019 - 01:12 AM

So apparently, unlike every other part of a unit, the muzzle and origin don't update when loading a save game, so you have to train a new unit for the change to take effect. Animations, fx, textures, and even map data will update properly when you load a savegame but not muzzle and origin. Thats so weird and inconsistent.



#104 Gambit

Gambit

    title available

  • Members
  • 6,320 posts
  • Location:Athens, Greece

Posted 24 October 2019 - 10:19 AM

Brother Moreartillery, I tested it extensively and for me, the 2nd projectile ALWAYS comes out from the proper origin.

I tested on the Dark Angels Vengeance, which fires 2 plasma cannon bolts.

And it is perfect.

Even after a save->load...

You may have to perhaps re-check your code?


-In search of Papasmurf...

#105 Moreartillery

Moreartillery
  • Members
  • 122 posts

Posted 26 October 2019 - 04:59 AM

It works now, I was just saying I had to train a new tank for the new origin to be applied.

 

My new problem is that a die_jumping animation I made gets cut off before finishing. I can see the unit start to fall out of the air but it disappears before hitting the ground. It works fine in the OE.



#106 Gambit

Gambit

    title available

  • Members
  • 6,320 posts
  • Location:Athens, Greece

Posted 26 October 2019 - 08:41 AM

If it is AE (fro example, a spawn_ext or a special_attack anim), it sounds like a problem with the time setting.

Otherwise,... you must ask a modeller :p


-In search of Papasmurf...

#107 Kekoulis

Kekoulis

    Apothecary Novice

  • Members
  • 1,855 posts
  • Location:Reclaimed Chemos
  • Projects:Emperor's Children
  •  Slaanesh's Glory

Posted 26 October 2019 - 12:01 PM

If it is AE (fro example, a spawn_ext or a special_attack anim), it sounds like a problem with the time setting.

Otherwise,... you must ask a modeller :p

No,he does not have to ask a kodeller,or else the modeller would have replied.

 

As long as it is fine in OE,then the only thing they have to do,is to set the correct timings in Corsix.


ec-sig-early2.gif

Mankind has seen the light,the light of Slaanesh.


#108 Moreartillery

Moreartillery
  • Members
  • 122 posts

Posted 29 October 2019 - 06:04 AM

I keep getting the following error when I try to import the hive tyrant. See attached screenshot. It doesn't extract the ref or anim files.

Attached Files



#109 Kekoulis

Kekoulis

    Apothecary Novice

  • Members
  • 1,855 posts
  • Location:Reclaimed Chemos
  • Projects:Emperor's Children
  •  Slaanesh's Glory

Posted 29 October 2019 - 10:40 AM

I keep getting the following error when I try to import the hive tyrant. See attached screenshot. It doesn't extract the ref or anim files.

Yeah,the model is damaged or the Importer borked.

 

Either way,I am afraid you can't import it.


Edited by Kekoulis, 29 October 2019 - 10:42 AM.

ec-sig-early2.gif

Mankind has seen the light,the light of Slaanesh.




Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users