Jump to content


Photo

How to Make GenTool Work?


  • Please log in to reply
9 replies to this topic

#1 CloneKiller

CloneKiller
  • Members
  • 7 posts

Posted 05 September 2018 - 09:30 PM

For over a year now I have struggled like mad trying to get GenTool to work. 

I am currently using the Origin versions of Zero Hour and Generals, Zero Hour being the ONLY game I wish to play online. I am currently using a Windows 7 PC with a external hard drive. 

I have made an account on C&C Online and downloaded GenTool version 7.4 my Zero Hour game is currently updated to version 1.04 and when I open the game, I see that GenTool opens and says that its running. But when I go to the multiplayer and click online, I login as usual, but I will ALWAYS get the same damn message. "Could not Connect to C&C Generals Zero Hour Online"

I have yet to receive any answer or even find anyone who has this many issues with this!

Please Please Please tell me what it is I am doing wrong and explain to me why I can't play online?



#2 Guest_protoman1008_*

Guest_protoman1008_*
  • Guests

Posted 06 September 2018 - 07:36 AM

Have you tried this? (Marked with <---)

 

 

 

- I bought the games on Origin and the C&C:Online launcher keeps saying the installation cannot be found. Or: You can not login.
Make sure to run the game with admin rights.
Solution 1 (Generals & Zero Hour):
1) Install the fixed launchers (applicable only if you have the Ultimate Collection via Origin) DOWNLOAD  <----
2) Install GenTool (can be installed if you have Origin versions / retail versions)
3) Uninstall C&C:Online (if you've been hooking, make sure you unhook first)
4) Launch the game and use your C&C:Online credentials to log in. GenTool has C&C:Online support built in.
Solution 3 (C&C3 & RA3): Go into Origin, click the game (in this case either C&C3 or RA3), click the "i" button to the left of "play", click "Game Properties" and check the box "Disable Origin in game for this game" and then launch RA3 or C&C3 via the normal C&C:Online method.


#3 ToxicShock

ToxicShock

    Gamereplays.org Staff

  • Division Leaders
  • 9,533 posts
  • Location:London, England
  • Projects:Shatabrick C&C Player Database
  •  I have blue text?
  • Division:C&C:Online
  • Job:C&C:Online Leader

Posted 06 September 2018 - 08:12 AM

I expect that your (institutional) provider has blocked TCP port 6667, which these games need to use (it was the same under gamespy). I should check with them and see if they will unblock it. If not, you will have to use a mobile connection or set up a VPN. You will be able to find a free VPN near where you are (google for some) but some are better than others.

Gamereplays.org staff - Shatabrick admin.


#4 CloneKiller

CloneKiller
  • Members
  • 7 posts

Posted 20 September 2018 - 09:57 PM

 

Have you tried this? (Marked with <---)

 

 

 

- I bought the games on Origin and the C&C:Online launcher keeps saying the installation cannot be found. Or: You can not login.
Make sure to run the game with admin rights.
Solution 1 (Generals & Zero Hour):
1) Install the fixed launchers (applicable only if you have the Ultimate Collection via Origin) DOWNLOAD  <----
2) Install GenTool (can be installed if you have Origin versions / retail versions)
3) Uninstall C&C:Online (if you've been hooking, make sure you unhook first)
4) Launch the game and use your C&C:Online credentials to log in. GenTool has C&C:Online support built in.
Solution 3 (C&C3 & RA3): Go into Origin, click the game (in this case either C&C3 or RA3), click the "i" button to the left of "play", click "Game Properties" and check the box "Disable Origin in game for this game" and then launch RA3 or C&C3 via the normal C&C:Online method.

 

I have tried both these numerous times, I can't get anything to work. I just get the same error over and over again



#5 CloneKiller

CloneKiller
  • Members
  • 7 posts

Posted 20 September 2018 - 10:04 PM

I expect that your (institutional) provider has blocked TCP port 6667, which these games need to use (it was the same under gamespy). I should check with them and see if they will unblock it. If not, you will have to use a mobile connection or set up a VPN. You will be able to find a free VPN near where you are (google for some) but some are better than others.

Huh? What does that mean? I'm using my own personal Wifi and Ethernet and even when I go and use a friend or relative's wifi I receive the exact same issues 



#6 Guest_protoman1008_*

Guest_protoman1008_*
  • Guests

Posted 21 September 2018 - 06:46 AM

Honestly I'm suspecting the 6667 TCP port being blocked as well, possibly other ports as well.

 

You could give a VPN a try, there are a few free VPNs such as Windscribe which offers 10 GB for free each month if you're worried about the bandwidth limitations.

A VPN can usually go around certain blockades, that includes blocked websites or other services by your provider.

 

It's worth a try to check if it was indeed something being blocked by the provider.

 

If using the VPN, don't forget to double check the local network IP settings in Generals. It should be set to the VPN's IP range. In my case it's in the 10.x.x.x range.

After that, try log in again and fingers crossed in the hope this is it.



#7 AtlKush

AtlKush
  • New Members
  • 2 posts

Posted 04 October 2018 - 12:20 PM

i am having a similar issue so i followed the advice listed above. i created account last night, verified email, etc. But when i click online and use my email, name and password from registration; if i click login it says invalid email, and if i click create account, it says it cannot communicate with zero hour online. i assume that i do not need to create account if i am using my registration info, but why would email not be valid if it has been verified?



#8 Guest_protoman1008_*

Guest_protoman1008_*
  • Guests

Posted 04 October 2018 - 12:27 PM

Make sure the e-mail address matches with the information here.



#9 AtlKush

AtlKush
  • New Members
  • 2 posts

Posted 04 October 2018 - 10:08 PM

protoman, i had not seen that screen yet. but that was it, i am online now. you are the man, thank you so much!!!



#10 iTzRiskx

iTzRiskx
  • Members
  • 13 posts

Posted 20 November 2018 - 02:46 AM

I'm having same issue As clonekiller. I use to play regular but 1 day game just don't let me go online. I click multiplayer and it stays there for 1-2 mins and then it said can conect with zero hours servers.😔




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users