Jump to content


Photo

Tech Artillery Bunker in Map Editor.


Best Answer Starkku, 03 November 2018 - 02:02 PM

Tech structures (NeedsEngineer=yes in rules) cannot be directly placed under ownership of non-neutral houses without problems such as this occuring. You need to use a trigger to change the owner from Neutral/Civilian or just stick to capturing them with Engineers.

Go to the full post


  • Please log in to reply
2 replies to this topic

#1 Hkhr

Hkhr
  • Members
  • 24 posts

Posted 03 November 2018 - 01:51 PM

I have made a singleplayer map and placed some Tech Artilleries, But it they don't shoot, The turret doesn't even move.

 

I haven't changed anything in the Structure options, Only Direction and Owner.

And there's enough power for the artillery.

 

Is this a bug or I have made something wrong?



#2 Starkku

Starkku

    Putting the Pro' in 'Procrastination'

  • Hosted
  • 431 posts
  • Location:Finland
  • Projects:Project Phantom
  •  C&C YR modder & Project Phantom mod leader.

Posted 03 November 2018 - 02:02 PM   Best Answer

Tech structures (NeedsEngineer=yes in rules) cannot be directly placed under ownership of non-neutral houses without problems such as this occuring. You need to use a trigger to change the owner from Neutral/Civilian or just stick to capturing them with Engineers.


Edited by Starkku, 03 November 2018 - 02:04 PM.

ppsign.gif

#3 Hkhr

Hkhr
  • Members
  • 24 posts

Posted 03 November 2018 - 02:09 PM

Tech structures (NeedsEngineer=yes in rules) cannot be directly placed under ownership of non-neutral houses without problems such as this occuring. You need to use a trigger to change the owner from Neutral/Civilian or just stick to capturing them with Engineers.

Thanks, It works fine now.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users