Jump to content


Photo

Red Alert 3 - CA public key patching routine failed


  • Please log in to reply
3 replies to this topic

#1 hibbjam

hibbjam
  • New Members
  • 2 posts

Posted 30 November 2018 - 09:18 PM

----- C&C:Online Launcher Start -----
Game: Red Alert 3
Red Alert 3 Install Path: C:\Program Files (x86)\Electronic Arts\Red Alert 3\
Started game with: ""C:\Program Files (x86)\Electronic Arts\Red Alert 3\RA3.exe" "
Caught CREATE_PROCESS_DEBUG_EVENT from Red Alert 3. Detaching...
Found game.dat process. PID 8516
*** Starting CA public key patching routine ***
ERROR: CA public key differs from expected value. Not patching.
ERROR: CA public key patching routine failed.
 
I've seen on another topic there is a fix for this. Please could you share it with me? Thanks


#2 ToxicShock

ToxicShock

    Gamereplays.org Staff

  • Division Leaders
  • 9,036 posts
  • Location:London, England
  • Projects:Shatabrick C&C Player Database
  •  I have blue text?
  • Division:C&C:Online
  • Job:C&C:Online Leader

Posted 05 December 2018 - 03:55 PM

Sorry for the delay in dealing with this.    I must have missed it somehow. I have sent you a PM with a solution which we're testing. If anyone else wants that solution to try, please make your own topic and post your error log.

Gamereplays.org staff - Shatabrick admin.


#3 hibbjam

hibbjam
  • New Members
  • 2 posts

Posted 09 December 2018 - 09:47 AM

Now it says 'Failed to connect to servers. Please check to make sure you have an active connection to the internet' and there is nothing wrong with my internet connection?



#4 ToxicShock

ToxicShock

    Gamereplays.org Staff

  • Division Leaders
  • 9,036 posts
  • Location:London, England
  • Projects:Shatabrick C&C Player Database
  •  I have blue text?
  • Division:C&C:Online
  • Job:C&C:Online Leader

Posted 09 December 2018 - 09:56 AM

Your provider is very capable of supporting this (I know from personal experience) so there is probably an issue with the configuration at your end.

 

If you have any Hamachi drivers you should make sure they are disabled.

 

Then check that the IP address shown in Options->Settings->Network is an address on the network you use to connect to the internet (probably 192.168 or 10. something). If there is more than one address, select the other one.


Gamereplays.org staff - Shatabrick admin.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users