Jump to content


Photo

Palantir Image Issue


  • Please log in to reply
4 replies to this topic

#1 Felipe Roll-st

Felipe Roll-st
  • Members
  • 48 posts

Posted 06 December 2018 - 04:06 AM

HI y'all

 

I'm trying to give a palantir image to few objects in which I'm lost as this is fairly simple to mod, the reason is cos even I put the code, and make sure the asset is good, the palantir of my objects is still black, it's happened with two heroes I've created and with the creep lairs, I want to add some images to the liars as in bfme 2, but they just don't show up, does anybody know why this happens?

 

appreciate any help folks.



#2 Miraak5

Miraak5

    Dragonborn

  • Members
  • 245 posts
  • Location:France
  • Projects:Rotwk mod: Wars of the North, BFME1 Patch 1.08
  •  BIG coding, Map scripting and AI coding

Posted 06 December 2018 - 01:36 PM

Did u linked your button/portrait name in mappedimage to the texture ?


He was the first...


#3 Felipe Roll-st

Felipe Roll-st
  • Members
  • 48 posts

Posted 07 December 2018 - 12:51 AM

yes, I even tried to give vanilla portraits to the lairs, but they don't appear, it's like if they were hardcoded but I don't think so as it's not really relevant to hardcode that :(

 

with my heroes the button image is shown but not the palantir one, even tho both images are in the same picture


Edited by Felipe Roll-st, 07 December 2018 - 12:53 AM.


#4 Ganon

Ganon

    What's this?

  • Project Team
  • 962 posts
  • Location:Ohio, United States
  • Projects:My Link Mod
  •  Code Scientist

Posted 07 December 2018 - 09:58 AM

Are you using these lines in the code for those units you're talking about?

    ; SelectPortrait for Heros is portrait behind skill buttons. HP = HeroPortrait.
    SelectPortrait = HPAragorn
    
    ; ButtonImage for Heros is button image on Hero Select UI to select hero. HI = HeroIcon or HeroImage.
    ButtonImage = HIAragorn

Also, within the respawn module for your hero, make sure to set this line;

        ButtonImage                = HIAragorn

 

After all that, if it still doesn't work, carefully double-check that you've properly mapped the texture in mapped images.


Edited by Ganon, 07 December 2018 - 10:00 AM.


#5 Miraak5

Miraak5

    Dragonborn

  • Members
  • 245 posts
  • Location:France
  • Projects:Rotwk mod: Wars of the North, BFME1 Patch 1.08
  •  BIG coding, Map scripting and AI coding

Posted 07 December 2018 - 10:54 AM

He does he said the problem was because he tried to give portrait to warg lair
and in the vanilla bfme1 warg lair have the orc pit portrait set but never shows up

 

i think it's hardcoded


He was the first...





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users