Jump to content


Photo

[RA3 Steam Windows 10] - Cannot connect to backend server

support red alert 3 backend

  • Please log in to reply
3 replies to this topic

#1 icemelt7

icemelt7
  • New Members
  • 3 posts

Posted 29 December 2018 - 09:37 PM

My CNC Logs


----- C&C:Online Launcher Start -----
Game: Red Alert 3
Red Alert 3 Install Path: C:\Program Files (x86)\Steam\steamapps\common\Command and Conquer Red Alert 3\
Started game with: "RA3.exe "
Caught CREATE_PROCESS_DEBUG_EVENT from Red Alert 3. Detaching...
Found game.dat process. PID 7176
*** Starting CA public key patching routine ***
CA public key is expected value.
Successfully patched CA public key.
*** Starting hostname hooking routine ***
Injecting DLL into game.dat process...
Result of injection: Code -1073741582

My NATTest

Using server nntest.cnc-online.net:30000
Bound to local port 64356
Bound to local alternate port 64357
Resolving hostname 'nntest.cnc-online.net'...
Resolved server host to be '37.247.49.213'
Sending client INIT from port 64356 to nntest.cnc-online.net:30000
Received server INIT [151380]
Our public address is 94.204.99.242:64356
Sending client INIT2 [151380] from port 64357 to nntest.cnc-online.net:30000
Received server INIT2 [151380]
Our alternate public address is 94.204.99.242:64357
Sending cient START [151380] from port 64357 to nntest.cnc-online.net:30000
Received server START [151380]
Server extra port is 40000
Sending client PING [151380] from port 64356 to nntest.cnc-online.net:40000
Received server PING(2) [151380]
Received server PING(3) [151380]
Received server PING(4) [151380]

===========
  SUCCESS
===========
Received 3 pings from nntest.cnc-online.net:40000.
NAT negotiation works with your router and connection.
==> You do not have to use port forwarding.
Press any key to continue . . .

I use the quick launcher to quickly launch RA3, I've selected no ip also, read all the thread and tried all the solutions, I am using 192.168 IP, I've removed firewall override.

 

Whenever I try to login I get an error "Cannot connect to backend servers", maybe this experimental launcher will solve this?



#2 ToxicShock

ToxicShock

    Gamereplays.org Staff

  • Division Leaders
  • 9,512 posts
  • Location:London, England
  • Projects:Shatabrick C&C Player Database
  •  I have blue text?
  • Division:C&C:Online
  • Job:C&C:Online Leader

Posted 30 December 2018 - 12:34 PM

I don't think it will help.  This looks more like a connection problem. Please could you open Windows PowerShell (type PowerShell at the start menu) and in the window type and enter

Test-NetConnection peerchat.server.cnc-online.net -port 6667

then post the output in here.


Gamereplays.org staff - Shatabrick admin.


#3 icemelt7

icemelt7
  • New Members
  • 3 posts

Posted 01 January 2019 - 09:16 AM

ComputerName     : peerchat.server.cnc-online.net
RemoteAddress    : 185.17.144.132
RemotePort       : 6667
InterfaceAlias   : WiFi
SourceAddress    : 192.168.0.135
TcpTestSucceeded : True


#4 icemelt7

icemelt7
  • New Members
  • 3 posts

Posted 01 January 2019 - 09:39 AM

I tried to observe the outgoing address from Red Alert 3 and I find it tries to connect to 

http://ripper.icetex-hosting.net/

Is this correct?







Also tagged with one or more of these keywords: support, red alert 3, backend

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users