Jump to content


Photo

RA3 ca public key patching routine failed

ra3 starterror

  • Please log in to reply
12 replies to this topic

#1 hexxen

hexxen
  • New Members
  • 4 posts

Posted 04 February 2019 - 08:43 PM

Hi guys, i have small issue.

I guess that u are familiar with some of those but as the tilte says i have problem with red alert 3. Whenever i launch it via C&C Online it shows me a error "ca public key patching routine failed". I've hooked ra3 ofc. Here are my logs:

 
 
----- C&C:Online Launcher Start -----
Game: Red Alert 3
Red Alert 3 Install Path: G:\RA3\
Started game with: "RA3.exe "
Caught CREATE_PROCESS_DEBUG_EVENT from Red Alert 3. Detaching...
Found game.dat process. PID 1772
*** Starting CA public key patching routine ***
ERROR: CA public key differs from expected value. Not patching.
ERROR: CA public key patching routine failed.
 


#2 Edvin2090

Edvin2090
  • Project Team
  • 203 posts
  • Location:Norway
  •  Blueberry pie

Posted 04 February 2019 - 10:49 PM

- When I launch my game using the C&C:Online launcher, I get the following error: "CA public key patching routine failed"
Solution: Try setting the launcher to Windows XP compatibility mode.

if you want to read more of this you can find it here: 
https://forums.revor...sues-solutions/

left click cnc online once 

then right click it once 

click on Properties

then click on compatability 

and Select Windows mode (service pack 3) 

or Select Windows 7 mode. 

 


mabye this will help you whit your cnc problem https://forums.revor...sues-solutions/

rember to give as mutch info as you can befor posting support tickets this will help you. https://forums.revor...-report-issues/

If you want to reach me faster for some support, feel free to join our discord server. https://discord.gg/hPPfJT3 
You can tagg either me @edvin#2274 or @tech support in the chat #support 


#3 hexxen

hexxen
  • New Members
  • 4 posts

Posted 05 February 2019 - 11:10 AM

Tks for your reply, but it seems that wasnt the case. i've done both i mean i set up to win xp and win 7 compatability and it didnt work.

any other ideas?



#4 Edvin2090

Edvin2090
  • Project Team
  • 203 posts
  • Location:Norway
  •  Blueberry pie

Posted 05 February 2019 - 05:45 PM

run with admin? 

what platfomr are you using orgin or steam? 


mabye this will help you whit your cnc problem https://forums.revor...sues-solutions/

rember to give as mutch info as you can befor posting support tickets this will help you. https://forums.revor...-report-issues/

If you want to reach me faster for some support, feel free to join our discord server. https://discord.gg/hPPfJT3 
You can tagg either me @edvin#2274 or @tech support in the chat #support 


#5 hexxen

hexxen
  • New Members
  • 4 posts

Posted 05 February 2019 - 07:07 PM

running as admin didnt help, im using no platform version, i bought

red alert long time ago



#6 ToxicShock

ToxicShock

    Gamereplays.org Staff

  • Division Leaders
  • 9,624 posts
  • Location:London, England
  • Projects:Shatabrick C&C Player Database
  •  I have blue text?
  • Division:C&C:Online
  • Job:C&C:Online Leader

Posted 06 February 2019 - 09:52 AM

Does the game still open and run if you start it without C&C:Online?


Gamereplays.org staff - Shatabrick admin.


#7 hexxen

hexxen
  • New Members
  • 4 posts

Posted 06 February 2019 - 04:08 PM

yup, the problem only occurs whenever i try to launch it via c&c online



#8 Edvin2090

Edvin2090
  • Project Team
  • 203 posts
  • Location:Norway
  •  Blueberry pie

Posted 08 February 2019 - 08:10 PM

I have sendt you a pm look in the top right for a red notification to find my message.

edit: 

its solved. 


Edited by Edvin2090, 14 February 2019 - 11:36 PM.

mabye this will help you whit your cnc problem https://forums.revor...sues-solutions/

rember to give as mutch info as you can befor posting support tickets this will help you. https://forums.revor...-report-issues/

If you want to reach me faster for some support, feel free to join our discord server. https://discord.gg/hPPfJT3 
You can tagg either me @edvin#2274 or @tech support in the chat #support 


#9 OldFartGameing

OldFartGameing
  • New Members
  • 1 posts

Posted 19 May 2020 - 11:54 AM

Hi having the same problem running windows 10



#10 Nixellion

Nixellion
  • New Members
  • 1 posts

Posted 08 June 2020 - 11:41 PM

Same issue here

 

EDIT: Reinstalled C&C Online and added it to exceptions for Windows Defender. It now does not show any errors, it hangs a bit, then the game starts loading (splash screen with RA logo), and then it disappears.

EDIT2: Ah no. Trying again, same error


Edited by Nixellion, 08 June 2020 - 11:53 PM.


#11 r33sin

r33sin
  • New Members
  • 1 posts

Posted 12 August 2020 - 03:24 PM

Same issue here

 

EDIT: Reinstalled C&C Online and added it to exceptions for Windows Defender. It now does not show any errors, it hangs a bit, then the game starts loading (splash screen with RA logo), and then it disappears.

EDIT2: Ah no. Trying again, same error

did you fix this?



#12 Skyline123

Skyline123
  • New Members
  • 1 posts

Posted 17 August 2020 - 07:39 AM

Hi guys,

 

I am also having the same problems of RA3 ca public key patching routine failed. Tried to reinstall CNC Revora Online twice already, Restarted my computer but it is still showing me the same issue. My game is running from steam and it runs fine without Revora Online but I need it to play with my friends online

 



#13 Medstar

Medstar
  • Members
  • 27 posts
  •  Programmer/Help Team Member

Posted 02 September 2020 - 12:05 AM

Hi having the same problem running windows 10

 

 

Same issue here

 

EDIT: Reinstalled C&C Online and added it to exceptions for Windows Defender. It now does not show any errors, it hangs a bit, then the game starts loading (splash screen with RA logo), and then it disappears.

EDIT2: Ah no. Trying again, same error

 

 

Hi guys,

 

I am also having the same problems of RA3 ca public key patching routine failed. Tried to reinstall CNC Revora Online twice already, Restarted my computer but it is still showing me the same issue. My game is running from steam and it runs fine without Revora Online but I need it to play with my friends online

Please make your own threads concerning your issues. The OP's issue is considered solved, so this thread is likely to be deleted sometime soon/will be ignored. This is so that the forum is easier to manage for the moderators/admins, easier to prune whenever there are a lot of topics to cover that have already been solved, and it helps them keep track of who all exactly needs help overall instead of trying to figure out who all needs help by reading through a huge thread.

 

Thank you.







Also tagged with one or more of these keywords: ra3, starterror

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users