Jump to content


Photo

BFME2 & RoTWK Freezes PC During Gameplay

crash error freeze

  • Please log in to reply
3 replies to this topic

#1 Arahor

Arahor
  • New Members
  • 3 posts

Posted 18 March 2019 - 01:40 PM

Hello

 

I have an issue with BFME2 and ROTWK when I'm playing and I'm at a loss here since I have ran out of ideas of what to do.

 

What happens is this.

 

I start a map, any map as a skirmish. I select the settings of my preferences and start to load into the game. After ~5 minutes of lag free play (perfectly smooth gameplay), just building and defending and all the usual stuff, no big deal, the game "tabs itself out to desktop and then in again" like it stops responding for 5 seconds, then it keeps going at it's usual phase. After maybe another 5 minutes the game freezes, locks itself up completely, and when it does that it also locks up my entire PC, ALT F4 dont work and CTRL ALT Delete dont work either, only way to solve it is to do a hard reboot on my PC. No error codes or anything are shown when this happens or from what I can see in the windows log.

 

First time i experienced this was last night with ROTWK, same story there as above, and now recently like 10 minutes ago in BFME2.

All are patched like the installation guide says and all, I'm also using the HD edition for BFME2. I tried to run the exe as admin or in compability mode but then the game would not launch. I also did what some had done in this thread just for good mesure https://forums.revor...ze#entry1051412 . But that did not help either.

 

My specs are

 

Windows 10 Home

EVGA GTX 980

I7-8700K

16gb 3200hz RAM

2TB HDD (This is where I got the game installed)

250GB SSD

500GB M.2 NvME (OS installed on here)

 

I'm using EVGA Precision x16 for fan curve on gpu in the background and otherwise it's only Firefox Nightly, Steam and Discord in the background while I ran these games but I can't imagine any of them conflicting with this. All drivers are up-to-date.

 

Although, I can run BFME perfectly fine.

 

I just wonder if there is anyone here that has had these issues before or if someone know why it is happening.

 

Thanks in advance.



#2 Arahor

Arahor
  • New Members
  • 3 posts

Posted 18 March 2019 - 06:18 PM

So I reinstalled the game completely, 100% clean install. Removed RoTWK in the process and installed BFME2 from scratch. Followed the instructions and now I get this error about 2 minutes in.

 

9HFC4k0.png

 

EDIT: I did another clean re-install. Patched it to 1.06 and then 1.09 like the guide says. Did NOT install the HD pack this time. 6 minutes in I get the same error as above.

EDIT2: Just did another clean install of the game. Now I got the same issue I wrote about in my first post in this thread.

EDIT3: I tried to rollback to 1.06 to see if that helped, but no. Still same issue as in first post.

EDIT4: So I reinstalled the game again from GameReplays, some special edition. But still had the same error. I just reinstalled the game following the links/downloads and the guide on this forum, I tried 1.06 without the HD mod and another mod that increases the zoom out, so just pure 1.06, but still had the same issue in my first post. So I patched the game to 1.07, installed the zoom mod, and HD edition and yeh that did not help either.

 

Worth mentioning, I've done a full clean re-install each time, deleting all the related files in roaming and my installation folder + removed the things from regedit related to the game. I tried different keygens even but now I consider myself being fully defeated, I can't solve this on my own.


Edited by Arahor, 19 March 2019 - 03:42 PM.


#3 Arahor

Arahor
  • New Members
  • 3 posts

Posted 20 March 2019 - 01:02 PM

This is the crash report when RoTWK hangs.

 

Källa
The Battle for Middle-earth™ II

Sammanfattning
Slutade fungera

Datum
‎2019-‎03-‎20 13:01

Status
Rapport skickad

Beskrivning
Felaktig programsökväg:    E:\Games\The Battle for Middle-earth ™ II\game.dat

Problemsignatur
Händelsenamn:    APPCRASH
Programnamn:    game.dat
Programversion:    2.1.2614.37001
Programtidsstämpel:    460da09e
Namn på felmodul:    KERNELBASE.dll
Modulens version:    10.0.17763.348
Tidsstämpel för felmodul:    53015794
Undantagskod:    04560123
Undantagsförskjutning:    0011c632
OS-version:    10.0.17763.2.0.0.768.101
Språkvariant-ID:    1053
Ytterligare information 1:    5dda
Ytterligare information 2:    5dda69e38ed6c0f59e329fc561b7df7c
Ytterligare information 3:    e19a
Ytterligare information 4:    e19a5a2886f49735433505aa2ae60171

Extra information om problemet
Bucket-ID:    3a8f301f17937087c4c441396fb8a4b0 (1496392691137160368)


Edited by Arahor, 20 March 2019 - 01:02 PM.


#4 Jokuc

Jokuc

    Hardcore Procrastinator

  • Members
  • 170 posts
  • Location:Sweden
  •  Mapper

Posted 26 March 2019 - 10:43 PM

Very odd. You don't have to download the game from other sources or use other "cracks"/keygens. The downloads provided in the installation guide here are fully functional. As mentioned in that thread you linked you might want to try force your computer to run the game with your graphics card and not the integrated graphics if your computer has that, though you did say it runs lag free so it doesn't seem like this is the issue either. Look if you've accidentally done some silly mistake such as writing an x between the resolution numbers in the options.ini file and if you haven't even set up an options.ini file be sure to do that. 

 

Since you have the game installed on the E:\ drive you also need the patch switcher to be on the same drive so it can access and patch all files, but if the game starts in 1.09 it probably did so I also doubt that is the issue. Be sure to put in the game.dat file that allows you to play without a disc after you updated to 1.06 or 1.09. Also you should wait with rotwk, hd edition, mods etc until you got your bfme2 working properly. 

 

It sounds like a real mess right now, messing with registry files can really screw things up if you don't know what you're doing but as lame as it may sound I think you need to uninstall everything completely and install the game with the files found in the installation thread here. If you downloaded the game elsewhere such as forshire or something it might be the cause of your issues.


Edited by Jokuc, 26 March 2019 - 10:49 PM.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users