Jump to content


Photo

Launcher cant start Red Alert 3 "CA public key patching routine failed"

launcher error ca public

  • Please log in to reply
2 replies to this topic

#1 savas16

savas16
  • New Members
  • 2 posts

Posted 08 July 2019 - 10:21 PM

Description: I tried hooking up Red Alert 3 to the launcher but didnt get any type of confirmation asking popup. When i try to start the game via launcher it just starts up , followed by the error message "CA public key patching routine failed". It occurs since i installed it yesterday and on every startup.

 

Suggestions i tried: - Changing compatibility to Win XP didnt work

                                   - Starting it as Admin didnt have an effect either

                                   - Looked through windows defender but couldnt find any kind of blockage

                                   - tried to repair the game but pointless

 

My System: The game is a steam version, im running on Win 10 Pro, it is updated to the latest patch.

 

Error log:

----- C&C:Online Launcher Start -----
Game: Red Alert 3
Red Alert 3 Install Path: C:\Program Files (x86)\Steam\steamapps\common\Command and Conquer Red Alert 3\
Started game with: "RA3.exe "
Caught CREATE_PROCESS_DEBUG_EVENT from Red Alert 3. Detaching...
Found game.dat process. PID 3048
*** Starting CA public key patching routine ***
ERROR: Reading process memory failed. Error: Nur ein Teil der ReadProcessMemory- oder WriteProcessMemory-Anforderung wurde abgeschlossen.


ERROR: Reading process memory failed. Error: Nur ein Teil der ReadProcessMemory- oder WriteProcessMemory-Anforderung wurde abgeschlossen.


ERROR: CA public key differs from expected value. Not patching.
ERROR: CA public key patching routine failed.



#2 Edvin2090

Edvin2090
  • Project Team
  • 94 posts
  • Location:Norway
  •  Blueberry pie

Posted 08 July 2019 - 10:39 PM

i have sendt you a privet message with a soultion we are testing IF ANY ONE WULD LIKE THAT SOLUTION TO TRY MAKE YOUR OWN SUPPORT TICKET AND POST YOUR ERROR LOG.


mabye this will help you whit your cnc problem https://forums.revor...sues-solutions/

rember to give as mutch info as you can befor posting support tickets this will help you. https://forums.revor...-report-issues/

#3 savas16

savas16
  • New Members
  • 2 posts

Posted 09 July 2019 - 10:07 PM

So i think i fixed my issue. But man was it a process. I had prior instances of RA3 before i bought in on steam so i guess that some residue was the reason for the hooking not working. I just completely set up my whole system from scratch and viola it works like a charm after intallation and patching. I am very grateful for ur time and effort. Keep it up lads.

Cheers!!!







Also tagged with one or more of these keywords: launcher, error, ca public

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users