Jump to content


[Zero Hour 1.04 Original] Cannot connect to other players - tried all typical solutions

  • Please log in to reply
3 replies to this topic

#1 Deic

  • New Members
  • 1 posts

Posted 27 August 2019 - 11:22 PM

As titled, I'm not able to establish a connection with other players. When the game is started during the lobby, I can only reach "Waiting on probe response" before the connection fails and I'm automatically kicked.


I faced this issue before around a year ago and managed to fix it while using the same operating system and router model as I am now (although different physical router) but can't seem to manage it now.


I have verified that all ports are properly open using the PFPortChecker by portforward.com.


It shouldn't be noteworthy because it's transparent to the network, but I'm using a WiFi Extender. I'm also generally tech savvy and experienced with the basics of port forwarding, so it's unlikely I've just accidentally made a huge mistake.




OS: Windows 10 Home Edition

Game: C&C Generals Zero Hour non-Origin edition (w/ Gentool) in Windows XP SP3 & as Administrator.

Router: Virgin Media Hub 3.0

WiFi Extender: Netgear u300


I don't have a CnCOnline_Log in %TEMP%.


Steps attempted:

  • Set up port forwarding rules for TCP 80, 6667, 28910, 29900, 29920, 16000 & UDP 4321, 27900, 16000 all in proper ascending order using my PC's assigned Static IP with Router Firewall ON (as that is apparently a requirement for my router model). It has been over 8 hours since I created these rules, so there shouldn't be any time-related issues (not that there should be anyway, but just in case...)
  • Added both Inbound and Outbound Windows Firewall exceptions for generals.exe, as well as disabling Windows Firewall completely.
  • Disabled UPnP, disabled Router Firewall, disabled both concurrently.
  • Configured my PC as the DMZ in my Router Settings. Combined this with the steps taken above.
  • Rebooted within router settings, "power cycled" for 1 minute, factory reset the router.
  • Ran the connection diagnostic tool with the following results:

Using server nntest.cnc-online.net:30000
Bound to local port 54390
Bound to local alternate port 54391
Resolving hostname 'nntest.cnc-online.net'...
Resolved server host to be ''
Sending client INIT from port 54390 to nntest.cnc-online.net:30000
Received server INIT [972751]
Our public address is
Sending client INIT2 [972751] from port 54391 to nntest.cnc-online.net:30000
Received server INIT2 [972751]
Our alternate public address is
Sending cient START [972751] from port 54391 to nntest.cnc-online.net:30000
Received server START [972751]
Server extra port is 40000
Sending client PING [972751] from port 54390 to nntest.cnc-online.net:40000
Received server PING(2) [972751]
Received server PING(3) [972751]
Received server PING(4) [972751]

Received 3 pings from nntest.cnc-online.net:40000.
NAT negotiation works with your router and connection.
==> You do not have to use port forwarding.
Press any key to continue . . .

So, essentially, I've tried everything I reasonably can without opting for a VPN (which would slow down my connection considerably, unfortunately.) If anyone can come up with any lesser-known solution, I'd appreciate it.




Edit: This is what TCPView gives me:



Edited by Deic, 28 August 2019 - 12:03 AM.

#2 ExtremeArmy

  • New Members
  • 1 posts

Posted 07 September 2019 - 10:44 PM

my friend has the exact same problem

#3 tommeke21

  • New Members
  • 1 posts

Posted 23 September 2019 - 10:54 PM

i got the same issue and im unable to fix it alone

#4 muxo92

  • New Members
  • 2 posts

Posted 30 October 2019 - 07:07 PM

i got the same issue. i try fix it all day

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users