Jump to content


Photo

Red Alert 3 Failed Connection


  • Please log in to reply
4 replies to this topic

#1 Cosmic_Candi

Cosmic_Candi
  • New Members
  • 2 posts

Posted 29 December 2019 - 01:06 PM

Hi all I am aware of the volume of posts on this issue and I promise I've read them all and tried everything I can, here is what I've done...

 

I set up DMZ (Though I am running on a 3G router so standard Port forwarding and port triggering does not work so I do not know if this will work either)

 

I have allowed it through my firewall

 

and I've ran the connection debugger

 

(See files for screenshot proof)

 

and got the following issue in the %TEMP% file

 

----- C&C:Online Launcher Start -----
Game: Red Alert 3
Red Alert 3 Install Path: C:\Program Files (x86)\Origin Games\Command and Conquer Red Alert 3\Red Alert 3\
Started game with: ""Red Alert 3\RA3.exe""
Caught CREATE_PROCESS_DEBUG_EVENT from Red Alert 3. Detaching...
Found game.dat process. PID 12420
*** Starting CA public key patching routine ***
CA public key is expected value.
Successfully patched CA public key.
*** Starting hostname hooking routine ***
Injecting DLL into game.dat process...
Result of injection: Code -1073741582
 

I also have definately hooked correcly I am running RA3 in XP compatibilty mode pack 2 and am default running cnc online as admin

This is on windows 10 and despite all of this I still cannot get into game always getting connection failed 1-2. My best guess is its my router but as I am a student I am not able to afford broadband and have to use 3G is there anything I have not tried? These issues have been happening from about 1 am to 3 am GMT and 12:30 pm GMT on 29/12/2019

 

I massively appreicate the help thank you very much.

 

Attached Thumbnails

  • Capture123.JPG
  • Capture.JPG
  • Screenshot_2019-12-29 Archer MR200.jpg


#2 Muddog007

Muddog007
  • New Members
  • 1 posts

Posted 31 December 2019 - 12:28 AM

Hi Cosmic,

I've had a similar issue when attempting to play Co-op online.

 

Could you confirm which screen you would see your connection failure on?

 

Was it at startup, when signing into the multiplayer server, or joining a game?

 

Kind regards,

Muddog


Edited by Muddog007, 31 December 2019 - 12:47 AM.


#3 Cosmic_Candi

Cosmic_Candi
  • New Members
  • 2 posts

Posted 31 December 2019 - 02:14 AM

Hi!

 

The second screenshot has the connection failure from the debugger

 

I get the issue whenever I join a game and I or the host attempt to start the game in which the host will see that I have a failed connection.

 

I hope this helps!

Thanks so much,

Cosmic



#4 Faiths180

Faiths180
  • New Members
  • 1 posts

Posted 05 January 2020 - 07:24 PM

Hi.

 

I seems to have the same problem with startup of the game, same "Result of injection - Code: -1073741582" in the CNCOnline_Log file, i installed C&C Online and i installed Patch for RA3 and after that it won't start up throu C&C Online launcher or throu Origin, it comes up with message about game can't start due to connecton problem with licenseserver, check your internetconnetion and try again in couple of minutes.

 

I hope someone has a solution for this problem, i want to play online with my son, my nephew and possible my brother.   



#5 yozhura06

yozhura06
  • New Members
  • 2 posts

Posted 06 January 2020 - 01:23 AM

hola tener problema para conectarme a online alguien que me pueda a ayudan por favor






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users