Jump to content


Photo

could not connect to the battle for middle earth II online


  • Please log in to reply
6 replies to this topic

#1 lopuchovec

lopuchovec
  • New Members
  • 1 posts

Posted 14 April 2020 - 02:00 PM

I have an issue that when I try to log in with my server account it will just show a message that says Could not connect to the battle for middle earth 2 online. I have the 1.09 patch installed and it works and also I thought it was an issue with my t3a server account but I tried using my friends login which he uses to log in and it still didnt work and I got the same message. I tried to reinstall the t3a launcher and same thing keeps happening 



#2 Gurtgray

Gurtgray
  • New Members
  • 1 posts

Posted 19 April 2020 - 08:55 AM

similar problem, ive installed and also installed the seperate online host but the two dont seem to connect, just takes to ea launcher ion game



#3 BlackerTheBerry

BlackerTheBerry
  • New Members
  • 1 posts

Posted 02 May 2020 - 08:33 PM

Same Problem here.

 

Some extra data. We are both connected to the same router. Both Win 10 Pc's. Exact same installation. Mine works, his shows the exact same error.



#4 HexStrain

HexStrain
  • New Members
  • 2 posts

Posted 18 May 2020 - 06:59 PM

I have the same !!! help please :evilthinkin:



#5 kotuwa

kotuwa
  • New Members
  • 1 posts

Posted 22 May 2020 - 09:33 AM

is it still working?

someone reply above posts in this thread pls :)
when tried to play online, it asks EA username, pw and nickname... Register / Login. What should we do there?

Use revora username n pw or what?

:?:



#6 fahdbhatti

fahdbhatti
  • New Members
  • 1 posts

Posted 29 May 2020 - 02:22 AM

I have the same problem when i try to login with t3a server password it says could not connect to BFME2: ROTW online, are the servers still up and running??



#7 Kili0401

Kili0401
  • New Members
  • 1 posts

Posted 31 May 2020 - 01:33 PM

I use a Laptop and a PC, on the PC it works just fine, but on the Laptop i get this error.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users