Jump to content


Photo

Online Error, "You must download the Update"


  • Please log in to reply
No replies to this topic

#1 SordidSpectacle

SordidSpectacle
  • New Members
  • 1 posts

Posted 27 May 2020 - 10:36 PM

I've been trying for some two weeks now to get the Online working on RotWK, but no matter how closely I follow the directions on T3A:Online, time and time again, I keep getting the same message when I go into the 'Online' tab in the main menu:

 

"You must download the Update to play The Battle For Middle-Earth II: Rise of the Witch-King Online".

 

It prompts me with the options "OK" or "Cancel". "OK" will close the game and give me a tiny pop-up window telling me I need Administrative Rights to install a patch, which is ludicrous as I obviously have admin on my own computer. Now, to keep trying over and over I've had to delete all of my installed BFME games, patches, patch switchers, and mods and reinstall them following the T3A:Online directions with the diligence of a pre-med student studying for finals. I am honestly at my wit's end here. I don't know what I'm doing wrong, and have finally resorted to coming here, in hopes that someone on this forum will throw me a proverbial bone and rescue me from this ceaseless nightmare of file explorer pages, download links, and virtual drive mishaps.

 

I love computers.

 

 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users