Jump to content


Online Error, "You must download the Update"

  • Please log in to reply
6 replies to this topic

#1 SordidSpectacle

  • New Members
  • 1 posts

Posted 27 May 2020 - 10:36 PM

I've been trying for some two weeks now to get the Online working on RotWK, but no matter how closely I follow the directions on T3A:Online, time and time again, I keep getting the same message when I go into the 'Online' tab in the main menu:


"You must download the Update to play The Battle For Middle-Earth II: Rise of the Witch-King Online".


It prompts me with the options "OK" or "Cancel". "OK" will close the game and give me a tiny pop-up window telling me I need Administrative Rights to install a patch, which is ludicrous as I obviously have admin on my own computer. Now, to keep trying over and over I've had to delete all of my installed BFME games, patches, patch switchers, and mods and reinstall them following the T3A:Online directions with the diligence of a pre-med student studying for finals. I am honestly at my wit's end here. I don't know what I'm doing wrong, and have finally resorted to coming here, in hopes that someone on this forum will throw me a proverbial bone and rescue me from this ceaseless nightmare of file explorer pages, download links, and virtual drive mishaps.


I love computers.



#2 YungBFME

  • New Members
  • 1 posts

Posted 01 December 2021 - 04:46 PM

long shot, but did you ever find a fix?
I'm in the same situation myself atm.

#3 Angmar009

  • Members
  • 21 posts

Posted 03 December 2021 - 09:32 PM

You can fix this by uninstalling 2.02 from the uninstall02.exe, install patch 2.01, then reinstall 2.02

They don't care if support needs help until support decides they don't want to help anymore.

#4 Smarv

  • New Members
  • 1 posts

Posted 16 January 2022 - 03:15 PM

if everything else doesn't work try opening the game as an administrator, worked for me :) 

#5 Cookies3000

  • New Members
  • 1 posts

Posted 28 April 2022 - 12:53 AM

Running T3A:Online as admin solved it for me. Under properties -> compability -> tick the run as admin box press apply and start T3A:Online

#6 BedHead

  • New Members
  • 2 posts

Posted 27 May 2022 - 12:46 PM

You can fix this by uninstalling 2.02 from the uninstall02.exe, install patch 2.01, then reinstall 2.02

How do you do this? I am having the same problem, and running the shortcut as administrator and in Windows XP SP3 compatibility mode doesnt work either

#7 ahmed007boss

  • New Members
  • 1 posts

Posted 01 June 2022 - 03:44 AM

still not working any other solutions? 

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users