Jump to content


Photo

ROTWK Mod Problem - "MISSING:OBJECT"

bfme2 rotwk

Best Answer PPK, 29 June 2020 - 12:37 AM

I resolve this problem. I put lotr.str on data folder (with .ini files) and WORKED! haha :)

Go to the full post


  • Please log in to reply
3 replies to this topic

#1 PPK

PPK
  • New Members
  • 4 posts

Posted 27 June 2020 - 09:33 PM

Hello. I'm new here, create an account recently to solve this problem. I'm trying to create a new character following the tutorial made by Malvack (https://www.the3rdag...?apage=846#page). In the tutorial he creates a character based on the CaH mode, but mine is a copy of Boromir (totally), where I only changed skills, looks (the appearance of a Arnor infantry was placed) and Portrait / Button images. The problem is in changing your name according to lotr.str: I created the OBJECT string: ArnorErak and the other CONTROLBAR, and inserted it in the DisplayName field (myhero.ini). When I enter the game, its name, recruitText, reviveText and Hotkey appears "MISSING: OBJECT: ArnorErak". It seems easy to correct but I'm having difficulties, I started to deal with it a week ago. I put it to test, OBJECT: RohanTheoden and its CONTROLBAR, it appears the name correctly ("Theoden"). I appreciate the attention and help, thank you :)

 

myhero.ini

-----------

DisplayName = OBJECT:ArnorErak
RecruitText = CONTROLBAR:ArnorErakRecruit
ReviveText = CONTROLBAR:ArnorErakRevive
Hotkey = CONTROLBAR:ArnorErakHotkey

 

lotr.str

------

OBJECT:ArnorErak
"Erak"
END
 
CONTROLBAR:ArnorErakRecruit
"Test" 
END
 
CONTROLBAR:ArnorErakRevive
"Revive the fallen Hero, Erak"
END
 
CONTROLBAR:ArnorErakHotkey
"Era&k"
END

Edited by PPK, 28 June 2020 - 12:25 PM.


#2 JUS_SAURON

JUS_SAURON

    El Shaddai

  • Members
  • 1,552 posts
  • Location:Trinidad
  • Projects: BFME2 MOD - Power Of The Ring
  •   INI Coder

Posted 28 June 2020 - 06:37 PM

Get a pure(vanilla) lotr.str file
setup a mod using -MOD command 

save in the the mod , 
then copy paste rename and it should work 

try changing an existing name IN THE LOTR.STR file like Theodan , 
if you can successfully change his name , then it means the game reads your lotr.str file changes 

and you can add new ones at the bottom ( or anywhere really )



#3 PPK

PPK
  • New Members
  • 4 posts

Posted 29 June 2020 - 12:29 AM

Not work. I extracted from lang/English.big -> lotr.str. It's vanilla lotr.str, but same error. 

 

My folder contains data and lotr.str archives only, I created a new rotwk shortcut  on desktop with -mod "C:\Program Files (x86)\Electronic Arts\The Lord of the Rings, The Rise of the Witch-king\lotrbfme2ep1.exe" -mod "C:\Users\will_\Documents\ShaiyaMOD"



#4 PPK

PPK
  • New Members
  • 4 posts

Posted 29 June 2020 - 12:37 AM   Best Answer

I resolve this problem. I put lotr.str on data folder (with .ini files) and WORKED! haha :)







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users