Jump to content


Photo

RED ALERT 3: Unable to Connect to C&C Online

ra3 black screen ca public key not responding windows 10

  • Please log in to reply
4 replies to this topic

#1 OldTimeRocker

OldTimeRocker
  • New Members
  • 2 posts

Posted 02 July 2020 - 02:01 AM

Red Alert 3 version: The original DVD box that I bought 12 years ago. 

 

System: Windows 10 Home 64 bit

CPU: Intel Core i5-4690

Memory: 16GB RAM

Graphics: nVidia geForce GTX 1070

 

NOTE: Before I setup my C&C online profile, I was able to open RA3 and I played through the first campaign mission.

The only issue that I experienced is this: after launching the game, I would get a completely black screen for nearly 3 minutes before the UI opened. Also, I would get this same black screen for about 3 minutes if I left any menu area and clicking "BACK" to return to the Main Menu (extremely annoying, yes, but I guess I could live with it if the game worked!).

 

Then, after registering on C&C online and setting up my profile, I opened the game.  I still got that same black screen for about 3 minutes before I finally reached the menu/UI.  I then navigated to Versus->Online, and I entered in my credentials: 

 

URxgBb6.png

 

I entered in my email address that I registered with, and then I used my Online ID and Password that I used for my profile (not the ID that I registered with).

When I clicked "Login", the game froze for about 3 minutes, and then I received this error:

 

yULfOK5.png

 

I retried this a few times, but it gave me the same error each time, so I quit the game, and then tried to launch it again.  

After the "3 Minute Black Screen", I receive the above "Server Error" again - but this time, the game was completely locked up.

I could not click the "OK" button to close the error. I had to forcibly end the process in Task Manager.

 

In order to get back into the game, I had to delete the "GameSpyLogin.ini" file in the %appdata% "Red Alert 3" folder.  

But as soon as I re-entered my credentials and tried to connecting to CNC online again, I had the exact same problem outlined above.

 

I tried a few of the suggested tricks in the FAQ.  I set the compatibility of the cnconline.exe file to "Windows XP SP3".  

That didn't help. I thought it must be an issue with my firewall, so I tried allowing ALL traffic (in and out) for the CNC Online Launcher in my firewall, but that did not help at all.

 

I also made the below edit to my "options.ini" file in the Red Alert 3 %appdata% folder, and then made it "read only" (as suggested in your FAQ), but it unfortunately did not help:

 

FirewallPortOverride = 16000

 

Thanks in advance for your help, it's greatly appreciated.

 

OTR

 

 



#2 OldTimeRocker

OldTimeRocker
  • New Members
  • 2 posts

Posted 02 July 2020 - 02:46 AM

I figured it out!  My stepson suggested that I look for the latest patch since I installed the game from my original DVD.

 

I found the 1.12 patch from Patches & Scrolls (https://www.patches-...tch/962/7/21763) and downloaded it and applied it.  This fixed EVERYTHING I noted above.  I was able to re-hook the C&C client to the newly patched executable and then everything worked.  The patch also removed the dreaded "3 minute black-screen wait" that I had to endure before reaching the menu.

 

Hopefully this will help someone else.

 

OTR



#3 magor747

magor747
  • New Members
  • 1 posts

Posted 14 August 2020 - 08:22 PM

I have problem coop multiplayer conection failed 1-2 =(



#4 Darth_Mangan

Darth_Mangan
  • New Members
  • 1 posts

Posted 12 September 2020 - 01:31 PM

Hi OldTimeRocker

 

I have the same problem. I tried to download and install the patch you linked to, but I still get the same error message. Do I have to do something about Gamespy?



#5 steveyjay75

steveyjay75
  • Members
  • 6 posts

Posted 13 September 2020 - 03:29 AM

ive just downloaded ra3 off steam , i have also set up a revora account , an ea account and the c&c online laund pad

 

if i click on ra3 to launch it takes a fair while but it will launch the game but when i try and select online play it asks for me EA account but fails to recognise it once entered

 

the same happens for tiberium wars 

 

im sure there is a fix but if someone can offer me some advice id be greatful 

 

i can only assume my version of the game is current as i just downloaded it , if its not where do i find the update

 

thanks







1 user(s) are reading this topic

1 members, 0 guests, 0 anonymous users