Jump to content


Photo

C&C 3 TW CD freezes upon selecting online

c&c 3 help cd

  • Please log in to reply
2 replies to this topic

#1 ValentineDietrich

ValentineDietrich
  • New Members
  • 1 posts

Posted 01 September 2020 - 02:39 PM

Whenever I try to click online while playing command and conquer 3 tiberium wars (which I have on my disc) the game freezes/crashes. I've looked everywhere but could not find an answer. The game is hooked up with CNConline and works fully apart from online.

 



#2 Medstar

Medstar
  • Members
  • 27 posts
  •  Programmer/Help Team Member

Posted 01 September 2020 - 09:25 PM

With you saying that you have the CD version of the game, I take it that it's patched up to v1.9, yes?

 

Also, it sounds like the launcher is failing to hook your game due to insufficient privileges. I suggest setting both your game and cnconline.exe to always run as administrator by going to their Properties > Compatibility > Checking the box for Always run as Admin.

 

After setting the new settings to the exe's, launch C&C:Online's launcher, unhook your game, re-hook it, then close the launcher completely. After that, launch Tiberium Wars directly from CNC3.exe or the shortcut you have for it--the launcher should pop up and you will need to press the CNC3 button.

 

That should fix the issue; you may also try reinstalling the C&C:Online launcher to ensure that the registry keys it sets are added correctly (that sometimes tends to be an issue for some people).

 

Let us know if the above works for you or not; if it hooks correctly, the game should not freeze once you select the multiplayer button. If a different error occurs when logging in, then that is a different issue (i.e. general connectivity) that can also be solved.



#3 Yesman523

Yesman523
  • New Members
  • 1 posts

Posted 16 September 2020 - 11:43 PM

I seem to be having the same issue....however it is with every single game. I followed what you mentioned above and made sure to click the box for run as admin. However when i run the game the following error pops up.

 

Missing required file "ssleay32.dll" 

 

Not sure what to do about this. 

 

Much help appreciated. 

 

I should mention that i run the game through origin. When i run the game without CNC Online and i click "online" in the main menu it also freezes on me.


Edited by Yesman523, 16 September 2020 - 11:44 PM.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users