Jump to content


Photo

Problem with CNConline installation

technical problem

  • Please log in to reply
7 replies to this topic

#1 NARVEK

NARVEK
  • Members
  • 5 posts

Posted 01 September 2020 - 09:24 PM

When installing CNConline,  the following inscription appears. What needs to be done to solve this problem?
 

Attached Thumbnails

  • File.PNG


#2 Medstar

Medstar
  • Members
  • 27 posts
  •  Programmer/Help Team Member

Posted 01 September 2020 - 09:35 PM

That sometimes happens to people when their registry permissions aren't set correctly. C&C:Online adds in "debugger" keys in order to hook into your game and redirect all of the network activity to our servers instead of the now-defunct GameSpy ones.

 

You may need to add the registry keys in manually in order for the C&C:Online launcher to install correctly; it tells you which keys are not being added correctly (like in your screenshot).

 

Just add in the keys yourself at the following locations in your registry that the installer is complaining about; if you would like a .reg file that does all of that automatically, let me know and I will provide one (some people are iffy about adding .reg files, so I always ask before forcing it on someone XD).

 

If you get write errors when trying to manually add the keys, then that means you need to gain ownership of that section of your registry, which you can Google how to do.



#3 NARVEK

NARVEK
  • Members
  • 5 posts

Posted 01 September 2020 - 09:57 PM

Yes i need a .reg file that does all of that automatically



#4 Medstar

Medstar
  • Members
  • 27 posts
  •  Programmer/Help Team Member

Posted 01 September 2020 - 11:41 PM

Here ya go; just run it and it should add the keys automatically. Then try running the installer again and see if it's still complaining about the keys or not.

Attached Files



#5 NARVEK

NARVEK
  • Members
  • 5 posts

Posted 02 September 2020 - 09:18 PM

thanks all work

)



#6 NARVEK

NARVEK
  • Members
  • 5 posts

Posted 02 September 2020 - 09:18 PM

thanks all work



#7 DarkMatter75

DarkMatter75
  • New Members
  • 1 posts

Posted 05 September 2020 - 01:09 AM

Hi all, i have this exact same problem. I have gone into Regedit and changed permissions for the 4 folders, and even added the strings manually, but cannot get them to add through the regfile, it's the strangest thing i just get the errors same as the OP. Im not stupid when it comes to finding my way around a PC but this problem is strane. Wondering if it's a Windows 10 thing? Any suggestions? Thanks.



#8 Debenebis

Debenebis
  • New Members
  • 1 posts

Posted 17 September 2020 - 01:57 AM

Here ya go; just run it and it should add the keys automatically. Then try running the installer again and see if it's still complaining about the keys or not.

 

Why is that reg not working for me ? it always tells me i got keys used by other programs or i didnt have enough rigths ? what can i do ? 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users