Jump to content


Photo

Need help and guidance in OE


23 replies to this topic

#1 Tony33

Tony33
  • Members
  • 21 posts

Posted 01 February 2021 - 12:31 PM

I am learning how to use OE, but when it comes assigning different weapon through OE clause on the same hardpoint, it seems the value option in clause properties is limited and not expandable, ranging only from basic space marine, chaos, eldar and orcs to imperial guards. When I looked up in many mods, they use custom value in name_for_this_weapon_choice, so if I want to make a model and use custom value like other mods did, what should I do? I am using DC mod tools 1.20 in a DC setup. Thx in advance :)

 

Edit:2021/2/7 It seems more problems appear as I learn and try to modify/implement old or new models in-game, so I think its better to focus my problems in this one post :)


Edited by Tony33, 07 February 2021 - 01:32 AM.


#2 Moreartillery

Moreartillery
  • Members
  • 218 posts
  • Projects:Cinematic Battles

Posted 02 February 2021 - 06:19 AM

Go to

C:\Program Files (x86)\THQ\Dawn of War - Dark Crusade\ModTools\ToolsData

and open ConditionStringPresets.lua

 

You can added/remove options there.


Developer of the Cinematic Battles mod.

https://www.moddb.co...nematic-battles


#3 Tony33

Tony33
  • Members
  • 21 posts

Posted 02 February 2021 - 08:07 AM

Thx you so much, that's very helpful, and I really learned a lot from your OE tutorials :)



#4 Moreartillery

Moreartillery
  • Members
  • 218 posts
  • Projects:Cinematic Battles

Posted 02 February 2021 - 09:57 AM

Thx you so much, that's very helpful, and I really learned a lot from your OE tutorials :)

 

Thats good to hear. What are you working on?


Developer of the Cinematic Battles mod.

https://www.moddb.co...nematic-battles


#5 Tony33

Tony33
  • Members
  • 21 posts

Posted 02 February 2021 - 04:50 PM

 

Thx you so much, that's very helpful, and I really learned a lot from your OE tutorials :)

 

Thats good to hear. What are you working on?

 

I am actually just playing around, very new to the DoW mod though. I have some experience in some basic modding through Corsix very long time ago. After I got in these game again through mods like UA and Unification, I want to explore this modding world more :)

BTW, may I ask you one more question? I also came across some mod unit with custom variable name. Like in the famous Imperator titan unit, I found some variable named Weapon_Range_Tracking_Shoulder_l which is different from default option Weapon_Range_Tracking_Shoulder. And that hardpoint spot is pretty much just placeholder and dont have any further weapon code attached to it. Will adding custom variable like this be recognizable by the game engine? Thx :)


Edited by Tony33, 02 February 2021 - 04:52 PM.


#6 Moreartillery

Moreartillery
  • Members
  • 218 posts
  • Projects:Cinematic Battles

Posted 02 February 2021 - 05:49 PM

 

 

Thx you so much, that's very helpful, and I really learned a lot from your OE tutorials :)

 

Thats good to hear. What are you working on?

 

I am actually just playing around, very new to the DoW mod though. I have some experience in some basic modding through Corsix very long time ago. After I got in these game again through mods like UA and Unification, I want to explore this modding world more :)

BTW, may I ask you one more question? I also came across some mod unit with custom variable name. Like in the famous Imperator titan unit, I found some variable named Weapon_Range_Tracking_Shoulder_l which is different from default option Weapon_Range_Tracking_Shoulder. And that hardpoint spot is pretty much just placeholder and dont have any further weapon code attached to it. Will adding custom variable like this be recognizable by the game engine? Thx :)

I don't know. There are so many default hardpoints that I never tried to add more.
 


Developer of the Cinematic Battles mod.

https://www.moddb.co...nematic-battles


#7 Tony33

Tony33
  • Members
  • 21 posts

Posted 03 February 2021 - 02:32 AM

Thx anyways :)



#8 Tony33

Tony33
  • Members
  • 21 posts

Posted 07 February 2021 - 01:50 AM

I want to post more problems I faced here if I may ask :) And please forgive my English that I am not a native speaker.

 

I want to modify the imperator titan (from other people's work, but I wont publish it and just want to try modifying and studying along the way. But if thats inappropriate then plz inform me) so its shoulder mounted tower and guns can fire. The original model only fire its left and right arms, but oddly though whenever I try to review right arm (that plasma annihilator), the OE crash. BTW, above the head, the model contain 4 towers each mounted with a cannon barrel, a bigger cannon in the middle with a turret on the rear, and also four smaller turret at the edge of the whole castle like structure that atop the titan's head. And my plan is to activate all of them, giving them individual rotation and firing anims.

 

I have some basic knowledge about 3ds max, and I managed to add bones for all the new weapons. I also get to know some basic User Defined properties like Stale=yes and Forceinvisible=yes. The exported new models (just contains new anims) can be previewed well in the anim section in the OE, so I went on defining all required clauses, conditions and actions. After assembling them all into action tree 'default', I import it in-game.

 

But the problem is, the in-game model only does aim_horizontal_left action, other anims in its default model cant play, like vertically rotate its right and left arm. I also tried reviewing the model in OE by controlling the Variables panel on the bottom of OE. And it is exactly the case in-game. When I check individual motion, the anims play just as intended according to their variables. But when I preview them from the Action and Action Trees, the only responding anim is aiming its left arm horizontally. Same things happen in other firing anims as well, except even in individual action part, the firing anim wont work (I set them to a modifier with firing process).

I strictly study the OE setup of baneblade, which has a lot of turrets, but I still can't manage to make the thing work :(

 

Attached File  Action Tree 01.JPG   42.17KB   0 downloadsAttached File  Action Tree 02.JPG   29.76KB   0 downloads

 

The custom condition I added:

"Aim_Horizontal_Shoulder_Main_F",
"Aim_Horizontal_Shoulder_Main_B",
"Aim_Horizontal_Shoulder_Left_F",
"Aim_Horizontal_Shoulder_Left_B",
"Aim_Horizontal_Shoulder_Right_F",
"Aim_Horizontal_Shoulder_Right_B",
"Aim_Horizontal_Shoulder_Left_F_Sub",
"Aim_Horizontal_Shoulder_Left_B_Sub",
"Aim_Horizontal_Shoulder_Right_F_Sub",
"Aim_Horizontal_Shoulder_Right_B_Sub",
Just like that, I do it for also Aim_Vertical, Weapon_range_upgrade, weapon_range_firing, weapon_range_tracking.

Edited by Tony33, 07 February 2021 - 01:58 AM.


#9 Moreartillery

Moreartillery
  • Members
  • 218 posts
  • Projects:Cinematic Battles

Posted 07 February 2021 - 04:14 AM

It sounds like the stale property is not set correctly. Only the bones that are used in the animation should not be stale, all others should be stale.

To clarify, each aim should only have one bone that is not stale and the firing anim must not use the aim bones bones either.

Edited by Moreartillery, 07 February 2021 - 04:39 AM.

Developer of the Cinematic Battles mod.

https://www.moddb.co...nematic-battles


#10 Tony33

Tony33
  • Members
  • 21 posts

Posted 07 February 2021 - 07:44 AM

It sounds like the stale property is not set correctly. Only the bones that are used in the animation should not be stale, all others should be stale.

To clarify, each aim should only have one bone that is not stale and the firing anim must not use the aim bones bones either.

Ty so much! I dont really know how these User Defined properties work before lol. I will tinkered them all and check those problems :) Btw, I noticed there is another property called Forceskinning=yes, not sure how it work though.



#11 Moreartillery

Moreartillery
  • Members
  • 218 posts
  • Projects:Cinematic Battles

Posted 07 February 2021 - 09:30 AM

I don't remember what forceskinning does. Maybe brother Kek can answer this one.

Btw I assume your working on the imperator from UA but the someone else made a new model recently. Look at the 30k40k age of technology mod on moddb.

Edited by Moreartillery, 07 February 2021 - 09:58 AM.

Developer of the Cinematic Battles mod.

https://www.moddb.co...nematic-battles


#12 Tony33

Tony33
  • Members
  • 21 posts

Posted 07 February 2021 - 10:35 AM

I don't remember what forceskinning does. Maybe brother Kek can answer this one.

Btw I assume your working on the imperator from UA but the someone else made a new model recently. Look at the 30k40k age of technology mod on moddb.

Yea, saw that amazing project, very nice details on those models. I just modify that model to learn OE and for some self fun lol. But will start make my models some day and start my first project.



#13 Tony33

Tony33
  • Members
  • 21 posts

Posted 08 February 2021 - 09:16 AM

It sounds like the stale property is not set correctly. Only the bones that are used in the animation should not be stale, all others should be stale.

To clarify, each aim should only have one bone that is not stale and the firing anim must not use the aim bones bones either.

I have gone through all the bones again, and assign stale = yes accordingly as you suggested. So far the aiming problems are fixed :) They work pretty smoothly in-game.

But the firing animations is still in glitch. The intended animation is just a simple recoil process controlled by a single bone and this bone is linked to the horizontal aiming bone. I have checked through the bones, the firing bone is only without its stale = yes in its firing animation, tracking animation and idle animation. Besides that in death animation and vis_anim that firing bone is also without stale = yes. In firing animations and stuff, other bones are set to stale = yes.

 

The imperator originally doesn't have firing animations, just radiating beams out. So I am not sure its issue in action tree or stuff. The new cannon I set use a weapon modifier to control firing process. If I just set the modifier to none, the firing animation can be preview from action and inside default action tree's action layer through variables panel, but cant do so in default tree. The whole problem is missing the animation, the event, fx and markers work as intended though.



#14 Tony33

Tony33
  • Members
  • 21 posts

Posted 08 February 2021 - 10:52 AM

It turn out to be still the same issue, looks like the weapon bone shouldn't coexist with those idle anim that model originally packed with. I remove the old idle animation from default action tree, the model finally works correctly. But two last question there lol, the laser(beam like weapon) fire from a top the titan will often time shot to totally different direction, is it a problem of marker pivot orientations? I tried to fix that refering to other model's laser weapon, but the problem still there. And the other problem is, I tried forcing the weapon dedicated to face the titan's rear, but they still can attack the front despite they try to aim to some degree. Is it due to the attribute stuff or still OE thing?



#15 Tony33

Tony33
  • Members
  • 21 posts

Posted 09 February 2021 - 10:31 AM

I searched for some fx tutorials and learn that fx_target_group_name (found in event property in OE) I used in my testing models not match their setting in-game and direct to other hardpoint. Since I also use a custom defined hardpoint motion variable, so I added the custom value in EventGroupNames.lua found in ModTools/ToolsData. And the fx of my laser cannon can match correctly to where the hardpoint actually attacking.



#16 Moreartillery

Moreartillery
  • Members
  • 218 posts
  • Projects:Cinematic Battles

Posted 09 February 2021 - 01:23 PM

I spent some time today figuring out how to make a turret that can't fire forward, you might find it useful.

 

How to set up a turret that can't fire forward: (from the relic chimera)
1. set up horizontal aim animation normally
2. aim vert animation is relative to the guns facing, so if gun aims left then aim vert will start and end aiming to the right
3. use horizontal aim modifier to change the default direction. left is 75, right is 25
4. aim vertical modifier is set normally, ie 50

 

Also, I'd like to know if you had to add the new bones to the ref file?


Developer of the Cinematic Battles mod.

https://www.moddb.co...nematic-battles


#17 Tony33

Tony33
  • Members
  • 21 posts

Posted 10 February 2021 - 01:41 AM

Yes, I added horizontal and vertical bones to the ref file and all the anim files.

I just referred to the original imperator model, and set the new horizontal bones just like it did with those arms, facing right from Front view. After get in some looking into Relic's original model of Baneblade, I realized I should set horizontal bone facing upward or downward at least. So even though I set the bones to control the recoil animation and they align the same as the model facing, the actual horizontal movement control is a mess lol.

 

Back to the topic, do you mean I should just make a horizontal aiming animation only moving 180 degree? If so, should I also look into the weapon code as well (since in-game the attribute controls from a 360 degree animation perspective from my assumption?). 

 

Thank you so much for your answer, I will try to clean those messed bones up, but that massive 80+ animation files though lol.


Edited by Tony33, 10 February 2021 - 02:04 AM.


#18 Moreartillery

Moreartillery
  • Members
  • 218 posts
  • Projects:Cinematic Battles

Posted 10 February 2021 - 07:54 AM

Back to the topic, do you mean I should just make a horizontal aiming animation only moving 180 degree?

No. I think all aim horizontal animations should be 360 degrees. We set the default direction of the gun in OE with a modifier, then the weapon file defines the max traverse left and right relative to that OE modifier.

 

I also have a theory that all bones only need to be in the ref file. If true it would save you a lot of time adding new bones to a unit, since you'd only have to add new bones to the ref and save a copy of the ref to make new animations. Try it and let me know if it works. But make a back up of your animation files first.


Edited by Moreartillery, 10 February 2021 - 07:59 AM.

Developer of the Cinematic Battles mod.

https://www.moddb.co...nematic-battles


#19 Tony33

Tony33
  • Members
  • 21 posts

Posted 11 February 2021 - 01:25 AM

Try it and let me know if it works. But make a back up of your animation files first.

 

I was and I am afraid I will be occupied by IRL stuff for a while (might be 2-3 days), so might not have the time to go through a model with new bones. But during my test to find out why the laser cannon was off the target, I did change the mesh for that laser cannon, and only in Ref and the animation file that it is actually present and working. I also rotated the vertical aiming bone for that mesh as well in the same manner. And the in-game testing so far seems its okay by just changing the ref file and the anim file that bone is without stale = yes. Not sure about creating a new bone and link them with other though.

Not sure these information is enough :) But I was planning to test it out later.



#20 Tony33

Tony33
  • Members
  • 21 posts

Posted 18 February 2021 - 01:57 PM

I finished my first original model for the Hammerfall bunker. And would like to try out the aforementioned method to set bones for specific animation files.

But before all that, I want to know what is a good reference polygon number to find a balance between graphics and performance? How many polygon is a good starting ground to aim for if this structure intended to be a 3x3 size in-game?

 

Attached File  HmmrFllBnkr.PNG   367.74KB   0 downloads

 

This model is a hi-poly monster for sure (already 18k polygons now lol and without converting all polygons into triangles), and I would need to revisit and reduce unnecessary polygon before further texturing, animating and importing into OE.


Edited by Tony33, 18 February 2021 - 11:38 PM.




Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users