Jump to content


Photo

C&C ZH Cannot connect to other players, tried everything.


  • Please log in to reply
5 replies to this topic

#1 MaixeZulu

MaixeZulu
  • Members
  • 5 posts

Posted 22 April 2021 - 11:08 PM

First up I wouldnt post if i havent tried and read all of the suggestions available.

I can login normally to the online server and I can host or join game but it never connects..waiting for probe response and fails to connect


I have the game through origin no mods installed exept gentools 8.4 and hd bar, game runs smooth.
A small list of things i tried:

*Run as admin and compatibility xp sp3
*Installed fix for ultimate collection (got it through the "before you post" section.
*Successfully opened ports as described in dominator youtube video allong with any other fix from that video (send delay, firewall exeption 27900port set)
*Checked boxes for private and public connection in windows firewall settings
*Set correct local ip in game options

I really cannot wrap my head around this and I am starting to lose hope.
I was able to connect to other players when I was using gameranger but not c&c online servers.

Is there something else that is missing? Am I opening the wrong ports?
TCP
80
6667
28910
29900
29920
UDP
4321
27900

On a sidenote I can connect if I use two of my pc's throught the same connection and play normally with no issues online I just cannot connect to any other player, my region is Greece and connection is vdsl 100m/bits pc more than capable.
Any help is deeply appreciated.

#2 MaixeZulu

MaixeZulu
  • Members
  • 5 posts

Posted 23 April 2021 - 12:01 PM

It seems I am able to work around this problem by using a vpn.
I used nord vpn and also tried windscribe connected with the recomended/fastest server and input my ipv4 in the game options.
Now it seems that this is the fastest way to get it working with no other ports or modem setup required.

But can it be done without vpn like a regular game?

Edited by MaixeZulu, 23 April 2021 - 12:26 PM.


#3 ZF_Cervanthes

ZF_Cervanthes
  • Members
  • 82 posts
  • Location:Germany
  •  Tech Support

Posted 23 April 2021 - 09:23 PM

if such a error occurs a vpn is the only  thing that can solve these errors  it has to do with different connection pathways and ipv protocolls why some users have to use a vpn like windscribe  if you wish a more detailed explanation ask me

It seems I am able to work around this problem by using a vpn.
I used nord vpn and also tried windscribe connected with the recomended/fastest server and input my ipv4 in the game options.
Now it seems that this is the fastest way to get it working with no other ports or modem setup required.

But can it be done without vpn like a regular game?


Greetings from Germany!!! 
Sincerely

Cervanthes your Random nerd from the internet

If you want to contact me you can find me on Discrod: Astolfo-Chan#2077
 


#4 MaixeZulu

MaixeZulu
  • Members
  • 5 posts

Posted 24 April 2021 - 03:28 AM

Well I dont know I tried again with another machine in the house and it still does not connect to all players.
Do you guys connect like reguraly to all players in every game with no extra setup steps?

Its kind of a weird problem even with vpn player connection is not guaranteed...
Should I check any settings in the vpn itself (udp/tcp ipv6v4 etc?).
And yes if you can elaborate more np :).

One more thing I forgot to mention.
Please check this pinned post.

https://forums.revor...625#entry968625

This is the common connection issues wiki for c&c ZH but the images for recomended ports are no longer visible so I cannot see what the settings are.
Does anybody have them?
If not this post does not provide any information.

Edited by MaixeZulu, 24 April 2021 - 03:39 AM.


#5 mezo_96

mezo_96
  • New Members
  • 1 posts

Posted 06 May 2021 - 11:22 PM

i have the same problem brother :( don't know what to do 



#6 ZF_Cervanthes

ZF_Cervanthes
  • Members
  • 82 posts
  • Location:Germany
  •  Tech Support

Posted Yesterday, 11:20 AM

when you are using windscribe vpn and follow these instructions 

 if you have the programm installed you should have a little windscribe window on your desktop, in the upper left corner you should see 3 stripes click that and navigate through there until you find a switch labeled Ipv6 on default its turned on but we want to turn it off (your pc will have to restart after that) after your pc restarts the windscribe program should autostart (you can just minimize or close it if you dont want to play) but if you want to play you will do following:

1. make sure that NOTHING is draining data in the background (you will get 10gb of data for free every month that should be more than enough even if you play active)

2. activate windscribe and wait until its connected as soon as its connected you can check again if anything is draining data

3. launch the game

4. in the game main menu you go to options

5. change your online and lan ip to the second available option (or the one that does not match any of your ips you might have been using with hamachi or something)

6. connect to genreals online (note it can take a few trys until the game will let you connect)

7. start a match with your mate and see if its works

8. if not try to change host and change who is using windscribe ( for example you use windscribe and he dont but it wont load so he uses windscribe and you dont)

9. in some cases it can change who needs to use it over time sometmes even both players needs it while ( me and the boys always need to circle the windscrib using one if we play but only if we are more than 2 people so connections can be weird sometimes)

and if connection errors still occure try actiavting ipv6 again and if connections to other players still fail communicate with other players and check who is able to connect who and who can play with one single random player


Greetings from Germany!!! 
Sincerely

Cervanthes your Random nerd from the internet

If you want to contact me you can find me on Discrod: Astolfo-Chan#2077
 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users