Jump to content


Click "Online" tells me to make EA account (doesnt connect to t3a)


  • Please log in to reply
6 replies to this topic

#1 Ramboward

  • New Members
  • 1 posts

Posted 19 May 2021 - 02:58 AM

HELLO! My friends have all installed ROTWK and t3a and we all can play, EXCEPT one of them. Every time he installs the game, and tries to click the "online" button at the main menu, the game freezes and then ask him to make an EA account. It doesnt seem like the game itself is directed to the t3a servers. He is using the t3a launcher and has installed it perfectly. We are at our wits end with this one, any help or information would be great, thank you!

#2 Nafafi

  • New Members
  • 1 posts

Posted 21 May 2021 - 12:10 AM

Same :(

#3 Dcrien

  • New Members
  • 1 posts

Posted 01 June 2021 - 11:42 AM


#4 BigWetCarl

  • New Members
  • 1 posts

Posted 04 June 2021 - 05:25 PM

The same is happening for me

#5 thejasondt

  • New Members
  • 1 posts

Posted 19 June 2021 - 07:02 PM


#6 Voodoozz

  • New Members
  • 2 posts

Posted 01 July 2021 - 07:12 AM

Same for me.

#7 Kralkatorrik

  • New Members
  • 1 posts

Posted 01 July 2021 - 05:56 PM

Same for me. Tried reinstalling T3A already and have everything running as administrator and tried starting everything in compatibility mode for Windows XP Service Pack 3.
Still wants me to connect to EA Servers. Can't figure out a fix and all I see in Forums is "reinstall everything" but all other things work fine (Campaign, Skirmish, War of the Ring) so I think it's connected to T3A in some way.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users