Jump to content


"You must run the game from its install directory" - The Lord of the Rings: The Battle for Middle Earth

  • Please log in to reply
1 reply to this topic

#1 Ltlandpa

  • New Members
  • 2 posts

Posted 08 November 2021 - 08:13 AM

My buddy and I both ran into an issue with BFME1. 
We had the T3A client version 1.5, and the game generally launched fine. When we selected to update to client version 2.1.3, it seemed to break the launching of the game, causing the "You must run the game from its install directory" error to pop up, in place of a successful launch.

After browsing the internet, I found my solution was restoring the previous versions of \EA GAMES\ or \The Battle for Middle-earth ™\ (they appeared for me; the Restore button was greyed out, but the Open button worked, and I was thusly able to copy the folder, and paste it to replace the current folder containing the version of the game's .exe that wouldn't launch.

Immediately afterwards, my issue was fixed.

However, my buddy ran into the same "run from install directory" issue, and when I walked him through it, there was no previous version. I don't know if it needed a moment, if there was an issue with his file history/if his computer didn't automatically create a file save point like mine inexplicably did, or if there was a way to refresh the list that was overlooked... I made him ensure that in Windows File Explorer, under the "View" component of File Explorer's UI, the "Hidden Items" box was ticked, to ensure all files could be seen, and had him do this with \Program Files (x86)\ selected (under Program File's properties, "Hidden" wasn't ticked, so I assume for all of the subfolders/contents inside Program Files, nothing else would've been hidden [unless he needed to select Hidden, and then de-select it, making sure "apply changes to this folder, subfolders, and files" was selected]... 

Granted, he's now closed Windows File Explorer-- maybe the save point will crop up in a bit... But, I had him try launching the lotrbfme.exe file, the lotrbfme_.exe file... 

I think I tried to make sure that he had those files run as administrator, which he claims/believes is what caused some of the breaks, potentially, though I'd read elsewhere it could've been a fix, albeit not really fixing anything in my experience, but neither damaging anything, too. I had him set the .exe files to run in compatibility mode for Windows XP (Service Pack 2).... 

Nothing seemed to fix the issue. 

The 1.5.0 version of the client opens for him, but clicking "Launch BFME" gives that "run from install directory" error; as does running both .exe's from the \The Battle for Middle-earth ™\ directory. I tried having him use the 2.1.3 client, and trying to launch BFME hooked and unhooked, to no avail. Checking for updates on the 2.1.3 client shows it's up to date; I had him skip/ignore the update on the 1.5.0 client version, as I did without issues, after having obtained the... seemingly error-inducing T3AOnline_2.1.3.msi file, and running it. 

I don't know if he opened the T3AOnline_2.1.3.msi file, and actually ran the repair (I did, at one time). 

We kinda did the installations/downloads a bit differently, and I don't know if it contributed to the issue; when I got the .rar file for the game, to extract, I extracted it to my desktop, and got a folder named "The Battle for Middle-earth"; inside, now, I have the shortcuts/files: Advanced Zoom-out, How to install, Music Switcher, Patch Switcher, Replay Manager, T3A Online (moved that into the same folder), T3AOnline_2.1.3.msi, The Battle for Middle Earth shortcut, and The BfMe Desktop Mode shortcut. 
Additionally, inside the "The Battle for Middle-earth" folder, I have a folder named "Game Files", which contains setup.exe, setup-1.bin, and setup-2.bin.

Note that, prior to this time, my friend's had the game running just fine. We both ran into the same issue, and I reiterate, thus far his issue hasn't resolved.

I think he moved the "The Battle for Middle Earth" shortcut, so it's separated from the "The Battle for Middle-earth" folder, or whatever his equivalent was that he received from extracting the .rar file. I think he still has the same install directory; that being, the Program Files (x86)\EA GAMES\The Battle for Middle-Earth\ directory... and I can't imagine there's an issue, there. 

I don't know if the compatibility mode for Windows XP (Service Pack 2) or Administrative Mode would cause any issues; I should think not. But I think the issue is that some files have been... maybe corrupted, or gone amiss, or there's a major issue with T3A's 2.1.3 client, that maybe.. duplicates the game's .exe files, if not some other issue...

As I said, I was able to restore the folders to their original form, fixing the launching of the game... and I still have a now-functional 2.1.3 T3A client, that works with-or-without hooking. 

As an aside, the only reason this became an issue was because of my burning curiosity... we tried to play an online game together, and we didn't go through any technical set-up process, and got a failure to connect, a "Can't connect; waiting for probe response" message, followed by troubleshooting information regarding antiviruses, firewalls, and et cetera.

I mistakenly assumed that maybe my friend needed the updated client, or that he needed the shortcut named "T3A online" to... play online, though I think we both got the error message, so it was a client-side issue, as it were, for the both of us (I know fuck-all about port-forwarding, and neither do my friends... I don't even know/am not the primary owner of [login information for]  my router, and would be reluctant about changing router settings, if things went horribly wrong and something got broken/I somehow created a network security vulnerability). 

Anyways, I'm sure that, on my part, I probably need a guide/trouble-shooting/walkthrough on how to play Online BFME/to figure out why it wouldn't work (I don't think it was an issue of my friends' or I's firewalls/antiviruses-- at the very least, I wasn't notified of anything being blocked, and I think, in the process of setting up the game, I was asked if I wanted the install-wizards, or something, to handle firewall exceptions, or something of the sort-- I assume the process was the same, for my friend).

Anyways, if anybody else has gone through, and knows sure-fire, if not multitudes of solutions for the "run from install directory" issue, those solutions would be deeply appreciated.

My buddy just got frustrated about the issues coming up (he was kinda reluctant to follow through on trying for fixes, and is prone to just throwing his hands in the air instead of continuing to try fixing/troubleshooting-- kinda understandable, in part because it's to where he can't fix it) and he said he was considering just uninstalling-- not sure if he plans on reinstalling afterwards, though he was the one who wanted me to play the game (with him)... I did see some people suggest that reinstalling may fix it, and I don't know if that solution would pose a risk to his campaign save files (unless he can find and back them up, if that is a potential risk)... and, also, I'm not sure if that'd require a fresh download, and THEN installation, or simply and assumedly running "unins000.exe", and then, once more, running the "setup.exe" file. 

Again, any help and insight would be deeply appreciated; apologies for posting this, if there are similar topics on the forum already, but I hope this topic can receive some attention, and assistance.
Many thanks, in advance.

#2 Ltlandpa

  • New Members
  • 2 posts

Posted 08 November 2021 - 08:39 AM

Also, note, that my buddy ran into an issue, while his game was still launched/working; when he went to Online matches... he couldn't log in with his T3A account information! It said something to the effects of his username/nickname being taken. Did he just need to create a new T3A account, still using the same Revora login information?
He tried writing in a new nickname, to no avail. 

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users