Jump to content


My friend can not register


  • Please log in to reply
1 reply to this topic

#1 Metalpixel

  • New Members
  • 1 posts

Posted 13 November 2021 - 07:23 PM

Dear devs,

I made my friend install the game with AOTR, everything runs smoothly except for T3A. 
He went onto the website and tried registering for an account, it says that the Email and username are already taken. He tried with several usernames and mails but it doesn't work. 

Could you help us please ? 

Thanks ! 

#2 Pumpkin_Sweet

  • Members
  • 8 posts

Posted 16 May 2022 - 11:42 PM

Hey guys, had the same issue and it seems to be something to do with chrome.

it seems that certain browsers have issues with both the download link and sometimes the confirmation email.


If you have problems with either of these try a different browser.


I personally have confirmed that the the ancient tech of internet explorer works for both in my case.

Edited by Pumpkin_Sweet, 16 May 2022 - 11:46 PM.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users