Jump to content


Red Alert 3 (Steam) crashes during start up when hooked

  • Please log in to reply
4 replies to this topic

#1 Tigerpaw28

  • New Members
  • 3 posts

Posted 03 January 2022 - 10:02 PM

I am unable to get my Steam copy of Red Alert 3 to launch when hooked. If I try to load it from C&C Online the splash screen will show briefly and then RA3 crashes. If I launch from Steam, the Play button changes to Stop briefly and then goes back to Play, no splash screen, and C&C Online does not open. Launching from the desktop shortcut there's no visible indication that anything is running. Launching the executable directly will get C&C Online to run but there's no splash screen. My anti virus is disabled.


If I unhook it, it runs fine. Error log shows the following:

----- C&C:Online Launcher Start -----
Game: Red Alert 3
Red Alert 3 Install Path: C:\Program Files (x86)\Steam\steamapps\common\Command and Conquer Red Alert 3\
Started game with: "RA3.exe "
Caught CREATE_PROCESS_DEBUG_EVENT from Red Alert 3. Detaching...
Found game.dat process. PID 40448
ERROR: game.dat process not found.

C&C Online is running as an administrator as is RA3.I've tried running it with and without XP compatibility and other than resolving the initial patching error, there's no difference. I do not get a prompt to confirm the hook, which seems like an issue based on the guides, but nothing seems to get that prompt to show.

#2 ZF_Cervanthes


    Tech Support

  • Project Team
  • 441 posts
  • Location:Germany
  • Projects:Loosing my Sanity, THM, Discord Bot, some UDK stuff
  •  [Unofficial] King of Tech Support dont panic if one of your games is bullying you im here to save you

Posted 03 January 2022 - 11:13 PM

What OS are you running?

Greetings from Germany :D
if your issue got solved please mark your post as answered, it makes our work easier.
We also have a official discord server https://discord.gg/FbNJdMreQh u can find me on there as Cervanthes#3136 my dms should be open otherwise just pop a friend request :D
P.S. gamenights are held every Friday for Kane´s Wrath, Red Alert 3 and Zero hour come by and enjoy some games!

#3 Tigerpaw28

  • New Members
  • 3 posts

Posted 04 January 2022 - 01:58 AM

Windows 10

#4 Medstar

  • Members
  • 45 posts
  •  Programmer/Help Team Member

Posted 04 January 2022 - 10:06 PM

The prompt that should pop up is automatically accepted due to you launching C&C:Online as Administrator. Try also launching from the executable itself, not through the standard shortcut Steam makes.


If that doesn't work, then do the following:

1) Create a new shortcut to RA3.exe
2) Right click the shortcut and go to Properties
3) Under the "Target" field, go all the way to the end of whatever is in that textbox (past all quotation marks too) and add a space
4) After the space, add the following: -win -xres 1920 -yres 1080 (change the 1920 and 1080 values to whatever resolution your monitor is)

5) After this, double click the executable to launch the game (this will put it in windowed mode)

6) If the process is successful, close the game and go to the shortcut's properties again

7) Remove the -win parameter you put earlier and launch the game again through the shortcut

8) If all goes well, the game should be back in fullscreen and running properly

#5 Tigerpaw28

  • New Members
  • 3 posts

Posted 07 January 2022 - 02:17 AM

Ah, that explains the lack of prompt.


Running the executable directly results in the C&C Online window popping up using the RA3 icon in the taskbar oddly enough. Same result using the shortcut with the windowed mode and resolution parameters.


Nothing in the CnCOnline log file this time around.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users