Jump to content


Can't Download T3A launcher

  • Please log in to reply
2 replies to this topic

#1 Stealth_Meister1

  • New Members
  • 1 posts

Posted 02 March 2023 - 08:43 PM

I don't know why it's not working. I tried downloading it and it's not working. It shows up in the downloads, but the litle blue bar in the top right (I use edge) doesn't go away. Trying to open it does nothing. I looked at it in the folder and it shows as an unconfirmed download. I disabled my antivirus shortly to download it and it still wouldn't let me download it. I have no idea what to do.

#2 Sire_Faramir

  • Members
  • 23 posts

Posted 04 March 2023 - 11:45 PM


problems like this are pretty common apparently. Anyway here how i solved this (edge): right click on the download button, copy link, paste link in the adress bar of another window of the browser, then manually click enter. Also the same strategy or variations of it (right click and open in new tab/window for example) applies on chrome, . I had the problem many times and other people i knew also and this always worked (sometimes after some trying/refreshing) so i dont think you need  to disable antivirus . Tried today before sending this and worked so i hope it works for you. Let me know


#3 Sire_Faramir

  • Members
  • 23 posts

Posted 04 March 2023 - 11:51 PM

By the way, if any moderator/administrator/whatever is reading this, since this problem is so frequent lately maybe you could pin a solution post/add this tip or a better one on the download page/ solve it

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users