Jump to content


[Red Alert 3](Steam) Connection 1-2 Error Solved

ra3 red alert 3 connection 1-2 co-op steam windows 11 vpn troubleshooting

  • Please log in to reply
No replies to this topic

#1 lastcall

  • New Members
  • 1 posts

Posted 18 May 2023 - 05:19 PM

The Issue

I was setting up CNCOnline and getting the dreaded "Connection 1-2 error" in the message window when attempting to start a co-op campaign mission (Soviet01) with both parties using C&C Online. After trying pretty much everything I could in these forums and through Google and Reddit, I finally solved the problem! A lot of people seem to face this issue when trying to play together on the same LAN but I've seen others on WAN even having the issue.


Verifying the Issue

The culprit is likely to be that you cannot receive pings from nntest.cnc-online.net:40000. You can verify this by downloading http://server.cnc-on.../NATNegTest.rar and running the .bat file. After you've run it, you're probably seeing this error:

Sending client PING [752737] from port 61569 to nntest.cnc-online.net:40000

Failed to receive any pings from nntest.cnc-online.net:40000.
It appears your router and/or connection is not capable of NAT negotiation.
==> You will need to use port forwarding and possibly configure a static port.
Press any key to continue . . .

You may even be seeing this error if you've properly configured your port forwarding on your router. (I could not determine why forwarding all listed RA3 ports did not resolve this issue so if anyone knows the answer to that, it would be appreciated.)


The Solution

Use a VPN. That's it. Simple, right? Okay, there's maybe a bit more than that to it. You'll need to use a VPN that passes the NATNegTest! Don't just assume your VPN does! (This was an assumption I made that led to a lot of headache.) A lot of people in this forum recommend Windscribe and I can now confirm that using Windscribe on both PCs on the same LAN results in successfully resolving this problem. I also made sure that both RA3 game clients selected the VPN IP address in the game's options menu. I'm sure other VPNs can work but, again, make sure to test them through the connection tool. If you're getting the failed to receive pings error still, the VPN you're testing is not going to work.

Edited by lastcall, 18 May 2023 - 05:22 PM.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users