Jump to content


Photo

need a bit of scripting help


  • Please log in to reply
1 reply to this topic

#1 killakanz

killakanz

    Infamy!

  • Hosted
  • 1,368 posts
  • Projects:Infamy!
  •  They've all got it infamy!

Posted 02 November 2005 - 11:32 AM

Hey guys.
You might be suprised to see me here, but this is my first stab at making missions...

I need some help though...
I got 2 reinforcing teams that enter through script just fine, but they should also guard a marked area once they arrive into it...
However, both teams go for a gangbang in the middle of the area and completly ignore enemy units...

Next problem: AI building stuff...

I got a build list, put the buildings in plenty of space, rotated them, gave the AI loads of cash, all this good stuff.
But they wont build anything... at all...
So after a while I gave up and gave them these buildings already built. The AI attempts to repair them, but wont rebuild even though I set 2 rebuilds on all buildings.

Also they wont try to build teams.
I set in the script that the AI should start building teams when a certain situation is met (a certain tank is destroyed).
The situation is met... and nothing happens...
The team is all basic units that do not require updates or gens promotions, just the buildings that are there already built.

I'm totally stuck on this... :(
Posted Image
New Tutorial Online Now!! Check it out!!

#2 TemporalityStorm

TemporalityStorm
  • New Members
  • 2 posts

Posted 02 December 2012 - 09:44 AM

Same problem is happening to me too.
I make the map, give the AI plenty of space, resources, InnerPerimeter and OuterPerimeter...., even the CombatZone.
The waypoints, and that stuff.
Even if I do all right, even following tutorials from ALL kind of site, It just won't work.
AI won't build anything.
Can anyone help?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users