Jump to content

Red Alert v3.03 beta internet game problem

  • Please log in to reply
3 replies to this topic

#1 Guest_Red Alert fan_*

Guest_Red Alert fan_*
  • Guests

Posted 30 April 2008 - 01:24 PM

Firstly my apologies if this is off topic or in the wrong area/forum. :(

I have used the VK's 1.05 fix for C&C 95 Gold and it solved the bugs I was having on winxp wery nicely.
Thank you for that! This inspired me to ask for help on Red Alert another old classic game.


Red Alert patched to version 3.03b
and also tested whit
Red Alert whit Aftermath addon patched to 3.03b

Using Windows XP (SP2) on all machines involved. Tested whit 2, 3 and 4 player online games.

All players have had the same versions when testing and so incompatibility should not be the case. Also tested on two computers in same room to make sure there are no user errors involved. :)

Seems to crash most of the time although sometimes it works (appears to be random). The crash usualy happens on the player who joins the game. Host appears to never crash.

Error message is given in windows (seems to be always the same error):

Application Error: C:\Westwood\REDALERT\ra95.dat
The instruction at 0041cb74 referenced memory at 00000185
The memory could not be read from

Click on OK to terminate the application

-Connecting to lobby works fine. (3.03 does not use west wood chat the lobby is fully integrated to game)
-Then the factions and map is chosen. All Ok sofar.
-When game setting are accepted and the host press Start problems appear.
-Host gets into the game, but units are frozen and after a while message appears that the game is waiting for the connections. -No matter how long the wait nothing happens except the game finaly returns to main screen after the timer counts to 0. (or if host presses "ESC"...)

The player who joins does not even see the game screen. He gets a black screen when the game should start. Again waiting does not help. There is the sound of windows error or exception heard in the background. Then there is the windows error message upon re-entering the desktop (shown abowe). RA95.exe in task manager shows "Not responding".

The game works perfectly fine whit version 1.08 only thing is that it is limited to maximum of two players in internet game. I know about LAN IPX emulators and that you can play using those (hamachi for example) to bypass that limitation, but it is not what I am looking for now. Since RA version 3.03 should play normaly over Internet whiout hamachi as 4 or even 8 player game it is frustrating that we cant get it to work. :p

I understand that v1.08 (Red Alert only) and v2.00 (whith aftermath addon) are the last truly official versions and v3.03b was a beta. Perhaps 3.03b never worked? Pehaps it worked before whit Windows 95/98, but now crashes on Windows XP for some reason? Anyone know more about this?

Ive tried using the standard THIPX32.DLL, the one suplied by westwood, and Scorpio's modified WinXP LAN dll. Those did not solve this crash. Also read somewhere that 3.03 doesn't even use the THIPX32.DLL -file. So no help in there. :)

Running the game in compatibility mode does not solve it either. Btw. v3.03 seems to start and run well even whitout compatibility modes set. Where as 1.08 needs to be run at Win 95 comp mode...

Or should I just be content whit using 1.08 limited to two players or a hamachi IPX LAN emulator method?

#2 Nyerguds

  • Members
  • 71 posts

Posted 30 May 2008 - 04:03 PM

I doubt VK will give support for any more C&C1/RA1 problems.. though you could try scorpio9a's new dll patch for TS/RA2. The old C&C1/RA1 patch doesn't work on RA1 3.03, but this new one might

#3 VK


    title available

  • Hosted
  • 360 posts
  • Projects:NPatch, ETS, NEngine, etc

Posted 14 June 2008 - 08:18 PM

Yes 3.03 doesn't use THIPX32.DLL at all.
all IPX code built into exe file :(

I haven't my computer with files and tools, so I can't help you :(
but later I can look into exe about your error.

honestly TD/RA have not very clear code, because they based on DOS versions of games.

developing line C&C 1: TD DOS -> RA DOS -> RA WIN -> TD WIN

code still have some old DOS stuffs, which work perfectly under Windows 95/98, but can't work very well on NT.
My site here: http://www.vk.cncguild.net - RP / NP / ETS / TOOLS.
Posted Image

#4 killa57

  • New Members
  • 4 posts

Posted 22 June 2008 - 01:03 AM

To Red Alert fan
nice i read what you posted not bad it happens to alot of red alert players on the internet section of red alert why? i have no idea but it could be alot of things like 1 ports not open 2 you trying to network on the internet section 3 you installed wwchat after the 3.03 patch. thats is what i think most of the problems are for red alert but hay i could be wrong if vk can fixs this problem he will be king of all kings and what you have described i have experienced but ill make sure ill post error i get here cya guys plz help ra1

*Edit* This is the error i got when i was online 1vs1 on the 3.03 version of red alert i joined the game played half way through and the game froze completly mouse didnt even move and the other guy got the count down but did not freeze like me. this happened twice *Edit*
1st game error RedAlert Game1
2nd game errorRedAlert Game2

Edited by killa57, 08 August 2008 - 01:02 AM.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users