Jump to content


Photo

ArmorUpgrade issue


  • Please log in to reply
5 replies to this topic

#1 Madin

Madin

    title available

  • Hosted
  • 686 posts

Posted 23 February 2009 - 10:23 PM

CODE
<?xml version="1.0" encoding="us-ascii" ?>
- <ArmorUpgrade xmlns="uri:ea.com:eala:asset" id="ModuleTag_InfusedCompositeArmorUpgrade" Permanent="true" ArmorSetFlag="PLAYER_UPGRADE_3">
<TriggeredBy>Upgrade_GDICompositeArmor</TriggeredBy>
<TriggeredBy>Upgrade_TiberiumInfusion</TriggeredBy>
</ArmorUpgrade>
The above code does not work. The idea is to experiment with cross faction upgrades. In this case if a nod militant squad get both the Tiberium infusion and the composite armor upgrades, they are suppossed to get a new unique armor.
The new armor template is done and referenced in a similar style to how the tiberium infused armor is referenced.

The nod squad can get the composite armor or tiberium infusion upgrade on its own. Has you can see from the above code, the armor set flag is unique (composite armor by itself is set to "PLAYER_UPGRADE_2").

Is the reason that the above code does not work because 2 "TriggeredBy" elements are not allowed?
If thats the case can I please have some pointers on how to get this unique armor to require that the player already has both tiberium infusion and composite armor?

#2 ravage

ravage
  • Hosted
  • 70 posts

Posted 24 February 2009 - 03:31 AM

try add RequiresAllTriggers="true" after ArmorSetFlag="PLAYER_UPGRADE_3" ?

#3 Madin

Madin

    title available

  • Hosted
  • 686 posts

Posted 24 February 2009 - 09:24 AM

Tried that, but still no joy. Does not like the code.

Edited by Madin, 24 February 2009 - 10:01 AM.


#4 Phil

Phil

    Force Majeure

  • Network Leaders
  • 7,971 posts
  • Location:Switzerland
  • Projects:Revora, C&C:Online
  •  Thought Police
  • Division:Revora
  • Job:Network Leader
  • Donated
  • Association

Posted 24 February 2009 - 03:25 PM

Does it fail to compile or does it just not work ingame?

revorapresident.jpg
My Political Compass

Sieben Elefanten hatte Herr Dschin
Und da war dann noch der achte.
Sieben waren wild und der achte war zahm
Und der achte war's, der sie bewachte.


#5 Madin

Madin

    title available

  • Hosted
  • 686 posts

Posted 24 February 2009 - 10:36 PM

Does it fail to compile or does it just not work ingame?

It just does not work ingame. The tiberium armor seems to override the new armor set.
So getting composite armor upgrade on its own will work, but adding tiberium infusion upgraede will not get me the new armor, but just the tiberium infusion effect.
Getting tiberium infusion first and then getting composite armor does nothing at all.

#6 CommieDog

CommieDog
  • Project Team
  • 81 posts
  • Location:Alaska (where even gravity is bigger)

Posted 02 March 2009 - 10:17 PM

You may need to add a ConflictsWith element to the other ArmorUpgrade modules telling them to not work when the other upgrade is purchased.
CommieDog™: The Original Proletarian Pet
Learn from your parents' mistakes: use birth control.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users