Jump to content


Photo

File Permissions


  • Please log in to reply
5 replies to this topic

#1 Jorg40

Jorg40

    <3 REVORA <3

  • Hosted
  • 2,284 posts
  • Location:Norway
  •  Zero Poster

Posted 19 July 2009 - 01:20 AM

Not sure if it is the server or not, but I am not allowed to set the file permissions through my FTP Client (tried FileZilla and SmartFTP) on my config.php file for CMS Frog.
I want to set it at 444. Read and Execute only. But each time I do that and save the settings, it changes is back to 755 as some sort of standard after closing the window.

Tried several other files aswell, but I can not get a file completely disabled from writing.

Hope someone saves my day. :p :p

#2 Banshee

Banshee

    One Vision, One Purpose!

  • Network Admins
  • 8,998 posts
  • Location:Rio De Janeiro, RJ, Brazil.
  • Projects:PPM, PPM: Final Dawn, OS SHP Builder, OS Palette Editor, OS W3D Viewer, VXLSE III, etc...
  •  Retired Network Leader
  • Division:Revora
  • Job:Maintenance Admin

Posted 19 July 2009 - 04:15 AM

Make sure your FTP program is not showing a cached directory. Try reconnecting to your FTP and see if it is still there. Chmod should work fine in the server, although we need to insist it sometimes.
Project Perfect Mod

Command & Conquer Mods, Mods Support, Public Researchs, Map Archives, Tutorials, Tools, A Friendly Community and much more. Check it out now!

Posted Image

#3 Bart

Bart

  • Network Admins
  • 8,524 posts
  • Location:The Netherlands
  • Division:Revora
  • Job:Network Leader

Posted 19 July 2009 - 10:06 AM

I want to set it at 444. Read and Execute only.

Do 644 then. Otherwise you'll lock yourself out forever. Btw, 4 is read, 5 is read and execute. Not that PHP files need execute anyway.
bartvh | Join me, make your signature small!
Einstein: "We can’t solve problems by using the same kind of thinking we used when we created them."

#4 Jorg40

Jorg40

    <3 REVORA <3

  • Hosted
  • 2,284 posts
  • Location:Norway
  •  Zero Poster

Posted 19 July 2009 - 01:01 PM

644 and the Frog CMS locks everything down because its not 444. :rolleyes: Damn frog...

I've turned of cache in SFTP but it looks like it is preventing me from locking myself out from the config file by always setting the file to User: write as a minimum. ^^ It hates me

#5 Phil

Phil

    Force Majeure

  • Network Leaders
  • 7,971 posts
  • Location:Switzerland
  • Projects:Revora, C&C:Online
  •  Thought Police
  • Division:Revora
  • Job:Network Leader
  • Donated
  • Association

Posted 20 July 2009 - 07:42 PM

I want to set it at 444. Read and Execute only.

Do 644 then. Otherwise you'll lock yourself out forever. Btw, 4 is read, 5 is read and execute. Not that PHP files need execute anyway.

Lock yourself out forever? You can chmod a file as long as you own it... even if it's previously set to '0000'. So chmodding to 0444 should work fine.

revorapresident.jpg
My Political Compass

Sieben Elefanten hatte Herr Dschin
Und da war dann noch der achte.
Sieben waren wild und der achte war zahm
Und der achte war's, der sie bewachte.


#6 Bart

Bart

  • Network Admins
  • 8,524 posts
  • Location:The Netherlands
  • Division:Revora
  • Job:Network Leader

Posted 20 July 2009 - 08:57 PM

Oh

Well, that's what they (all the hosters and online PHP tutorials) told me back when I was a noob :omg:
bartvh | Join me, make your signature small!
Einstein: "We can’t solve problems by using the same kind of thinking we used when we created them."




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users