Jump to content


Photo

Patch for 2.0psi? I didn't expect a patch for 2.0psi!


  • This topic is locked This topic is locked
76 replies to this topic

#1 Speeder

Speeder

    #ControlMOre

  • Hosted
  • 8,914 posts
  • Location:Czech Republic
  • Projects:Mental Omega
  •  Mental Omega Creator

Posted 19 November 2010 - 10:44 PM

Posted Image

Well, neither did I or I but expect the unexpected. 25 months have passed since the last update of 2.0psi and here it is - second and last patch for latest installment in 2.0 "series".

Why are we updating 2.0psi? First of all - because I now know how I should have fixed all the critical bugs in that version. That means, no more Apoc/BFRT crawling, Epsilon campaign progression issues etc. Everything's listed in the changelog below. Second - 3.0 will be different from version 2.0 so it shouldn't be left unpatched, at least not left with those gamebreaking bugs, right? Also, you will be able to feel the difference once you play 3.0 for the first time.

And god damn, 2.0psi should've been patched ages ago. So it is. Better late than never.

:thumbsupsmiley: Download patch 2 for MO2.0psi

What you should have in your YR directory is - YR patched to 1.001, NPSE 0022 (both available in our download section), core launcher for v2.0psi and new patch.

Now, to check if you have everything installed properly, you should take a look at the bottom-right corner in the first section of the main menu. It should look like this:

Posted Image

If it does say it's 2.0psi P2 / NPSE then you have both patch 2 and NPSE 0022 installed correctly.

Be warned - .xmlf file for Patch 2 has the same name as .xmlf for Patch 1 released 25 months ago, so make sure you have the right file in your game directory before activation!

Information given on the website about units, sides, features etc. may not be accurate, because the website will be only updated before 3.0 release!

* * *

Changes in Patch 2 (19.11.2010):

- gates for Soviets and Epsilon included

- Mission progression for Epsilon is fixed
- Spy infiltration bug ultimately fixed
- Battle Fortress/Apocalypse Tank will no longer lose their speed
- Apocalypse Tank is no longer an omnicrusher
- Elite Apocalypse Tanks target air units again
- Elite Mig Fighters can attack air units now
- Mig Fighter damage vs structures decreased
- Barracuda fires two missiles instead of one (with power equal to previous single missile)
- Sniper weapons no longer work against airborne infantry

- Shadow Tank requires Research Lab
- Virus requires Research Lab
- Sniper requires Allied Tech Center
- Mirage Tank requires Allied Tech Center

- Shroud is permamently removed in Foresight game mode
- Killer Whale no longer uses a sonic wave and can fight other underwater animals
- Soviet Repair Drone is amphibious now
- Grizzly Tank is no longer immune to mind control
- Robot Tank is buildable in skirmish again
- Tesla Trooper is no longer immune to tesla weapons
- Aeroblaze can no longer attack hover/naval units
- Black Eagle no longer uses a HMG against air units
- Scavenger armor increased by 50 points
- Focus Tank armor increased by 70 points
- Centurion Siege Crawler damage decreased
- EA/WW loading video removed
- Epsilon can build Research Lab in Bloody Games
- Epsilon Attack Dog no longer kills with poison
- Tank Bunker requires Epsilon Conyard only again
- Battle Bunker requires Soviet Conyard only again
- Americans receive veteran Tanya instead of veteran GIs
- Chinese receive veteran Flak Troopers instead of veteran Conscripts

- Abrams Tank will no longer attack parachuting Adepts in YUR04
- Virus will now auto target enemies in YUR04

- animations translucency removed
- updated soviet sidebar
- new art for Watch Tower
- added improved score screen animations for Epsilon by Blade
- updated Enforcer sound
- updated Epsilon Airpad cameo

Things which will NOT be fixed in 2.0psi:

- Assault Mappacks are read incorrectly by the mod, you have to rename AM mixes (see forums)
- New maps provided by the mod will most likely cause Reconnection Errors
- Tech slider set to 1 may cause crashes, don't use it

* * *

All right then, back to work on 3.0.. Stay tuned! Oh, and btw..

Edited by Speeder, 20 February 2012 - 02:07 PM.

mainbanner.jpg
bt_left.pngbt_fb.pngbt_yt.pngbt_tw.pngbt_md.pngbt_right.png
115776.png


#2 Black/Brunez

Black/Brunez

    Title? What title?

  • Project Team
  • 1,262 posts
  • Location:Somewhere in Brazil
  •  Mentalmeister - Random Annoying Guy

Posted 19 November 2010 - 11:36 PM

Is this going to be added on MODDB? That would be good, specially during the MOTY. :thumbsupsmiley:

#3 Zenothist

Zenothist

    Former Mentalmeister

  • Project Team
  • 1,727 posts
  • Location:The Netherlands
  •  Each post handcrafted for the discerning reader.

Posted 19 November 2010 - 11:36 PM

Well, hopefully my several hours of frantic testing payed off and I got most of the game breaking bugs. :thumbsupsmiley:

#4 subajk

subajk
  • Members
  • 11 posts
  • Location:Lithuania, Klaipėda

Posted 20 November 2010 - 10:58 AM

Wow, thanks speeder. Hope this help your mod to win moddb MOTY :thumbsupsmiley:
In Soviet Russia, You dont play Red Alert 3. You play Red Alert 2!

#5 Runown

Runown
  • Members
  • 61 posts

Posted 20 November 2010 - 02:27 PM

Posted Image

I'm sure I'm not the only one...Posted Image

#6 Speeder

Speeder

    #ControlMOre

  • Hosted
  • 8,914 posts
  • Location:Czech Republic
  • Projects:Mental Omega
  •  Mental Omega Creator

Posted 20 November 2010 - 02:34 PM

@Runown:

Haha, so you're updating YR to 1.001?

Well, if this happens that means two possible things:

1. Your YR is not an original copy and won't be patched to 1.001.

2. Your YR was patched to 1.001, you installed NPSE and then tried to patch it to 1.001 again.

Edited by Speeder, 20 November 2010 - 02:34 PM.

mainbanner.jpg
bt_left.pngbt_fb.pngbt_yt.pngbt_tw.pngbt_md.pngbt_right.png
115776.png


#7 Runown

Runown
  • Members
  • 61 posts

Posted 20 November 2010 - 03:05 PM

The second one...

sooo...What should I do? :l

#8 Speeder

Speeder

    #ControlMOre

  • Hosted
  • 8,914 posts
  • Location:Czech Republic
  • Projects:Mental Omega
  •  Mental Omega Creator

Posted 20 November 2010 - 03:10 PM

Well, I don't see a point in installing 1.001 again if 1.001 and NPSE are both already installed?

Edited by Speeder, 20 November 2010 - 03:10 PM.

mainbanner.jpg
bt_left.pngbt_fb.pngbt_yt.pngbt_tw.pngbt_md.pngbt_right.png
115776.png


#9 Runown

Runown
  • Members
  • 61 posts

Posted 20 November 2010 - 04:20 PM

Because I have this

Posted Image

and not that? Posted Image

#10 Speeder

Speeder

    #ControlMOre

  • Hosted
  • 8,914 posts
  • Location:Czech Republic
  • Projects:Mental Omega
  •  Mental Omega Creator

Posted 20 November 2010 - 04:26 PM

That means patch 2 is not being read. Did you extract the Mental Omega 20psi 00.xmlf file into the YR directory and then activated the mod via the core launcher?

NPSE seems to be installed just fine.

Edited by Speeder, 20 November 2010 - 04:26 PM.

mainbanner.jpg
bt_left.pngbt_fb.pngbt_yt.pngbt_tw.pngbt_md.pngbt_right.png
115776.png


#11 Runown

Runown
  • Members
  • 61 posts

Posted 20 November 2010 - 05:08 PM

Yes,but still appears MO 2.0psi / NPSE...

I tried to uninstall and reinstall NPatch,but nothing... u-u

#12 Darkstorm

Darkstorm

    Prime Minister of Norway

  • Members
  • 750 posts
  • Location:United States
  •  Ghost

Posted 20 November 2010 - 08:50 PM

Well the NPatch thing won't do anything, how about you reinstall MO. (download psi and the patch again)

Also I just realized, this is essentially 2.5 without the new missions and maybe some additional units.

29llidi.jpg


#13 Speeder

Speeder

    #ControlMOre

  • Hosted
  • 8,914 posts
  • Location:Czech Republic
  • Projects:Mental Omega
  •  Mental Omega Creator

Posted 20 November 2010 - 09:02 PM

No, it isn't. I've done changes to 2.0psi and it doesn't contain anything from 2.5/3.0 betas.

mainbanner.jpg
bt_left.pngbt_fb.pngbt_yt.pngbt_tw.pngbt_md.pngbt_right.png
115776.png


#14 Darkstorm

Darkstorm

    Prime Minister of Norway

  • Members
  • 750 posts
  • Location:United States
  •  Ghost

Posted 20 November 2010 - 09:27 PM

Well the changes are pretty much the same is what I mean.

29llidi.jpg


#15 DeviantProtagonist

DeviantProtagonist
  • New Members
  • 2 posts
  •  Freelancer

Posted 20 November 2010 - 09:49 PM

Feels good to have spies working proper. :p

But it's a shame about the Aeroblaze tweak, though. :ermm:

#16 Speeder

Speeder

    #ControlMOre

  • Hosted
  • 8,914 posts
  • Location:Czech Republic
  • Projects:Mental Omega
  •  Mental Omega Creator

Posted 20 November 2010 - 11:20 PM

Seriously, I can't believe nobody reported Aeroblaze bug before. :ermm:

mainbanner.jpg
bt_left.pngbt_fb.pngbt_yt.pngbt_tw.pngbt_md.pngbt_right.png
115776.png


#17 Runown

Runown
  • Members
  • 61 posts

Posted 20 November 2010 - 11:40 PM

fffffffffff-

The patch still don't work.I don't know what to do.I want to try it now. Posted Image

#18 Speeder

Speeder

    #ControlMOre

  • Hosted
  • 8,914 posts
  • Location:Czech Republic
  • Projects:Mental Omega
  •  Mental Omega Creator

Posted 20 November 2010 - 11:50 PM

Runown, what's the name of your MO2.0psi launcher file?

mainbanner.jpg
bt_left.pngbt_fb.pngbt_yt.pngbt_tw.pngbt_md.pngbt_right.png
115776.png


#19 Runown

Runown
  • Members
  • 61 posts

Posted 21 November 2010 - 12:07 PM

Runown, what's the name of your MO2.0psi launcher file?


Mental Omega APYR 20psi.exe...

Do you want to know it becauseee...?

#20 mevitar

mevitar

    (◉ _ ◉)

  • Hosted
  • 1,967 posts
  • Location:your imagination
  • Projects:Doom Desire
  •  :3

Posted 21 November 2010 - 12:20 PM

Because the launcher and the patch file should have same name (plus patch should have a 00 ending). So, in your case, the launcher should be named "Mental Omega APYR 20psi.exe", and the patch "Mental Omega APYR 20psi 00.xmlf".
ded signature

(◉ ᗝ ◉)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users