Jump to content


Photo

Fixing Connection Issues (Port Forwarding Guide)

bfme1 & bfme2

  • Please log in to reply
189 replies to this topic

#1 Mathijs

Mathijs

    Lounge Act

  • Division Leaders
  • 13,400 posts
  • Division:BFME
  • Job:Leader

Posted 21 September 2013 - 04:44 PM

If you are experiencing connection issues (being unable to connect to players after the host starts the game), please follow this guide.

 

 

After every step you can check whether it already works - then you don't have to do the other steps.

 

STEP 0:

In your firewall: Allow the game to send and receive TCP and UDP packages. You can temporarily disable it completely to see if it helps.

 

STEP 1:

Make sure that port 16000 (UDP) is opened in your router settings and forwards all internet traffic to your computer.

If you don't know how to do this, this website offers comprehensive guides for just about every router out there: http://portforward.com/

Use following tool to find out if the port is actually opened:

http://portforward.c...p/portcheck.htm

(Don't buy anything! Just read the information how you can forward your port!)

 

Be aware that an IP based forwarding rule might have to be adjusted every time you reboot your computer. Most routers allow to select your machine by MAC-address. If possible do the latter.

If more than one player wants to play from behind the same network, you will have to forward more ports. For example port 16000 UDP to the computer of player 1, and port 16001 UDP to the computer of player 2.

 

STEP 2 (especially helpful if you can not login):

Go to your options.ini file, which is usually located in

%appdata%\Roaming\My Battle for Middle-earth Files\ (for BFME2, %appdata%\Roaming\My Battle for Middle-earth Files(tm) II Files)

or, equivalently

C:\Users\ [Your Computer Name] \AppData\Roaming\My Battle for Middle-earth Files (for BFME2, C:\Users\ [Your Computer Name] \AppData\Roaming\My Battle for Middle-earth(tm) II Files)

Open a file called options.ini and add the following to it:

FirewallBehavior = 1
FirewallNeedToRefresh = FALSE
FirewallPortAllocationDelta = 0
FirewallPortOverride = 16000 

For BFME2/RotWK you should not add the 'FirewallPortOverride = 16000' line, there it won't allow you to host.

 

If present, remove the line

GameSpyIPAddress = xxx.xxx.xxx.xxx

Afterwards, make sure Options.ini is set to Read Only (right click > properties)

 

_______________________________________________________________________

 

If you CANNOT perform port forwarding, the only other option (not guaranteed to work) you can try is:

 

- Go to OPTIONS

- Press REFRESH NAT

 

When leaving a finished game, REFRESH NAT AGAIN.

 

IF YOU HAVE HAMACHI INSTALLED, PLEASE SHUT IT DOWN BEFORE PLAYING ONLINE

 

_______________________________________________________________________

 

For more info on port forwarding and connection issues, see the following:

  • Guide on how to fix CONNECTION PROBLEMS can be found HERE (thanks to user barrrrt)
  • Comprehensive FAQ that includes CONNECTION PROBLEMS can be found HERE (thanks to gamereplays)

Edited by ICT, 05 May 2017 - 05:55 AM.
clarifications

ykmHRUP.png


#2 barrrrt

barrrrt
  • Members
  • 30 posts

Posted 21 September 2013 - 07:51 PM

Hamachi shutting down didnt solve the problems during ea times. It has to be disabled in device manager!!!! The problem seemed to be, that the hierarchy of the network devices makes problems. Bfme always tries to add the ip address of the device, that is listed in the highest hierarchy and that is active.

Here is a short description, what you have to think about:

 

 

 

 

UPDATE: This link works now:

http://sdrv.ms/1h6rJYj


Edited by barrrrt, 22 October 2013 - 11:07 PM.


#3 Mathijs

Mathijs

    Lounge Act

  • Division Leaders
  • 13,400 posts
  • Division:BFME
  • Job:Leader

Posted 21 September 2013 - 07:57 PM

Thank you, very helpful!


ykmHRUP.png


#4 barrrrt

barrrrt
  • Members
  • 30 posts

Posted 21 September 2013 - 09:21 PM

Correct me if i'm wrong. But "refresh nat" just sets some stuff in options.ini. So if your options.ini is set up properly, you dont have to press "refresh nat" all the time.

 

People should consider, that we have the same problems that we had when we played on ea server. So if the Server developer hasnt changed the need to port forward, you have to do so!!!!!!  in the link (2 posts above) i add my thoughts and add the guides!!!!

 

For the most people the guides should solve the problems. but there are some routers (i hope just 5% of the people) that have to change stuff in the options.ini (firewall behaviour)..... what is that??? you will find some informations about that in the FAQ of gamereplays...

 

here we go... http://www.gamerepla...714&mode=linear



#5 Dark Avenger

Dark Avenger
  • New Members
  • 3 posts
  • Location:UK

Posted 23 September 2013 - 08:57 PM

I quite often loose connection, but I can't see any answers here that help me.  The Nat refresh doesn't help and I think my router is configured OK, the router IP address is shown as Gamespy login.  Any more suggestions please?



#6 barrrrt

barrrrt
  • Members
  • 30 posts

Posted 23 September 2013 - 11:35 PM

You are loosing connection at what time? In game? 

Or arent you able to connect to the server?



#7 THORONGlL

THORONGlL

    Avant-garde

  • Hosted
  • 449 posts

Posted 24 September 2013 - 10:18 AM

I quite often loose connection, but I can't see any answers here that help me.  The Nat refresh doesn't help and I think my router is configured OK, the router IP address is shown as Gamespy login.  Any more suggestions please?

have you tried this :
http://forums.revora...-to-the-server/



#8 Dark Avenger

Dark Avenger
  • New Members
  • 3 posts
  • Location:UK

Posted 25 September 2013 - 03:45 PM

Thanks for suggestions. Not many people online to be able to test my connection is OK now.  Will let you know if further problems.



#9 Radspakr Wolfbane

Radspakr Wolfbane

    The John Farnham of modding

  • Members
  • 7,722 posts
  • Location:less than 5 meters from my bed
  • Projects:Comeback tour
  •  The Retired Beard

Posted 19 October 2013 - 08:25 AM

That skydrive link is dead.


Break dancing into the hearts of millions


#10 barrrrt

barrrrt
  • Members
  • 30 posts

Posted 22 October 2013 - 11:05 PM

should work with this link i hope...

http://sdrv.ms/1h6rJYj



#11 sueffkopp

sueffkopp
  • New Members
  • 4 posts

Posted 16 December 2013 - 10:37 PM

I can't connect to more than 1 person it seems. Do I have to open ports and if yes, which? Is one port enough?



#12 Mathijs

Mathijs

    Lounge Act

  • Division Leaders
  • 13,400 posts
  • Division:BFME
  • Job:Leader

Posted 17 December 2013 - 11:13 AM

I suggest reading this thread:

 

http://forums.revora...can-i-fix-this/


ykmHRUP.png


#13 Cowell10

Cowell10
  • New Members
  • 2 posts

Posted 07 March 2014 - 05:22 PM

I don't have a lord of the rings file in roaming data?



#14 Mathijs

Mathijs

    Lounge Act

  • Division Leaders
  • 13,400 posts
  • Division:BFME
  • Job:Leader

Posted 07 March 2014 - 07:27 PM

What do you mean? If you have installed Battle for Middle-earth correctly, you should have a My Battle for Middle-earth Files folder in Application Data.


ykmHRUP.png


#15 Goossfrabaa

Goossfrabaa
  • New Members
  • 3 posts

Posted 04 April 2014 - 07:55 AM

hey guys! i've opened 16000 (UDP) port  but port checker says it's not open 
here's screenshoot. http://postimg.org/image/roux2gg8z/
router settings is above. help please



#16 ICT

ICT

    -

  • Division Admins
  • 2,804 posts
  •  -- MOC --
  • Division:BFME
  • Job:Online Admin

Posted 04 April 2014 - 07:59 AM

I've heard that in very rare cases this particular port checker fails even with the port being open.. the question is: are you able to play online wiithout problems? ;)


"To know what question we may reasonably propose is in itself a strong evidence of sagacity or intelligence. For if a question be in itself incongruous and begs for uncalled-for answers, it holds, sometimes, besides embarrassing the proposer, the disadvantage to seduce the unguarded listener into giving absurd answers, and we are presented with the ridiculous spectacle of one (as the ancients said) milking the he-goat, and the other holding a sieve beneath."


#17 Goossfrabaa

Goossfrabaa
  • New Members
  • 3 posts

Posted 04 April 2014 - 08:01 AM

i've played one game yesterday (1v1).

not sure about biger games and my conn is yellow not green



#18 ICT

ICT

    -

  • Division Admins
  • 2,804 posts
  •  -- MOC --
  • Division:BFME
  • Job:Online Admin

Posted 04 April 2014 - 08:14 AM

The color is due to network latency, it doesnt tell you anything about the port.


"To know what question we may reasonably propose is in itself a strong evidence of sagacity or intelligence. For if a question be in itself incongruous and begs for uncalled-for answers, it holds, sometimes, besides embarrassing the proposer, the disadvantage to seduce the unguarded listener into giving absurd answers, and we are presented with the ridiculous spectacle of one (as the ancients said) milking the he-goat, and the other holding a sieve beneath."


#19 Revolutzer

Revolutzer
  • Members
  • 11 posts

Posted 04 April 2014 - 08:27 AM

i've played one game yesterday (1v1).

not sure about biger games and my conn is yellow not green

The color of the connection sign just shows you how well the connection is: green = very good, yellow = good, red = slow BUT it is far away to be exactly, it shows at me that i have a ping of 320 ms while i got a ping of 30 ;)
So you dont have to be worry about playing bigger games. It should just work fine.

And could you tell me why the fuck you use Hitler as Avatar, not very elegant to be honest..


Edited by Revolutzer, 04 April 2014 - 08:28 AM.


#20 Goossfrabaa

Goossfrabaa
  • New Members
  • 3 posts

Posted 04 April 2014 - 09:10 AM

smileing hitler? c'moon! u must agree it's funny.
u can report me if u dont like.
well then i guess my conn is good.thanks for ur asnwers.
hope i wont get much lag or i'll torture a tied jew in my basement!






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users