Jump to content


Photo

"Could not connect to battle for middle earth online"


Best Answer Goldtouch, 04 November 2013 - 09:59 AM

Open the options.ini and alter the entry "GameSpyIPAddress = xxx.xxx.xxx.xxx" to "GameSpyIPAddress = 0.0.0.0" or just remove that line completely. 
 
Save your changes, then go properties and set the .ini to "read-only" mode.

Go to the full post


  • Please log in to reply
11 replies to this topic

#1 Goldtouch

Goldtouch

    title available

  • Hosted
  • 449 posts

Posted 04 November 2013 - 09:57 AM

  • Open the options.ini file
--- For Windows XP the Replays folder can be found in - C:\Documents and Settings\[yourname]\Application Data\My Battle for Middle-earth(tm) Files\
 
--- For Windows Vista or Windows 7 the Replays folder can be found in - C:\User\User Name\App Data\Roaming\My Battle for Middle-earth(tm)\
  • Remove the line "GameSpyIPAddress = xxx.xxx.xxx.xxx"
  • save it (shortkey = ctrl + S)
  • right click -> properties on "options.ini"  set the file as "Read-Only"
  • Start your game and login to the server

Edited by THORONGlL, 04 November 2013 - 09:58 AM.


#2 Goldtouch

Goldtouch

    title available

  • Hosted
  • 449 posts

Posted 04 November 2013 - 09:59 AM   Best Answer

Open the options.ini and alter the entry "GameSpyIPAddress = xxx.xxx.xxx.xxx" to "GameSpyIPAddress = 0.0.0.0" or just remove that line completely. 
 
Save your changes, then go properties and set the .ini to "read-only" mode.



#3 chopin89

chopin89
  • New Members
  • 3 posts

Posted 28 November 2013 - 12:55 AM

Hi I have followed the instructions above by changing the options.ini file to read only, but i am still getting 

Could not connect to battle for middle earth online error.. Help!  

#4 Phil

Phil

    Force Majeure

  • Network Leaders
  • 7,971 posts
  • Location:Switzerland
  • Projects:Revora, C&C:Online
  •  Thought Police
  • Division:Revora
  • Job:Network Leader
  • Donated
  • Association

Posted 28 November 2013 - 02:09 AM

Have you allowed BFME through your firewall?

When (date and time, as precise a possible) did you try to log in? And with which nickname?


revorapresident.jpg
My Political Compass

Sieben Elefanten hatte Herr Dschin
Und da war dann noch der achte.
Sieben waren wild und der achte war zahm
Und der achte war's, der sie bewachte.


#5 chopin89

chopin89
  • New Members
  • 3 posts

Posted 28 November 2013 - 02:31 AM

Yup, I have even try switching off firewall but it still dont work. I use bfme online edition by the way..

Try log in about half an hour ago, nickname is amituo



#6 Goldtouch

Goldtouch

    title available

  • Hosted
  • 449 posts

Posted 28 November 2013 - 01:40 PM

Things that could fix it:

  • Add game.dat to your firewall / antivirus its 'excluded list'
  • Run the shortcut of BFME as "windows xp service pack 2" and "run as administrator"
  • To test if maybe your router is causing it temporarly change to a DMZ .
    If you are able to connect then then you know your router is the cause...

Edited by THORONGlL, 28 November 2013 - 01:44 PM.


#7 chopin89

chopin89
  • New Members
  • 3 posts

Posted 29 November 2013 - 01:52 AM

Ah tried everything! exclude game.dat, run as admin, change to dmz.. it still shows the same message :(



#8 TheMesoria

TheMesoria
  • New Members
  • 3 posts

Posted 16 January 2014 - 05:16 PM

Hey i got similar problem, but when i tried to solve it, i could not find options.ini file. I guess its a problem, isn't it?

 

EDIT

 

Actually i found way to avoid problem, but still I am suprised that i do not have this...


Edited by TheMesoria, 16 January 2014 - 07:54 PM.


#9 EatontaWWII

EatontaWWII
  • New Members
  • 3 posts

Posted 28 May 2014 - 05:56 AM

Hey i got similar problem, but when i tried to solve it, i could not find options.ini file. I guess its a problem, isn't it?

 

EDIT

 

Actually i found way to avoid problem, but still I am suprised that i do not have this...

I cannot find the options.ini file either... how did you fix this problem?



#10 Hypnodisc

Hypnodisc
  • New Members
  • 3 posts

Posted 08 October 2014 - 05:47 AM

 

  • Open the options.ini file
--- For Windows XP the Replays folder can be found in - C:\Documents and Settings\[yourname]\Application Data\My Battle for Middle-earth(tm) Files\
 
--- For Windows Vista or Windows 7 the Replays folder can be found in - C:\User\User Name\App Data\Roaming\My Battle for Middle-earth(tm)\
  • Remove the line "GameSpyIPAddress = xxx.xxx.xxx.xxx"
  • save it (shortkey = ctrl + S)
  • right click -> properties on "options.ini"  set the file as "Read-Only"
  • Start your game and login to the server

 

Oh my word you are a life saver, sir. I've had the same connection issue for a while now, thought it was the server until someone responded saying it's been up the whole time. I did this and it instantly worked. You have my sincerest thanks.



#11 Lay Vee

Lay Vee
  • New Members
  • 1 posts

Posted 16 December 2014 - 10:31 PM

 

  • Open the options.ini file
--- For Windows XP the Replays folder can be found in - C:\Documents and Settings\[yourname]\Application Data\My Battle for Middle-earth(tm) Files\
 
--- For Windows Vista or Windows 7 the Replays folder can be found in - C:\User\User Name\App Data\Roaming\My Battle for Middle-earth(tm)\
  • Remove the line "GameSpyIPAddress = xxx.xxx.xxx.xxx"
  • save it (shortkey = ctrl + S)
  • right click -> properties on "options.ini"  set the file as "Read-Only"
  • Start your game and login to the server

 

Thank you!!!!!! I can now Join the Multiplayer :)



#12 Espiritviril``

Espiritviril``
  • New Members
  • 1 posts

Posted 30 March 2016 - 11:27 PM

You are the best , worked like charm thx.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users