Jump to content


Chasemm18

Member Since 13 Nov 2019
Offline Last Active Jan 14 2020 04:52 AM

Topics I've Started

CRASH War of the Ring

13 November 2019 - 01:49 AM

Hello, every time I try to launch the war of the ring the game crashes for me, I have the 2.02v8 installed as well as Age of the Ring 4.0, I am unable to install BFME2 v1.06 because the patcher says "old file not found" same with 2.01 for ROTWK, If it helps Im using the elamigos version of the game the Battle for Middle Earth Collection edition. Thank you!