Jump to content


[Red Alert 3] CO-OP Out of sync issue

coop ra3 out-of-sync

  • Please log in to reply
No replies to this topic

#1 padawan4330

  • New Members
  • 1 posts

Posted 15 January 2024 - 08:10 PM

Hello everyone,


I tried playing RA3 co-op with a friend.

I have the ultimate collection (Origin), while he has a standalone version (Origin).

About 5 seconds after we start the co-op game, we get the following error message (it doesn't matter who is hosting):

Out of Synch
Red Alert 3 has gone out of synch with the other match participants. It is possible that the other players have modified their game versions. This match cannot continue. Please restart Red Alert 3 to help avoid future de-syncs.

We've tried a versus game as well. We get the same error, but about 5-10 mins into the game.

I am using Windows 11 (emulated using VMware Fusion Tech Preview) on a M2 Macbook Pro, while my friend is using regular Windows 11.


We have also tried to play using the same "unofficial bootlegged" version of the game, but the result was the same.

This is the error log file:

----- C&C:Online Launcher Start -----
Game: Red Alert 3
Red Alert 3 Install Path: C:\Program Files (x86)\Electronic Arts\Red Alert 3\
Started game with: "RA3.exe "
Caught CREATE_PROCESS_DEBUG_EVENT from Red Alert 3. Detaching...
Found game.dat process. PID 7456
*** Starting CA public key patching routine ***
CA public key is expected value.
Successfully patched CA public key.
*** Starting hostname hooking routine ***
Injecting DLL into game.dat process...
Result of injection: Code -1073741582

If anyone has any advice, we would be grateful!

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users