Jump to content


Photo

Can't register a online account on BFME2


  • Please log in to reply
23 replies to this topic

#21 zvangi

zvangi
  • New Members
  • 2 posts

Posted 31 December 2019 - 01:27 AM

* Just an update. If i login with correct username and invalid password it throws " the user supplied an invalid password " but if i use my correct password it says it cannot connect to servers.



#22 Spidgeon

Spidgeon
  • New Members
  • 1 posts

Posted 07 January 2020 - 04:45 AM

Yeah doesn't work for me. Says user supplied an invalid password. I'm guessing not many people are playing anyway considering how many hoops you need to jump through ti get this working.



#23 hambone93

hambone93
  • New Members
  • 1 posts

Posted 13 May 2020 - 11:16 PM

All right, I found a solution. Change your nickname. Worked for me. I don't know why. Make it super uncommon.



#24 Iselwood

Iselwood
  • New Members
  • 2 posts

Posted 28 July 2020 - 06:37 PM

Hello everyone, i managed to do everything right on my pc and i can finally play the game and even login to the online servers! For bfme 2 i mainly followed this video's instructions: https://www.youtube....DO4udSs&t=1050s step by step and it worked for me even though it is a bit outdated. As for rotwk it was a bit more complicated and needed more searching to find solutions.

 

First of all i would like to express my thanks to all of you in the community, trying to keep it alive and keeping it real, all this work that has been done!

Secondly, i would like to ask some of you guys who know what's going on and know what's important to make the online work, please do an updated youtube video or something like the one in the link i sent, guiding step by step once again, both for bfme 2 and rotwk, explaining the differences and what needs to be changed in order to play bfme 2 or rotwk.

 

 

Finally, the main reason i do this post is because i called a friend of mine to draw swords with me again in Middle-earth, and we did a phone call and step by step i was guiding him to install the bfme 2 just the way i did for my pc, together with the video in the link again. Everything worked fine, until he opened the game, clicked online, entered his account's info and clicked login. Then, even though at one time he was able to enter and see the screen where you choose your country, the game took him out to his desktop, like he pressed alt-tab, and it popped up the following message:     Electronic Arts Inc.     Get a cheat code or game hint for your game and much more! etc etc, telling him again to register now or later in the ea. I also attached a photo of the message too.And he tells me that everytime he clicks login it pops up this message and get him out to desktop, not closing the game app, but not joining him to t3a-revora servers. Can someone help? Why even though we did exactly the same things, there is this difference happening to his pc ? The only extra information i can give you at the moment is that he is running windows 8 while i have windows 10, so maybe there is something going on with this. I know windows 8 are very bad with permissions etc etc. 

 

Again thank you for your work and your time on behalf of all the rest lotr and bfme fans! Let me know if you can help us with this.

 

So, next day my friend told me than he wasnt clicking on login, but his was clicking on register and thats why it popped up that window. So that problem is solved, but 5 days now im trying to make it work and there is always something. So we managed to enter the same lobby, everything is okay but we couldnt establish a connection.. Always the result was connection failed, we tried do almost everything. Firewall turn off, option.ini stuff, refresh NAT, everything except this port forwarding. Its the only thing i dont know how to do it correctly. I entered my router's site, put in my info, named the port 16000, also the port 27901 thorongils suggesting, but when i try to ensure i did everything alright, my port checker says my port is not open. I dont know what info i must put and how to set it up correctly. Really dont know what to do... external ip, internal ip? original ip? static ip? Someone please help!

Attached Thumbnails

  • 116396756_822715411466078_6909910573723655445_n.png

Edited by Iselwood, 29 July 2020 - 08:36 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users