Jump to content


Photo

[BFME2] T3A:Online Installation Support

bfme2

  • Please log in to reply
463 replies to this topic

#21 Eol Ecthelion

Eol Ecthelion
  • Members
  • 24 posts

Posted 03 April 2014 - 03:04 PM

posted log.log in gr



#22 Sick23

Sick23
  • New Members
  • 1 posts

Posted 03 April 2014 - 05:29 PM

i have the same problem to install as Eol Ecthelion

 

Win 7 and i´m the admin but get the same message as on his picture

 

pls help



#23 Mathijs

Mathijs

    Post-modern Shaman

  • Network Leaders
  • 13,623 posts
  • Projects:Age of the Ring
  • Division:Revora
  • Job:Leader

Posted 03 April 2014 - 05:33 PM   Best Answer

If you cannot install the launcher (because it says the Setup WIzard ended prematurely):

 

Please download this file: loginstall.bat and place it on your Desktop. Then copy/move the installer T3AOnlineBFME2_x.x.x.msi (only one installer, no previous versions!) to your Desktop. Double click the loginstall.bat and try to install the launcher. After it fails, grab the newly created log.txt and attach it to a post here.

 

If you are having difficulty getting the server to work and you are using the patch switcher:

 

Solution: Download the updated Patch Switcher from here.

 

If you are having an issue starting the game because you get an error saying the wrong CD is inserted:

 
Solution: Go to the BFME2 installation folder (Program Files\Electronic Arts\The Battle for Middle-earth™ II) Right click lotrbfme2.exe, Properties -> compatibility -> Change Settings for all users -> tick out the compatibility mode.


#24 ICT

ICT

    -

  • Veterans
  • 3,071 posts
  •  -- MOC --
  • Division:BFME
  • Job:Online Admin

Posted 03 April 2014 - 07:11 PM

i have the same problem to install as Eol Ecthelion

 

Win 7 and i´m the admin but get the same message as on his picture

 

pls help

 

Does it also happen when you run via rightclick - run as admin?

 

Also possible that your antivirus blocks the installation, you maybe want to disable it.

I've seen this problem when some files in %TEMP% cause a problem, you could clean that as well, just in case.

 

Eol Ecthelion, thanks for the log. Im not quite sure why the renaming fails. try the same please.


"To know what question we may reasonably propose is in itself a strong evidence of sagacity or intelligence. For if a question be in itself incongruous and begs for uncalled-for answers, it holds, sometimes, besides embarrassing the proposer, the disadvantage to seduce the unguarded listener into giving absurd answers, and we are presented with the ridiculous spectacle of one (as the ancients said) milking the he-goat, and the other holding a sieve beneath."


#25 3eorN'

3eorN'
  • New Members
  • 4 posts

Posted 03 April 2014 - 07:12 PM

We have discovered an error with the current version of the BFME2 Patch Switcher, which makes it bug out our T3A:Online launcher.

Yea, I have patch switcher. I will wait for fix, I dont want to reinstall game now.



#26 Mathijs

Mathijs

    Post-modern Shaman

  • Network Leaders
  • 13,623 posts
  • Projects:Age of the Ring
  • Division:Revora
  • Job:Leader

Posted 03 April 2014 - 07:20 PM

 

We have discovered an error with the current version of the BFME2 Patch Switcher, which makes it bug out our T3A:Online launcher.

Yea, I have patch switcher. I will wait for fix, I dont want to reinstall game now.

 

That's up to you, but reinstalling only takes a minute ;)



#27 Ridder Geel

Ridder Geel

    Master Yelloh

  • T3A Staff
  • 10,778 posts
  • Location:The Netherlands (AKA: Holland)
  • Projects:RC Mod + SEE + RTS Engine
  •  The Dangerous T3A Team Chamber Member
  • Division:BFME
  • Job:T3A Staff

Posted 03 April 2014 - 08:32 PM

Oh guys... Oddly my actual BFME 2 cd claims to not be a BFME 2 cd... sup with that? :p (It worked before getting the T3A: Online)... Just thought i'd mention it...


Ridder Geel

#28 Sharx

Sharx
  • New Members
  • 2 posts

Posted 03 April 2014 - 08:53 PM

i can't use the t3a: online server because it tells me after starting lotrbfme2.exe to put the right disk in my dvd drive (i put the right disk in it).

this problem doesn't appear when i use lotrbfme2_.exe ...but it doesn't include the t3a server.

i installed a clean bfme2 version, patched it to 1.06 and installed T3AOnlineBFME2_1.4.2.msi then.

i don't use any switchers or modifications and ran the game with administrator rights.



#29 Mathijs

Mathijs

    Post-modern Shaman

  • Network Leaders
  • 13,623 posts
  • Projects:Age of the Ring
  • Division:Revora
  • Job:Leader

Posted 03 April 2014 - 09:02 PM

i can't use the t3a: online server because it tells me after starting lotrbfme2.exe to put the right disk in my dvd drive (i put the right disk in it).

this problem doesn't appear when i use lotrbfme2_.exe ...but it doesn't include the t3a server.

i installed a clean bfme2 version, patched it to 1.06 and installed T3AOnlineBFME2_1.4.2.msi then.

i don't use any switchers or modifications and ran the game with administrator rights.

We are looking into this issue and will get back to you once we know more. Thanks for reporting it.



#30 Sharx

Sharx
  • New Members
  • 2 posts

Posted 03 April 2014 - 09:10 PM

the solution (thx to Smof) is to remove the compatibility mode from lotrbfme2.exe, which was set automatically.



#31 Smof

Smof
  • New Members
  • 2 posts

Posted 03 April 2014 - 09:11 PM

The "wrong CD" problem is solved for many.

 

Solution:

 

 Right click the .exe data (the file that starts bfme game) -> Properties -> compatibility -> Change Settings for all users -> tick out the compatibility mode.

 

Then it should work.

 

So all in all just take out the compatibility mode.


Edited by Smof, 03 April 2014 - 09:13 PM.


#32 Mathijs

Mathijs

    Post-modern Shaman

  • Network Leaders
  • 13,623 posts
  • Projects:Age of the Ring
  • Division:Revora
  • Job:Leader

Posted 03 April 2014 - 09:13 PM

The "wrong CD" problem is solved for many.

 

Solution:

 

 Right click the .exe data (the file that starts bfme game) -> Properties -> compatibility -> Change Settings for all users -> tick out the compatibility mode.

 

Then it should work.

 

So all in all just take out the compatibility mode.

Indeed? How strange.

 

Well, good. Thanks a whoooole lot friend.



#33 Eol Ecthelion

Eol Ecthelion
  • Members
  • 24 posts

Posted 03 April 2014 - 09:50 PM

 

i have the same problem to install as Eol Ecthelion

 

Win 7 and i´m the admin but get the same message as on his picture

 

pls help

 

Does it also happen when you run via rightclick - run as admin?

 

Also possible that your antivirus blocks the installation, you maybe want to disable it.

I've seen this problem when some files in %TEMP% cause a problem, you could clean that as well, just in case.

 

Eol Ecthelion, thanks for the log. Im not quite sure why the renaming fails. try the same please.

 

 

i readed the log, it said something about system restore. so i enabled system restore.

didnt work

turned off antivirus

didn't work

i readed something about a missing file (lotrbfme2.lcf). i found it, it was invisible

i made it visible.

 

and worked :DDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDD



#34 ICT

ICT

    -

  • Veterans
  • 3,071 posts
  •  -- MOC --
  • Division:BFME
  • Job:Online Admin

Posted 03 April 2014 - 09:53 PM

Windows... alright, very well!

I couldnt think what made the lotrbfme2.lcf fail... this is ..unexpected ;)

 

Great, have fun!


"To know what question we may reasonably propose is in itself a strong evidence of sagacity or intelligence. For if a question be in itself incongruous and begs for uncalled-for answers, it holds, sometimes, besides embarrassing the proposer, the disadvantage to seduce the unguarded listener into giving absurd answers, and we are presented with the ridiculous spectacle of one (as the ancients said) milking the he-goat, and the other holding a sieve beneath."


#35 Eol Ecthelion

Eol Ecthelion
  • Members
  • 24 posts

Posted 04 April 2014 - 08:02 AM

Well... months ago i made invisible all files i had not interest about, since i constantly im doing stuff on the bfme2 folder. Seems like the installer just can't find occult files.

 

By the way, do i need to copy any files to C:\Program Files (x86)\BFME2PatchSwitcher\106\ or C:\Program Files (x86)\BFME2PatchSwitcher\108\?

Because i have had to install it again. I suppouse when i switch to patch 1.00, then 1.06 or 1.8, i would be overplacing t3a files.

 

One more thing! sometimes the server falls down by 10-15 secs (dc menu to all players) :(


Edited by Eol Ecthelion, 04 April 2014 - 08:04 AM.


#36 ICT

ICT

    -

  • Veterans
  • 3,071 posts
  •  -- MOC --
  • Division:BFME
  • Job:Online Admin

Posted 04 April 2014 - 08:07 AM

...

 

By the way, do i need to copy any files to C:\Program Files (x86)\BFME2PatchSwitcher\106\ or C:\Program Files (x86)\BFME2PatchSwitcher\108\?

Because i have had to install it again. I suppouse when i switch to patch 1.00, then 1.06 or 1.8, i would be overplacing t3a files.

 

...

 

You could replace the lotrbfme2.exe in the directories 100/106 with the new lotrbfme2.exe from our launcher (after making a backup). That should solve the need to reinstall everytime.


"To know what question we may reasonably propose is in itself a strong evidence of sagacity or intelligence. For if a question be in itself incongruous and begs for uncalled-for answers, it holds, sometimes, besides embarrassing the proposer, the disadvantage to seduce the unguarded listener into giving absurd answers, and we are presented with the ridiculous spectacle of one (as the ancients said) milking the he-goat, and the other holding a sieve beneath."


#37 Bofur

Bofur

    The Bolicious One

  • Hosted
  • 1,765 posts
  • Location:England
  • Projects:The Age of the Firstborn - The Rebirth
  •  The Bolicious T3A Team Chamber Member

Posted 05 April 2014 - 08:08 PM

Well, this is embarrassing... :p

 

I have the no-cd problem, which is not solved by unchecking the compatibility box... I have patches, but they show up as 1.01 and 1.03 in program files... And the installer (.exe) which the T3A site linked to said it was installing 1.05... weird...

 

Any ideas? And I'd prefer not to no-cd/crack the game... I'm an honest sort... mostly :p


left64_by_obsidianlake-d5ruayp.pngAotF.pngright64_by_obsidianlake-d5ruf44.png


#38 deathgod

deathgod
  • New Members
  • 1 posts

Posted 05 April 2014 - 11:47 PM

Hello i have the following problem. I have windows 8.1 and i cant install the t3a launcher. This is what i get: http://www.gamerepla...howtopic=945829

#39 Antahrg

Antahrg
  • Members
  • 14 posts

Posted 06 April 2014 - 01:22 AM

"Any ideas? And I'd prefer not to no-cd/crack the game... I'm an honest sort... mostly :p "

I think this is legal if you own the original CD.

Deathgod : I have no idea about how to fix it, but I would try to start it in compatibility mode.

Edited by Antahrg, 06 April 2014 - 01:23 AM.


#40 ICT

ICT

    -

  • Veterans
  • 3,071 posts
  •  -- MOC --
  • Division:BFME
  • Job:Online Admin

Posted 06 April 2014 - 08:27 AM

 

Did you type your username into the "EA Account Name" field exactly as it is here?

Yes, I typed

3eorN'

 

Maybe I should register again with ingame "Register" button ? I didnt make it yet, maybe admin could firstly check whats up with the account.

 

 

3eorN', there seems to be an internal issue with your username, we are trying to firgure it out.


"To know what question we may reasonably propose is in itself a strong evidence of sagacity or intelligence. For if a question be in itself incongruous and begs for uncalled-for answers, it holds, sometimes, besides embarrassing the proposer, the disadvantage to seduce the unguarded listener into giving absurd answers, and we are presented with the ridiculous spectacle of one (as the ancients said) milking the he-goat, and the other holding a sieve beneath."






Also tagged with one or more of these keywords: bfme2

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users