Jump to content


Photo

Fixing Connection Issues (Port Forwarding Guide)

bfme1 & bfme2

  • Please log in to reply
194 replies to this topic

#141 ICT

ICT

    -

  • Veterans
  • 3,072 posts
  •  -- MOC --
  • Division:BFME
  • Job:Online Admin

Posted 24 May 2016 - 06:02 AM

You have to use your server account to login (that's the one you create when registering/logging in via t3aonline.net)

"To know what question we may reasonably propose is in itself a strong evidence of sagacity or intelligence. For if a question be in itself incongruous and begs for uncalled-for answers, it holds, sometimes, besides embarrassing the proposer, the disadvantage to seduce the unguarded listener into giving absurd answers, and we are presented with the ridiculous spectacle of one (as the ancients said) milking the he-goat, and the other holding a sieve beneath."


#142 Desarus

Desarus
  • Members
  • 5 posts

Posted 24 May 2016 - 01:24 PM

I will check on the gamespyip address line issue when I get home from work and update this post, not sure if I've edited that at all but I do remember adding the other four lines posted the options.ini document.

 

I was actually logging in with my server account login, I just called it the wrong thing in my first post haha my bad.

 

What are/how do I check for Hamachi Virtual Devices or other similar things that may be preventing me from playing? Sorry for a dumb question if this is a very simple fix.



#143 Desarus

Desarus
  • Members
  • 5 posts

Posted 24 May 2016 - 09:55 PM

The gamespyip address line was removed when I checked my options.ini file.



#144 ICT

ICT

    -

  • Veterans
  • 3,072 posts
  •  -- MOC --
  • Division:BFME
  • Job:Online Admin

Posted 24 May 2016 - 10:06 PM

Can you post the launcher logfile? It's in your %TEMP% directory. 

 

If you have any virtual network adapters or VPN software make sure to disable those.


"To know what question we may reasonably propose is in itself a strong evidence of sagacity or intelligence. For if a question be in itself incongruous and begs for uncalled-for answers, it holds, sometimes, besides embarrassing the proposer, the disadvantage to seduce the unguarded listener into giving absurd answers, and we are presented with the ridiculous spectacle of one (as the ancients said) milking the he-goat, and the other holding a sieve beneath."


#145 Desarus

Desarus
  • Members
  • 5 posts

Posted 24 May 2016 - 10:21 PM

Ok so I actually just found a new issue I think which is probably my main issue. I just went to check my Port Forwarding to make sure I had done that all correctly and when I went into it, what I had created last night was no longer showing. It looked as if I had never created a Port Forward. Now when I went to put it in again it tells me "Failure! Please check your inputs." Everything should be correct so I'm unsure why I'm getting the failure message. My info looks like this:

Common Service: Other

Service Name: BFME1

Service Type: UDP

Server IP Address: 10.0.0.66

Server IPv6 Address: lots of numbers and letters

Start Port: 16000

End Port: 16000



#146 Desarus

Desarus
  • Members
  • 5 posts

Posted 03 June 2016 - 12:43 PM

How do I post the launcher logfile? When I go to my %TEMP% directory I didn't see what you were looking for. I'm sure its there, I'm just not sure of the file/folder name I should be looking for.



#147 Demondestroyer2

Demondestroyer2
  • New Members
  • 2 posts

Posted 21 June 2016 - 03:18 AM

i cant join games because it says the game is in a different version but i have the newest update of the mod in my game



#148 goksukarax22

goksukarax22
  • New Members
  • 1 posts

Posted 03 July 2016 - 10:06 PM

guys i  cannot login. "login time out" any one help ?



#149 ICT

ICT

    -

  • Veterans
  • 3,072 posts
  •  -- MOC --
  • Division:BFME
  • Job:Online Admin

Posted 04 July 2016 - 07:48 AM

Did you follow all the steps in http://t3aonline.net/setup? Did you allow the game in your firewall? Did you follow STEP2 in the first post of this topic?


"To know what question we may reasonably propose is in itself a strong evidence of sagacity or intelligence. For if a question be in itself incongruous and begs for uncalled-for answers, it holds, sometimes, besides embarrassing the proposer, the disadvantage to seduce the unguarded listener into giving absurd answers, and we are presented with the ridiculous spectacle of one (as the ancients said) milking the he-goat, and the other holding a sieve beneath."


#150 Poulet

Poulet
  • New Members
  • 2 posts

Posted 16 August 2016 - 03:15 PM

So when i create a match and a friend joins it says that it is trying to connect or bad connection, i set it to false and my friend to and it automatically goes to true again, how do i fix this?

It used to work 


Edited by Poulet, 16 August 2016 - 10:08 PM.


#151 ICT

ICT

    -

  • Veterans
  • 3,072 posts
  •  -- MOC --
  • Division:BFME
  • Job:Online Admin

Posted 19 August 2016 - 10:26 AM

Sorry, I don't really understand your problem. Can you explain more please?


"To know what question we may reasonably propose is in itself a strong evidence of sagacity or intelligence. For if a question be in itself incongruous and begs for uncalled-for answers, it holds, sometimes, besides embarrassing the proposer, the disadvantage to seduce the unguarded listener into giving absurd answers, and we are presented with the ridiculous spectacle of one (as the ancients said) milking the he-goat, and the other holding a sieve beneath."


#152 EnriqueDK

EnriqueDK
  • Members
  • 10 posts

Posted 23 December 2016 - 12:10 AM

hi, maybe u guys can help me out with this problem

 

i have bfm2 v1.08 i can join game, and host, poeple can join me too , but i have poor conntion, and we can't get the game start... if i test my internet is over 900mbit up and down, 

 

i play on win10 any info u more need just say :-)



#153 ICT

ICT

    -

  • Veterans
  • 3,072 posts
  •  -- MOC --
  • Division:BFME
  • Job:Online Admin

Posted 23 December 2016 - 06:47 AM

You need to allow the game to connect through every firewall you night have installed. Add the game to the firewalls exception list.

On top of that you might have to configure port forwarding. There are many topics about it here, just read through them. Like the one you have posted in.

"To know what question we may reasonably propose is in itself a strong evidence of sagacity or intelligence. For if a question be in itself incongruous and begs for uncalled-for answers, it holds, sometimes, besides embarrassing the proposer, the disadvantage to seduce the unguarded listener into giving absurd answers, and we are presented with the ridiculous spectacle of one (as the ancients said) milking the he-goat, and the other holding a sieve beneath."


#154 Periquito

Periquito
  • New Members
  • 3 posts

Posted 30 December 2016 - 12:00 AM

Hi,

 

I'm using the Battle for Middle Earth + Patch 1.06 T3A from your webpage.

When I install it on Windows 7 it works perfectly, and I can enter your servers. Life is that I must use Linux (Ubuntu 14.04).

 

I tried wine on it, and it installed and worked fine - I can play Skirmish as if I was on windows.

However, when I try to enter the servers, it says "Login timed out". This does not happen on Windows 7.

 

I ran "sudo ufw disable", and added in the "/etc/hosts" file the line "192...(IP) myhostname", where "myhostname" is my hostname.

But it did not solve the issue, the message "Login timed out" still pops up.

The ports are forwarded on the router.

 

Any idea on how to proceed/what to check?

Thank you very much!

 

(The temp file shows the same as the people above,

----- T3A:Online Client Start -----
BFME Install Path: C:\Program Files (x86)\EA GAMES\La Batalla por la Tierra Media™\
Found game.dat process. PID 43
CA public key is expected value.
Successfully patched CA public key.
Injecting DLL into game.dat process...
Result of injection: Code -1073741595

)

 

(Options.ini file,

AudioLOD = High
FixedStaticGameLOD = High
IdealStaticGameLOD = High
IsThreadedLoad = yes
Resolution = 1024 768
StaticGameLOD = High
TimesInGame = 1
FirewallBehavior = 1
FirewallNeedToRefresh = FALSE
FirewallPortAllocationDelta = 0
FirewallPortOverride = 16000

)


Edited by Periquito, 30 December 2016 - 12:05 AM.


#155 Periquito

Periquito
  • New Members
  • 3 posts

Posted 30 December 2016 - 03:24 PM

Maybe I got the source of the problem:

 

So far I've run "wine lotrbfme_.exe", skipping the T3A launcher, and the game runs well (except from the connection to the server, "login timed out").

If I run "wine lotrbfme.exe", the T3A launcher opens, and when opening the game from it, the game crashes at the splashimage, if that's the name (the first image that appears, with The Lord Of The Rings on it).

 

Is it compulsory to open the game from the T3A launcher in order to access the servers? Do you know any idea on how to fix this? :'( I'm not a programmer/pro informatician, I have little idea. I'm just a highly motivated regular user.


Edited by Periquito, 30 December 2016 - 03:26 PM.


#156 ICT

ICT

    -

  • Veterans
  • 3,072 posts
  •  -- MOC --
  • Division:BFME
  • Job:Online Admin

Posted 30 December 2016 - 06:04 PM

Unfortunately the launcher is required to redirect the games connection to our server. You can't get it to work with wine. We're working on a new launcher though, which might allow playing under wine in the future.


"To know what question we may reasonably propose is in itself a strong evidence of sagacity or intelligence. For if a question be in itself incongruous and begs for uncalled-for answers, it holds, sometimes, besides embarrassing the proposer, the disadvantage to seduce the unguarded listener into giving absurd answers, and we are presented with the ridiculous spectacle of one (as the ancients said) milking the he-goat, and the other holding a sieve beneath."


#157 The_TITAN

The_TITAN
  • New Members
  • 3 posts
  • Location:GOA

Posted 29 January 2017 - 06:18 AM

ok now even im having some problems

with pfportchecker

it does not verify my router



#158 Lordsodor

Lordsodor
  • New Members
  • 1 posts

Posted 03 February 2017 - 12:49 AM

So I just Installed the game (Battle for Middle Earth 2), patched it, installed the T3A Launcher and got to connect to the server, thing is when I make a game and a friend of mine joins or not I get a red dot which the game says it's a "Bad Connection" and we can't start the game, I don't have a bad connection and this is kinda weird, already did the ini stuff, haven't done the portforwarding cause I'm afraid I might fuck something up and mess my router or something, but yeah that's the problem ¿can someone give me a hand or a hint?



#159 Brabox

Brabox
  • Project Team
  • 20 posts
  • Location:Netherlands
  •  Lord of Idiots

Posted 22 February 2017 - 01:20 PM

Hi guys, this is a question regarding the RotWK beta of T3A online.

 

Setting up the connections with 6 players or more takes a long time. Sometimes, it doesn't work at all. Also, the game seems to freeze a bit when connections are setting up.

 

I've opened UDP port 16000 (in fact, I'm forwarding all UDP ports above 8080 to my PC). I've verified I can set up connections using netcat.

 

Should everyone do this? What are the exact effects of doing or not doing it?

 

Also when I set the port to 16000 via the in-game options screen, that only seems to make things worse.

 

 

I guess what I want to ask concretely is:

how are the connections set up between players and how does port forwarding affect it? I'm pretty sure most players didn't open their port, but can still connect to each other apparently. That seems very odd to me. You didn't somehow implement uPnP right?



#160 ICT

ICT

    -

  • Veterans
  • 3,072 posts
  •  -- MOC --
  • Division:BFME
  • Job:Online Admin

Posted 22 February 2017 - 04:35 PM

No, UPNP has not been implemented and it is not guaranteed to work either. It might help in some cases though. The clients communicate between themselves and do not handle game connections via the server - that's why people need to be able to connect to each other directly. For that the some kind of NAT is needed (the game does not have any bypassing procedures implemented as far as I know). Usually it requires people to forward an UDP port from their router to their game client. If at least one player is unable to connect to all others the game won't start.

 

Some routers might use other techniques and do not require manual configuration, others can be set to DMZ temporarily to run checks.


"To know what question we may reasonably propose is in itself a strong evidence of sagacity or intelligence. For if a question be in itself incongruous and begs for uncalled-for answers, it holds, sometimes, besides embarrassing the proposer, the disadvantage to seduce the unguarded listener into giving absurd answers, and we are presented with the ridiculous spectacle of one (as the ancients said) milking the he-goat, and the other holding a sieve beneath."





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users