Jump to content


Photo

Fixing Connection Issues (Port Forwarding Guide)

bfme1 & bfme2

  • Please log in to reply
203 replies to this topic

#181 ICT

ICT

    -

  • Veterans
  • 3,072 posts
  •  -- MOC --
  • Division:BFME
  • Job:Online Admin

Posted 16 May 2017 - 06:05 PM

Can you try to login to https://t3aonline.ne...count/profiles/ and create a new profile there?

 

With that profile (as your nickname) try to login again.


"To know what question we may reasonably propose is in itself a strong evidence of sagacity or intelligence. For if a question be in itself incongruous and begs for uncalled-for answers, it holds, sometimes, besides embarrassing the proposer, the disadvantage to seduce the unguarded listener into giving absurd answers, and we are presented with the ridiculous spectacle of one (as the ancients said) milking the he-goat, and the other holding a sieve beneath."


#182 Lenwe137

Lenwe137
  • New Members
  • 2 posts

Posted 16 May 2017 - 06:29 PM

It doesn't work. Same error message as before.



#183 ICT

ICT

    -

  • Veterans
  • 3,072 posts
  •  -- MOC --
  • Division:BFME
  • Job:Online Admin

Posted 16 May 2017 - 06:37 PM

I get an immediate disconnect from your side. Are you sure there is no antivir or another firewall blocking the connection?
I mean you can try to move the options.ini out of your directory or use an empty one and start trying to connect with that, if nothing else helps.


"To know what question we may reasonably propose is in itself a strong evidence of sagacity or intelligence. For if a question be in itself incongruous and begs for uncalled-for answers, it holds, sometimes, besides embarrassing the proposer, the disadvantage to seduce the unguarded listener into giving absurd answers, and we are presented with the ridiculous spectacle of one (as the ancients said) milking the he-goat, and the other holding a sieve beneath."


#184 Anfalas10

Anfalas10
  • New Members
  • 2 posts

Posted 25 May 2017 - 05:44 AM

Hey I have followed all the instructions here:

 

https://forums.revor...rwarding-guide/

https://forums.revor...gin timed out

 

and my login is still timings out. If I have installed the launcher do I need to open it again. Is it not integrated into the game? I cannot however find the T3AOnline_Log.txt file. I am aware the admin says that is a result of incorrect installation but I have followed the instruction and videos multiple times. Any help is appreciated.



#185 darksplinter

darksplinter
  • New Members
  • 2 posts
  • Location:Reading, PA

Posted 13 August 2017 - 10:55 PM

I need help on windows 10, my mcafee expired but the connection is still open even with the firewall on. still having trouble starting and joining a game 

 

 

 



#186 davestarky

davestarky
  • New Members
  • 2 posts

Posted 20 August 2017 - 05:36 PM

Hello, I need help, the installation was succesful but I keep getting the gamespy online menu, and it should be a Revora online menu isn't it? Anyone else having this problem? I hope you can help me.



#187 ICT

ICT

    -

  • Veterans
  • 3,072 posts
  •  -- MOC --
  • Division:BFME
  • Job:Online Admin

Posted 20 August 2017 - 08:30 PM

For BFME2 it stays the old menu, just enter the t3a server account credentials.


"To know what question we may reasonably propose is in itself a strong evidence of sagacity or intelligence. For if a question be in itself incongruous and begs for uncalled-for answers, it holds, sometimes, besides embarrassing the proposer, the disadvantage to seduce the unguarded listener into giving absurd answers, and we are presented with the ridiculous spectacle of one (as the ancients said) milking the he-goat, and the other holding a sieve beneath."


#188 davestarky

davestarky
  • New Members
  • 2 posts

Posted 21 August 2017 - 03:18 PM

Ok thank you, I already played and it was good. I seem to have a problem though: My game says I've disconnected while in game even though I keep playin normally but when I'm in the lobby it kicks me out of the online interface.



#189 Silverbeard

Silverbeard
  • New Members
  • 2 posts

Posted 22 August 2017 - 07:37 AM

Is anyone else having issues in connecting to an online game after the new update to T3AOnline_2.1.3 despite following all the guides above?
 
I have read and tried all the fixes and work arounds I can find on the T3A website, but nothing is fixing the issue.  I keep getting the NAT Firewall message that has long been a bug bear with this game since it was first released.
 
Any help would be great!


#190 Silverbeard

Silverbeard
  • New Members
  • 2 posts

Posted 22 August 2017 - 07:51 AM

For more info on port forwarding and connection issues, see the following:

  • Guide on how to fix CONNECTION PROBLEMS can be found HERE (thanks to user barrrrt)

 

 

The target of this link no longer exists, or is not accessible from here.



#191 Bijuklic

Bijuklic
  • New Members
  • 1 posts

Posted 13 November 2017 - 11:35 AM

how to play online with mobile internet? i checked my phone, firewall is off, yet in game says can't connect to players :( on my home internet it works fine



#192 ICT

ICT

    -

  • Veterans
  • 3,072 posts
  •  -- MOC --
  • Division:BFME
  • Job:Online Admin

Posted 13 November 2017 - 01:17 PM

In the worst case you'll have to use a VPN. I'm not sure how the mobile internet works in your case. You should have a look at the cnc support subforums, https://forums.revor...online-support/, I'm sure there are a few cases of people with mobile internet.


"To know what question we may reasonably propose is in itself a strong evidence of sagacity or intelligence. For if a question be in itself incongruous and begs for uncalled-for answers, it holds, sometimes, besides embarrassing the proposer, the disadvantage to seduce the unguarded listener into giving absurd answers, and we are presented with the ridiculous spectacle of one (as the ancients said) milking the he-goat, and the other holding a sieve beneath."


#193 4tuneakabenji

4tuneakabenji
  • New Members
  • 1 posts

Posted 14 December 2017 - 09:48 PM

Hi guys,

 

If you still have some issue with port forwarding, just try this tool: https://www.verigio....port-forwarder/

It works for us perfectly.  <:) 

Good luck and have fun on T3A! ;)



#194 Jokuc

Jokuc

    Hardcore Procrastinator

  • Members
  • 183 posts
  • Location:Sweden
  •  Mapper

Posted 27 April 2018 - 02:49 PM

Solving issue of port 16000 blocked even after portforward

 

So you have set up your Options.ini, you made the exceptions in the firewall and you've finally done the portforwarding people told you about... but you still can't connect to players, and the port tester fails to connect.

 

Finding the reason can be difficult, but a common problem that not many people know about is actually caused by your ISP (internet service provider). Most addresses you will find on the internet use the protocol IPv4, however this type of IP has been around for a long time and the addresses are running out. There is another protocol called IPv6, which will fix this issue, but it takes time to transition to this protocol with already established services. So in the meantime, a lot of ISPs have resorted into using something called Carrier-Grade Network Address Translation or CGNAT/CGN for short. This technology allows multiple users to share the same public IP-address, saving address-space.

 

A regular NAT takes a Private IP (the IP used on your home network to identify your computer, 192.168.1.25 for example), then converts it into a Public IP (the IP displayed on the internet, 85.132.133.196 for example). The difference between this and CGNAT is that multiple users behind a cgnat will share the same Public IP, but each user connected with this IP will be logged with a tag to identify where the traffic should be routed back to. Since this means you do not have your own unique IPv4 address but rather shares one with other people, it also means that you cannot control the ports for this IP and thus portforwarding is not possible. Your ISP is in control of the ports and if they do not have the specific port you need open, in this case 16000 udp, this is most likely what is causing the connection problems.  (note: this explanation is simplified)

 

So how do you know if you're behind CGNAT? First you can see if your public IP displayed on websites such as whatismyip.com is the same as the WAN IP listed in your router settings. If they are not the same, chances are you're behind cgnat. Some routers don't show WAN IP in the settings, sadly. But the best way to find out is to call your ISP and ask if you are behind a CGNAT or NAT444. If they say you are, tell them that you want it gone and you need a dedicated Public IP. Some ISPs will do this for free, others will charge you a small fee for it. Some even state on their website that they are using this technology so you can make sure beforehand that it's their doing.

 

If you want a more detailed explanation follow these links:

https://chrisgrundem...cgn-lsn-breaks/

https://www.a10netwo...rier-grade-nat/

https://www.networkw...-grade-nat.html

 

Edit: Made it easier to understand while including links to more detailed explanations.


Edited by Jokuc, 26 February 2020 - 01:11 AM.


#195 MooseMan

MooseMan
  • New Members
  • 3 posts

Posted 07 April 2019 - 04:35 PM

Thanks for your reply Jokuc, I've been trying all day to get this to work and then read your post and find out I'm behind a CGNAT...



#196 Bautmeay

Bautmeay
  • New Members
  • 1 posts

Posted 29 January 2020 - 07:33 PM

hello we encountered this problem when entering with my friend

 "connections are in progress, or connetion problem detected.Please click the Connections button where you can chech every player's connection and retry" who can help us


Edited by Bautmeay, 29 January 2020 - 07:36 PM.


#197 Bracco40

Bracco40
  • New Members
  • 1 posts

Posted 19 March 2020 - 09:11 AM

Hello everyone!
I’m trying to play BFME 1 and 2 with two friends of mine, and I can connect with one of them, but not with the other one. Already done:
-switch off firewall
-modify Options.ini as reported here https://forums.revor...rwarding-guide/

Can anybody please help? Thank you!

#198 Jokuc

Jokuc

    Hardcore Procrastinator

  • Members
  • 183 posts
  • Location:Sweden
  •  Mapper

Posted 21 March 2020 - 01:06 PM

Hello everyone!
I’m trying to play BFME 1 and 2 with two friends of mine, and I can connect with one of them, but not with the other one. Already done:
-switch off firewall
-modify Options.ini as reported here https://forums.revor...rwarding-guide/

Can anybody please help? Thank you!

 

Open port 16000 UDP. Pick your router model here and follow the instructions

https://portforward.com/router.htm



#199 soruthon

soruthon
  • New Members
  • 2 posts

Posted 22 March 2020 - 12:30 AM

Hello,

 

Battle for Middle Earth 2 - When I click  multiplayer ==> online in the main menu, the game freezes for about 5 minutes and then it takes me to the login page where it tells me "cannot connect to servers, please check internet connection" and then kicks me back to the main menu. Did I miss something when I installed everything? I signed up for an account, added the options file in Roaming, have tried to play under both 1.6 and 1.9, and am launching the game from the T3A launcher. Any help would be greatly appreciated!

 

Thanks!

 

Edit: I've added the following to the options.ini and still can't connect:

 

FirewallBehavior = 1
FirewallNeedToRefresh = FALSE
FirewallPortAllocationDelta = 0

 

I also deleted the GameSpy IP address line and bypassed Windows firewall.


Edited by soruthon, 22 March 2020 - 12:31 AM.


#200 Jokuc

Jokuc

    Hardcore Procrastinator

  • Members
  • 183 posts
  • Location:Sweden
  •  Mapper

Posted 25 March 2020 - 03:44 PM

When I click  multiplayer ==> online in the main menu, the game freezes for about 5 minutes and then it takes me to the login page where it tells me "cannot connect to servers, please check internet connection" and then kicks me back to the main menu. Did I miss something when I installed everything?

 

Sounds like the installation of the launcher is corrupted or something. Try reinstall it and do so after making sure the game itself launches on the latest patches.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users